summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin Yang <yangmame@icloud.com>2024-08-21 22:24:25 +0800
committerYixun Lan <dlan@gentoo.org>2024-08-23 08:00:47 +0000
commit3db2e6fb294e331348613851f4adae0beea5127d (patch)
tree4cb9d2278fa7a741f23af4e2636ee45e6fa2a949
parentsys-process/runit: update HOMEPAGE, SRC_URI (diff)
downloadgentoo-3db2e6fb294e331348613851f4adae0beea5127d.tar.gz
gentoo-3db2e6fb294e331348613851f4adae0beea5127d.tar.bz2
gentoo-3db2e6fb294e331348613851f4adae0beea5127d.zip
net-vpn/candy: new package, add 5.10.3
Closes: https://github.com/gentoo/gentoo/pull/38237 Signed-off-by: Xin Yang <yangmame@icloud.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--net-vpn/candy/Manifest1
-rw-r--r--net-vpn/candy/candy-5.10.3.ebuild42
-rw-r--r--net-vpn/candy/files/README.gentoo10
-rw-r--r--net-vpn/candy/metadata.xml23
4 files changed, 76 insertions, 0 deletions
diff --git a/net-vpn/candy/Manifest b/net-vpn/candy/Manifest
new file mode 100644
index 000000000000..5c32f1d0d2a1
--- /dev/null
+++ b/net-vpn/candy/Manifest
@@ -0,0 +1 @@
+DIST candy-5.10.3.gh.tar.gz 115258 BLAKE2B 70d698d69fbb0a28adeb1ba515a1a1f6986c083d3a04b688bfd5b7ead98941bac46af47cd745b74928fc56466ebe3fa7d570f7ecaa1716b2eac948d9eaf52fe2 SHA512 c56ab81f599c5fbf72c509265b3fc0189a17e36b8738e536f21702585e7994c706a277d8c1dbf8b68e7f3609518fec0b4daccc0b180d375463e898bb7d41bbdc
diff --git a/net-vpn/candy/candy-5.10.3.ebuild b/net-vpn/candy/candy-5.10.3.ebuild
new file mode 100644
index 000000000000..9460dccd05c1
--- /dev/null
+++ b/net-vpn/candy/candy-5.10.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake systemd readme.gentoo-r1
+
+DESCRIPTION="A reliable, low-latency, and anti-censorship virtual private network"
+HOMEPAGE="https://github.com/lanthora/candy"
+SRC_URI="https://github.com/lanthora/candy/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ dev-libs/poco
+ dev-libs/openssl
+ dev-libs/spdlog
+ dev-libs/libfmt
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_install(){
+ cmake_src_install
+ default
+
+ insinto /etc
+ doins candy.cfg
+
+ systemd_dounit candy.service
+ systemd_dounit candy@.service
+ newinitd candy.initd candy
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/net-vpn/candy/files/README.gentoo b/net-vpn/candy/files/README.gentoo
new file mode 100644
index 000000000000..810d833321b0
--- /dev/null
+++ b/net-vpn/candy/files/README.gentoo
@@ -0,0 +1,10 @@
+Notes:
+ Running candy with multi instances
+
+ 1) Using OpenRC
+ Prepare /etc/candy.d/${foo}.cfg first
+ # ln -s /etc/init.d/candy{,.${foo}}
+ # rc-update add candy.${foo} default
+
+ 2) Using Systemd
+ # systemctl enable candy@${foo}
diff --git a/net-vpn/candy/metadata.xml b/net-vpn/candy/metadata.xml
new file mode 100644
index 000000000000..997cf71315bb
--- /dev/null
+++ b/net-vpn/candy/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>yangmame@icloud.com</email>
+ <name>Xin Yang</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lanthora/candy</remote-id>
+ <maintainer>
+ <name>lanthora</name>
+ <email>lanthora@outlook.com</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>