summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-26 05:34:39 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-26 05:45:02 +0200
commit37dc9e560e44d4ddb2eb8335b4c717f1a9ab2530 (patch)
tree40c1a37981720c3285b9a036c053cc70e5cbad7e
parentx11-apps/viewres: Version bump to 1.0.6 (diff)
downloadgentoo-37dc9e560e44d4ddb2eb8335b4c717f1a9ab2530.tar.gz
gentoo-37dc9e560e44d4ddb2eb8335b4c717f1a9ab2530.tar.bz2
gentoo-37dc9e560e44d4ddb2eb8335b4c717f1a9ab2530.zip
xfce-extra/xfce4-screenshooter: Bump to 1.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-screenshooter/Manifest1
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.6.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-screenshooter/Manifest b/xfce-extra/xfce4-screenshooter/Manifest
index 256b938dc7e2..c7df8e269240 100644
--- a/xfce-extra/xfce4-screenshooter/Manifest
+++ b/xfce-extra/xfce4-screenshooter/Manifest
@@ -1 +1,2 @@
DIST xfce4-screenshooter-1.9.5.tar.bz2 502423 BLAKE2B b71dd5d016ff86ea5b654264dca129fd1b9316a0d0f2926a40556448c11a51992e4921c3ff9da952ac5e2962cf5baa18df8a110127cb68e89ee1b1cb2252bb7a SHA512 e5797a6defa4df94c552e8ff39b21f4203b6795669e8145ea5ef609fc7b29bcfa846b19b253b39b12ab0e6c130c7f9e67dd5aa628cefe9b063fb9f74dd2c3ee1
+DIST xfce4-screenshooter-1.9.6.tar.bz2 529233 BLAKE2B db314b3b451c3f560d8068932b21049f3e9587f8e329b1efb08e25227ab812c15b76a9d9a5bd3ffa1b4663ec81508f6cda2b6d31054b72d7487a111477962a62 SHA512 17d4afb346f09f97225c0fe65ed2389733e98d58729f15f7ec2b601682d7e15a6d9c67b85840593c17298fc32c250d8eb2e8d349ccd355507f4c18b5e312ae35
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.6.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.6.ebuild
new file mode 100644
index 000000000000..b65fb42de209
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16:=
+ >=net-libs/libsoup-2.26:=
+ >=x11-libs/gdk-pixbuf-2.16:=
+ >=x11-libs/gtk+-3.20:3=
+ dev-libs/libxml2:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXfixes:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-xfixes
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}