summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-05 05:08:38 +0100
committerSam James <sam@gentoo.org>2021-10-05 05:08:52 +0100
commit2c12ebe0782722ba274045eb033f457242664734 (patch)
treeca7518bef0be3f9c87a060623536cd840abbff2d
parentdev-libs/hiredis: add 1.0.1 (diff)
downloadgentoo-2c12ebe0782722ba274045eb033f457242664734.tar.gz
gentoo-2c12ebe0782722ba274045eb033f457242664734.tar.bz2
gentoo-2c12ebe0782722ba274045eb033f457242664734.zip
app-crypt/libmd: add 1.0.4
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-crypt/libmd/Manifest1
-rw-r--r--app-crypt/libmd/libmd-1.0.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-crypt/libmd/Manifest b/app-crypt/libmd/Manifest
index f3a9a3d4ff77..907624d3255f 100644
--- a/app-crypt/libmd/Manifest
+++ b/app-crypt/libmd/Manifest
@@ -1 +1,2 @@
DIST libmd-1.0.3.tar.xz 258584 BLAKE2B 35b732800a4b0a7b8d0a88eeff5e7e80fe55ab5ed05b7a7a1ffe866e156cc6dc6daca95f865a56297857b10b1bdfc9815b5bf0b198e8284f217498265c08fcc9 SHA512 f4b5a86bea7b9fac9f7f173032ee436d1e7141f760c1a114a785d31644edbf6802fe8193cc4cf3b5c66d38963be919c05055780bdf6bf5a47927690490ff5966
+DIST libmd-1.0.4.tar.xz 264472 BLAKE2B ddc2da74635f5cc009c66a58ae82b83e6e0930e18af8a6b0ecec7cbf378246707b493a99fb97d3491d0d626a0d5ef068baea6a3ba2ec311c5a1516ba5b4e2fd5 SHA512 731553ecc5e0e1eb228cced8fccd531fe31fb5c7627ca30013d287e1aeb8222959cf7498fbb7414bbabb967b25d4e8b0edd54fc47f6ccf55fc91087db0725ce3
diff --git a/app-crypt/libmd/libmd-1.0.4.ebuild b/app-crypt/libmd/libmd-1.0.4.ebuild
new file mode 100644
index 000000000000..f8676be74512
--- /dev/null
+++ b/app-crypt/libmd/libmd-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Message Digest functions from BSD systems"
+HOMEPAGE="https://www.hadrons.org/software/libmd/"
+SRC_URI="https://archive.hadrons.org/software/libmd/${P}.tar.xz"
+
+LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}