summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-02 08:46:59 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-02 09:20:58 +0200
commit2b2fb2d705356ae5c3371922c77bb50683709289 (patch)
treed37aa2abb7708dbb4d5f449670f72507e5a05dfa
parentdev-python/rpy: Resolve circular dependency (diff)
downloadgentoo-2b2fb2d705356ae5c3371922c77bb50683709289.tar.gz
gentoo-2b2fb2d705356ae5c3371922c77bb50683709289.tar.bz2
gentoo-2b2fb2d705356ae5c3371922c77bb50683709289.zip
dev-python/pytest-django: New package, ebuild written by me
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/metadata.xml9
-rw-r--r--dev-python/pytest-django/pytest-django-2.8.0.ebuild22
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
new file mode 100644
index 000000000000..1ef809c3cbaa
--- /dev/null
+++ b/dev-python/pytest-django/Manifest
@@ -0,0 +1 @@
+DIST pytest-django-2.8.0.tar.gz 15405 SHA256 d145ac9dc7a557a719ab79770be0941004e1e038e137c34591919d9df2a790b1 SHA512 bc692f1b3112e07f435db746328fea18b78e71fecbded26a4e68f7dbd9b84698d193a3d191d1039a3ff23e88d2dbf4beb0d08e382fbde333033b8b54fbe99dee WHIRLPOOL 1bc9b446a826bfa5c842dc40efb9f51a16dba1e9a3e5f2c1cc7afb6a34ffd69ed2a4a3be197fbf23bc7425773acb71bda4bcfebae6189f06fc95ac2219250d13
diff --git a/dev-python/pytest-django/metadata.xml b/dev-python/pytest-django/metadata.xml
new file mode 100644
index 000000000000..cdf82d15f553
--- /dev/null
+++ b/dev-python/pytest-django/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-django/pytest-django-2.8.0.ebuild b/dev-python/pytest-django/pytest-django-2.8.0.ebuild
new file mode 100644
index 000000000000..6380851f2a00
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-2.8.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-django https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"