summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-10-12 14:10:58 -0400
committerCraig Andrews <candrews@gentoo.org>2017-10-12 14:21:53 -0400
commit253b163f27eb4b087b79316b5c66f0f9236a5498 (patch)
tree27baab76c47073ad225a27d37b7c749773253ea3
parentapp-backup/btrbk: <=0.25.1 does not work with >=btrfs-progs-4.13.2 (diff)
downloadgentoo-253b163f27eb4b087b79316b5c66f0f9236a5498.tar.gz
gentoo-253b163f27eb4b087b79316b5c66f0f9236a5498.tar.bz2
gentoo-253b163f27eb4b087b79316b5c66f0f9236a5498.zip
app-backup/btrbk: Bump to 0.26.0
Closes: https://github.com/gentoo/gentoo/pull/5929 Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--app-backup/btrbk/Manifest1
-rw-r--r--app-backup/btrbk/btrbk-0.26.0.ebuild45
-rw-r--r--app-backup/btrbk/btrbk-9999.ebuild19
3 files changed, 62 insertions, 3 deletions
diff --git a/app-backup/btrbk/Manifest b/app-backup/btrbk/Manifest
index eb62507f4f64..ae497cbf3c51 100644
--- a/app-backup/btrbk/Manifest
+++ b/app-backup/btrbk/Manifest
@@ -1,2 +1,3 @@
DIST btrbk-0.24.0.tar.xz 72308 SHA256 032671c2905005d91a87b85acf8daec05df09bfad9e191092610094fb9a65906 SHA512 fbe180743743ead1241968765b5ae6eff37b2925bee8379443568c126426f2098d280a3f62d13e5f5b63f967ac9889ad9331d73f354d0cd441c907ba92258267 WHIRLPOOL 19052093dcec40d4a8bd5593538f6ec44ea2bbaf6a846f966cebb1f1ff76b9c94700a0bad6f16f33258f92fa05180efc2ba770f02db5553e755beb21b6761ed9
DIST btrbk-0.25.1.tar.xz 74904 SHA256 25bbfe9352b833761c2ec929d744faa2b33670dac0dc00b6e51ed0d2d64e0c0b SHA512 6802e379f49c5433a811f6f844cf2663c752b23d8d678f001bb8cba9b099c7527983e23169814c7469ab8682b95fa0f742d1088415747ebebfe0fcc36425cd05 WHIRLPOOL 05850216548c01d86b0ec508e11d8085dec597b41bad491cbf65aa9f41432a09b2a0f79ec821bf16c0e7f24271bcb4cce1f9b52352d7d6cd67ef2ac9850a19e0
+DIST btrbk-0.26.0.tar.xz 82472 SHA256 608c49fa0cdb204d8ef818924d49f520a68a80557bfc8cf6902135377a8136af SHA512 a08ec4e2e0d164b9a9a17b3d4b8417eb3890994c8aa2233ecda9d616659fce917311a94fdfd6762acacb40dc25a60fe8f6880703c980ccd4a176b14e24a2bb00 WHIRLPOOL 183d9f91b9c310921ca2a1e7c6c05946a6b0db0885ff1013d81355170c019d7090fb91a400d62fc1ab3f2ca27fd1f2cf04c4794a88d85684fbbe1d6e8a6cdf67
diff --git a/app-backup/btrbk/btrbk-0.26.0.ebuild b/app-backup/btrbk/btrbk-0.26.0.ebuild
new file mode 100644
index 000000000000..8588eb6d0e34
--- /dev/null
+++ b/app-backup/btrbk/btrbk-0.26.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://dev.tty0.ch/btrbk.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
+HOMEPAGE="https://digint.ch/btrbk/"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+pv"
+
+DEPEND=">=app-text/asciidoc-8.6.0
+ app-text/xmlto"
+
+RDEPEND="dev-lang/perl
+ net-misc/openssh
+ pv? ( sys-apps/pv )
+ >=sys-fs/btrfs-progs-3.18.2"
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
+}
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
+ upgrade_0_26_0_warning="1"
+ fi
+}
+pkg_postinst() {
+ if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
+ ewarn "If you are using raw targets, make sure to run the"
+ ewarn "\"raw_suffix2sidecar\" utility in each target directory."
+ fi
+}
diff --git a/app-backup/btrbk/btrbk-9999.ebuild b/app-backup/btrbk/btrbk-9999.ebuild
index 8718b6220261..8588eb6d0e34 100644
--- a/app-backup/btrbk/btrbk-9999.ebuild
+++ b/app-backup/btrbk/btrbk-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ if [[ ${PV} == "9999" ]] ; then
KEYWORDS=""
else
SRC_URI="https://digint.ch/download/btrbk/releases/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm ~x86"
fi
DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
@@ -21,7 +21,9 @@ LICENSE="GPL-3+"
SLOT="0"
IUSE="+pv"
-DEPEND=""
+DEPEND=">=app-text/asciidoc-8.6.0
+ app-text/xmlto"
+
RDEPEND="dev-lang/perl
net-misc/openssh
pv? ( sys-apps/pv )
@@ -30,3 +32,14 @@ RDEPEND="dev-lang/perl
src_install() {
emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
}
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-0.26.0" ; then
+ upgrade_0_26_0_warning="1"
+ fi
+}
+pkg_postinst() {
+ if [[ "${upgrade_0_26_0_warning}" == "1" ]]; then
+ ewarn "If you are using raw targets, make sure to run the"
+ ewarn "\"raw_suffix2sidecar\" utility in each target directory."
+ fi
+}