summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-02 14:31:12 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-02 14:38:52 +0300
commit21acf2b4353e5e3ffac4be39be7762437e55813c (patch)
tree2681732c78964e0d0da7679209a184fe46880208
parentdev-python/pocketlint: add 0.23, PEP517 (diff)
downloadgentoo-21acf2b4353e5e3ffac4be39be7762437e55813c.tar.gz
gentoo-21acf2b4353e5e3ffac4be39be7762437e55813c.tar.bz2
gentoo-21acf2b4353e5e3ffac4be39be7762437e55813c.zip
dev-python/sphinx-tabs: add 3.4.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sphinx-tabs/Manifest1
-rw-r--r--dev-python/sphinx-tabs/sphinx-tabs-3.4.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/sphinx-tabs/Manifest b/dev-python/sphinx-tabs/Manifest
index 713f4d5bca94..45e78f2419ff 100644
--- a/dev-python/sphinx-tabs/Manifest
+++ b/dev-python/sphinx-tabs/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-tabs-3.3.1.tar.gz 523932 BLAKE2B 8b941eb549ea8a10fcd329e880b8fa15742ba7903f4f9d6422335cf889c344a1fec8f16798c286b0c0f7561c128ea297153c31d0445b867e5e23f7960698d31a SHA512 d93ba1149a20711b52f8a76f22d212fdbb97349561f3e13b53873cdb4dba8f18f645e2d73ef378c2dde3d1c0c585c1402d73f4102da0e973be0c90a5912e7036
DIST sphinx-tabs-3.4.0.gh.tar.gz 524212 BLAKE2B 18688d10d37e5794340ccfc5d798a31bf80374ed74e64dcb54ae53dc557d7538de39b4e29002d16735cab5ed4618189af54da2682dce195c503af442f554fef7 SHA512 2833586c7040e454cac65963a3dfb22ac7e09b0a4cd5cba9ea449d798a5d7120ce3d19ac0a9d638a9389d52773bd98ab4bde33d06924170757036ff3218f6d55
+DIST sphinx-tabs-3.4.1.gh.tar.gz 524071 BLAKE2B 5aecb9c22a298c1347bf82cbbc16709f3f6cd38b0f0f6e4948411f1fdd79ba17d3e75178b8c092df7b8abc812dd4b0102879774708552a062aad0fe0b0653717 SHA512 b6079d3ae91479d40aaf35926226eb7dd783de7cec0e721cb13a036fc520bb3afda0dffb0669dc5054fc665125c3620261b1ea7ffe685d5b177bc980e3b4d7e4
diff --git a/dev-python/sphinx-tabs/sphinx-tabs-3.4.1.ebuild b/dev-python/sphinx-tabs/sphinx-tabs-3.4.1.ebuild
new file mode 100644
index 000000000000..c69664385e9c
--- /dev/null
+++ b/dev-python/sphinx-tabs/sphinx-tabs-3.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tabbed views for Sphinx"
+HOMEPAGE="
+ https://github.com/executablebooks/sphinx-tabs/
+ https://pypi.org/project/sphinx-tabs/
+"
+SRC_URI="
+ https://github.com/executablebooks/sphinx-tabs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # Unpackaged rinohtype
+ tests/test_build.py::test_rinohtype_pdf
+)
+
+src_prepare() {
+ # annoying, incorrect version limitations
+ sed -i -e '/install_requires/d' setup.py || die
+
+ # fix tests for >=sphinx-5
+ sed -e 's/\(Permalink to this\) heading/\1 headline/g' \
+ -i tests/test_build/test_*.html || die
+
+ distutils-r1_src_prepare
+}