summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-09-08 23:33:32 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-14 20:56:24 +0300
commit20c8368cf286bde437ea7d8f5fd7d2b9269ac7b5 (patch)
tree92958bd2a0da41da469f71e477e27d53b4fc1f30
parentmedia-gfx/pqiv: add 2.12 (diff)
downloadgentoo-20c8368cf286bde437ea7d8f5fd7d2b9269ac7b5.tar.gz
gentoo-20c8368cf286bde437ea7d8f5fd7d2b9269ac7b5.tar.bz2
gentoo-20c8368cf286bde437ea7d8f5fd7d2b9269ac7b5.zip
media-gfx/pqiv: drop 9999
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32694 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--media-gfx/pqiv/pqiv-9999.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/media-gfx/pqiv/pqiv-9999.ebuild b/media-gfx/pqiv/pqiv-9999.ebuild
deleted file mode 100644
index 65bba986493e..000000000000
--- a/media-gfx/pqiv/pqiv-9999.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit linux-info toolchain-funcs xdg-utils
-
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://github.com/phillipberndt/pqiv.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="powerful GTK 3 based command-line image viewer with a minimal UI"
-HOMEPAGE="https://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="archive ffmpeg imagemagick pdf postscript webp"
-
-RDEPEND="
- >=dev-libs/glib-2.32:2
- >=x11-libs/cairo-1.6
- x11-libs/gtk+:3
- archive? ( app-arch/libarchive:0= )
- ffmpeg? ( media-video/ffmpeg:0= )
- imagemagick? ( media-gfx/imagemagick:0= )
- pdf? ( app-text/poppler:0= )
- postscript? ( app-text/libspectre:0= )
- webp? ( media-libs/libwebp:0= )
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-doecho() {
- echo "$@"
- "$@" || die
-}
-
-pkg_setup() {
- if use kernel_linux; then
- CONFIG_CHECK="~INOTIFY_USER"
- linux-info_pkg_setup
- fi
-}
-
-src_configure() {
- local backends="gdkpixbuf"
- use archive && backends+=",archive,archive_cbx"
- use ffmpeg && backends+=",libav"
- use imagemagick && backends+=",wand"
- use pdf && backends+=",poppler"
- use postscript && backends+=",spectre"
- use webp && backends+=",webp"
-
- doecho ./configure \
- --backends-build=shared \
- --backends=${backends} \
- --prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
- --destdir="${ED}"
-}
-
-src_compile() {
- tc-export CC
- emake VERBOSE=1 CFLAGS="${CFLAGS}"
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}