summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-12-06 20:46:43 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-12-06 20:46:43 +0000
commit1f50a9f0f8b764286757365840d9ba20198efe09 (patch)
treeea650c34282679245939ec33136fc3177a0a0c82
parent2022-12-06 20:31:49 UTC (diff)
parentsys-process/at: allow app-alternatives/lex, app-alternatives/yacc (diff)
downloadgentoo-1f50a9f0f8b764286757365840d9ba20198efe09.tar.gz
gentoo-1f50a9f0f8b764286757365840d9ba20198efe09.tar.bz2
gentoo-1f50a9f0f8b764286757365840d9ba20198efe09.zip
Merge updates from master
-rw-r--r--app-editors/vile/Manifest1
-rw-r--r--app-editors/vile/vile-9.8w-r1.ebuild58
-rw-r--r--app-editors/xvile/Manifest1
-rw-r--r--app-editors/xvile/metadata.xml1
-rw-r--r--app-editors/xvile/xvile-9.8w-r2.ebuild61
-rw-r--r--app-text/xmlto/xmlto-0.0.28-r10.ebuild56
-rw-r--r--dev-util/cproto/cproto-4.7u-r1.ebuild (renamed from dev-util/cproto/cproto-4.7u.ebuild)7
-rw-r--r--sys-devel/autoconf-dickey/metadata.xml1
-rw-r--r--sys-process/at/at-3.2.5-r1.ebuild98
9 files changed, 281 insertions, 3 deletions
diff --git a/app-editors/vile/Manifest b/app-editors/vile/Manifest
index 00935df1403b..4e1addb900e6 100644
--- a/app-editors/vile/Manifest
+++ b/app-editors/vile/Manifest
@@ -1,3 +1,4 @@
DIST vile-9.8t.tgz 2352119 BLAKE2B fc1c75eba09e8be99945ba0d178fd150576d8108f906afb20dba265adaee9e5bea4869415d3ebceabf0b6b56c147add79e9c7e4fe34d7f4744930c3728e4a4a4 SHA512 4be4e37c7231395cae9236796073c2c3e428f1945283785a931c5d4cce94e0f970efa6634b0f9053679a00f4b4577704ea38ded2129e444b26ee9935a1c3d229
DIST vile-9.8v.tgz 2405398 BLAKE2B cd8753c57ff95c9b420026128fd19b7c689c99500da7cae91d3160dded46aa101b0cae32daeaf0377d4d72a5e526e8e4f25422bbbff2cc5ecdef10b7f04c8b39 SHA512 b752f26148bd4411ab6b31697459a16d8168f79ffad6b3509d6cf5d40611176b833e56f4bac21fe18ecdd256be467ba96ea98149daceab671002df49508eb8d2
DIST vile-9.8w.tgz 2407322 BLAKE2B 824142c2d081db7c74ab4ce36db63e2d26e82954b32d274477f920b3519c75a249745365f7fb4f117f613c04fddd468394b4636d5f84d9f024eee3cb9c8332ba SHA512 54a96b400f479c633b917691fdab5ec5098ff1d6a6f5390c085635b4449ee7f02988e52c6b442918917455d02d5d74781ed57e4f944422576cf6532caaa446af
+DIST vile-9.8w.tgz.asc 729 BLAKE2B 24ee3733957239b808566cf1c46cd45089ab0e9cd980fc477190beca79a85e6d31925c8eb02138442e4776b7ee678aec9d522d4bb3a8d72670e0720ab9369a5c SHA512 143eaa6ea64cf1d8dc078aba197544a036858f91a15f2f8c4254095f7cdc725b1720cf600afcd3ba67cf0c0414cefb0a058a5730d1a70906fe3591ddc46fb916
diff --git a/app-editors/vile/vile-9.8w-r1.ebuild b/app-editors/vile/vile-9.8w-r1.ebuild
new file mode 100644
index 000000000000..91e20371b305
--- /dev/null
+++ b/app-editors/vile/vile-9.8w-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with app-editors/xvile
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="https://invisible-island.net/vile/"
+SRC_URI="https://invisible-island.net/archives/vile/current/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/vile/current/${P}.tgz.asc )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl iconv"
+
+RDEPEND=">=sys-libs/ncurses-5.2:=
+ virtual/libcrypt:=
+ iconv? ( virtual/libiconv )
+ perl? ( dev-lang/perl:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/lex
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+IDEPEND="app-eselect/eselect-vi"
+
+src_configure() {
+ econf \
+ --disable-stripping \
+ --with-ncurses \
+ --with-pkg-config \
+ $(use_with iconv) \
+ $(use_with perl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc CHANGES* README doc/*.doc
+ docinto html
+ dodoc doc/*.html
+}
+
+pkg_postinst() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating ${EPREFIX}/usr/bin/vi symlink"
+ eselect vi update --if-unset
+}
diff --git a/app-editors/xvile/Manifest b/app-editors/xvile/Manifest
index 00935df1403b..4e1addb900e6 100644
--- a/app-editors/xvile/Manifest
+++ b/app-editors/xvile/Manifest
@@ -1,3 +1,4 @@
DIST vile-9.8t.tgz 2352119 BLAKE2B fc1c75eba09e8be99945ba0d178fd150576d8108f906afb20dba265adaee9e5bea4869415d3ebceabf0b6b56c147add79e9c7e4fe34d7f4744930c3728e4a4a4 SHA512 4be4e37c7231395cae9236796073c2c3e428f1945283785a931c5d4cce94e0f970efa6634b0f9053679a00f4b4577704ea38ded2129e444b26ee9935a1c3d229
DIST vile-9.8v.tgz 2405398 BLAKE2B cd8753c57ff95c9b420026128fd19b7c689c99500da7cae91d3160dded46aa101b0cae32daeaf0377d4d72a5e526e8e4f25422bbbff2cc5ecdef10b7f04c8b39 SHA512 b752f26148bd4411ab6b31697459a16d8168f79ffad6b3509d6cf5d40611176b833e56f4bac21fe18ecdd256be467ba96ea98149daceab671002df49508eb8d2
DIST vile-9.8w.tgz 2407322 BLAKE2B 824142c2d081db7c74ab4ce36db63e2d26e82954b32d274477f920b3519c75a249745365f7fb4f117f613c04fddd468394b4636d5f84d9f024eee3cb9c8332ba SHA512 54a96b400f479c633b917691fdab5ec5098ff1d6a6f5390c085635b4449ee7f02988e52c6b442918917455d02d5d74781ed57e4f944422576cf6532caaa446af
+DIST vile-9.8w.tgz.asc 729 BLAKE2B 24ee3733957239b808566cf1c46cd45089ab0e9cd980fc477190beca79a85e6d31925c8eb02138442e4776b7ee678aec9d522d4bb3a8d72670e0720ab9369a5c SHA512 143eaa6ea64cf1d8dc078aba197544a036858f91a15f2f8c4254095f7cdc725b1720cf600afcd3ba67cf0c0414cefb0a058a5730d1a70906fe3591ddc46fb916
diff --git a/app-editors/xvile/metadata.xml b/app-editors/xvile/metadata.xml
index 5156eb857fef..d110c3ebb42b 100644
--- a/app-editors/xvile/metadata.xml
+++ b/app-editors/xvile/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<changelog>https://invisible-island.net/vile/CHANGES.html</changelog>
+ <remote-id type="github">ThomasDickey/vile-snapshots</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-editors/xvile/xvile-9.8w-r2.ebuild b/app-editors/xvile/xvile-9.8w-r2.ebuild
new file mode 100644
index 000000000000..2c2ed794f608
--- /dev/null
+++ b/app-editors/xvile/xvile-9.8w-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with app-editors/vile
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+MY_P="${PN/x/}-${PV}"
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="https://invisible-island.net/vile/"
+SRC_URI="https://invisible-island.net/archives/vile/current/${MY_P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/vile/current/${MY_P}.tgz.asc )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~riscv ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND="
+ ~app-editors/vile-${PV}
+ virtual/libcrypt:=
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0
+ >=x11-libs/libXaw-1.0.1
+ >=x11-libs/libXpm-3.5.4.2
+ perl? ( dev-lang/perl:= )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ app-alternatives/lex
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+
+PATCHES=( "${FILESDIR}/${P}"-fix-build-for-clang16.patch )
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ econf \
+ --disable-stripping \
+ --with-ncurses \
+ --with-pkg-config \
+ --with-x \
+ $(use_with perl)
+}
+
+src_install() {
+ dobin xvile
+ dodoc CHANGES* README doc/*.doc
+ docinto html
+ dodoc doc/*.html
+}
diff --git a/app-text/xmlto/xmlto-0.0.28-r10.ebuild b/app-text/xmlto/xmlto-0.0.28-r10.ebuild
new file mode 100644
index 000000000000..362c6a9539c2
--- /dev/null
+++ b/app-text/xmlto/xmlto-0.0.28-r10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Script for converting XML and DocBook documents to a variety of output formats"
+HOMEPAGE="https://pagure.io/xmlto"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="latex text"
+
+RDEPEND="
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ || ( sys-apps/util-linux app-misc/getopt )
+ text? ( || ( virtual/w3m www-client/elinks www-client/links www-client/lynx ) )
+ latex? ( dev-texlive/texlive-formatsextra )
+"
+DEPEND="${RDEPEND}"
+# We only depend on lex when we patch the input lexer.
+# We touch it in fix-warnings.patch.
+BDEPEND="app-alternatives/lex"
+
+DOCS=( AUTHORS ChangeLog FAQ NEWS README THANKS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch
+ "${FILESDIR}"/${PN}-0.0.28-allow-links.patch
+ "${FILESDIR}"/${P}-dont-hardcode-paths.patch
+ "${FILESDIR}"/${P}-fix-warnings.patch
+)
+
+src_prepare() {
+ default
+
+ # fix symbol clash on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/\(attrib\|val\)/XMLTO\1/g' xmlif/xmlif.l || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ # We don't want the script to detect /bin/sh if it is bash.
+ export ac_cv_path_BASH="${BASH}"
+ has_version sys-apps/util-linux || export GETOPT=getopt-long
+
+ econf
+}
diff --git a/dev-util/cproto/cproto-4.7u.ebuild b/dev-util/cproto/cproto-4.7u-r1.ebuild
index 065167dec606..30f8f696e3d9 100644
--- a/dev-util/cproto/cproto-4.7u.ebuild
+++ b/dev-util/cproto/cproto-4.7u-r1.ebuild
@@ -15,8 +15,9 @@ LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-DEPEND="
- sys-devel/flex
+DEPEND="app-alternatives/lex"
+BDEPEND="
+ app-alternatives/lex
app-alternatives/yacc
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
"
-BDEPEND="verify-sig? ( sec-keys/openpgp-keys-thomasdickey )"
diff --git a/sys-devel/autoconf-dickey/metadata.xml b/sys-devel/autoconf-dickey/metadata.xml
index d4fcaf15067d..af5286fc415a 100644
--- a/sys-devel/autoconf-dickey/metadata.xml
+++ b/sys-devel/autoconf-dickey/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Base System</name>
</maintainer>
<upstream>
+ <changelog>https://invisible-island.net/autoconf/autoconf-252/ChangeLog</changelog>
<remote-id type="github">ThomasDickey/my-autoconf-snapshots</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sys-process/at/at-3.2.5-r1.ebuild b/sys-process/at/at-3.2.5-r1.ebuild
new file mode 100644
index 000000000000..c04c4703b4cf
--- /dev/null
+++ b/sys-process/at/at-3.2.5-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools pam systemd
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://blog.calhariz.com/index.php/tag/at https://packages.qa.debian.org/a/at.html"
+SRC_URI="http://software.calhariz.com/at/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/a/at/${MY_P}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="pam selinux"
+
+DEPEND="
+ acct-group/at
+ acct-user/at
+ virtual/mta
+ pam? ( sys-libs/pam )
+ selinux? ( sys-libs/libselinux )
+"
+RDEPEND="${DEPEND}
+ virtual/mta
+ virtual/logger
+ selinux? ( sec-policy/selinux-at )
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ "${FILESDIR}"/${PN}-3.1.14-Makefile.patch
+ # fix parallel make issues, bug #244884
+ "${FILESDIR}"/${PN}-3.1.10.2-Makefile.in-parallel-make-fix.patch
+ "${FILESDIR}"/${PN}-3.1.13-configure.in-fix-PAM-automagick-dep.patch
+ # Fix parallel make issue (bug #408375)
+ "${FILESDIR}"/${PN}-3.1.13-parallel-make-fix.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sysconfdir="${EPREFIX}"/etc/at
+ --with-jobdir="${EPREFIX}"/var/spool/at/atjobs
+ --with-atspool="${EPREFIX}"/var/spool/at/atspool
+ --with-etcdir="${EPREFIX}"/etc/at
+ --with-daemon_username=at
+ --with-daemon_groupname=at
+ $(usex pam '' --without-pam)
+ $(use_with selinux)
+ )
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/atd.rc9 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+
+ if use pam ; then
+ newpamd "${FILESDIR}"/at.pamd-3.1.13-r1 atd
+ fi
+
+ systemd_dounit "${FILESDIR}/atd.service"
+ keepdir /var/spool/at/atspool
+}
+
+pkg_preinst() {
+ # Preserve existing .SEQ files (bug #386625)
+ local seq_file="${EROOT}/var/spool/at/atjobs/.SEQ"
+ if [[ -f "${seq_file}" ]] ; then
+ einfo "Preserving existing .SEQ file (bug #386625)."
+ cp -p "${seq_file}" "${ED}"/var/spool/at/atjobs/ || die
+ fi
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ local atspooldir="${EROOT}/var/spool/at"
+ chown at:at "${atspooldir}/atjobs"
+ chmod 1770 "${atspooldir}/atjobs"
+ chown at:at "${atspooldir}/atjobs/.SEQ"
+ chmod 0600 "${atspooldir}/atjobs/.SEQ"
+ chown at:at "${atspooldir}/atspool"
+ chmod 1770 "${atspooldir}/atspool"
+}