summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-12 16:02:56 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-12 16:02:56 -0400
commit1e41c8a67c618b551d3812c11e0f4a905692e3a4 (patch)
tree972d4ec4457c85a2bc72d5a63381757a77921d37
parentgames-strategy/endless-sky: drop 0.9.16.1 (diff)
downloadgentoo-1e41c8a67c618b551d3812c11e0f4a905692e3a4.tar.gz
gentoo-1e41c8a67c618b551d3812c11e0f4a905692e3a4.tar.bz2
gentoo-1e41c8a67c618b551d3812c11e0f4a905692e3a4.zip
games-strategy/freeorion: drop 0.5
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-strategy/freeorion/Manifest1
-rw-r--r--games-strategy/freeorion/files/freeorion-0.5-ccache.patch18
-rw-r--r--games-strategy/freeorion/freeorion-0.5.ebuild123
3 files changed, 0 insertions, 142 deletions
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
index 855ea24f8f6f..25410153d695 100644
--- a/games-strategy/freeorion/Manifest
+++ b/games-strategy/freeorion/Manifest
@@ -1,2 +1 @@
DIST FreeOrion_v0.5.0.1_Source.tar.gz 152861158 BLAKE2B 6924d4916fcd3ac93e7498b5247957a6fb62b8523aa49114e9e11ef5e3b89374966551bc14192fa7928951728ce814fb86d89365beb97aa7c2bc84408bfcadd2 SHA512 dc267231329f0615f12887f22139d57a2611f378e17e8b0f26c00efdb77e73ef737ff875350f805d34a07ca4ce0595758e4f61168878477ebbd92d0149bcdc22
-DIST FreeOrion_v0.5_Source.tar.gz 152861207 BLAKE2B 5263f9c2461db35b5283122889d0779f175af095e90eb782d21b6870193669b0307c2df95ebde78b3f762d2d0e1e1d8ec5f537bd44bf6810b9fbf76c58322172 SHA512 ec1247584d317ca0d0394d62754fd35b1d1212323e96e644c9efae422437daf63aac12c2798274993c9c29887fe73a51bfe11e9b53370dc261a0683efe312f19
diff --git a/games-strategy/freeorion/files/freeorion-0.5-ccache.patch b/games-strategy/freeorion/files/freeorion-0.5-ccache.patch
deleted file mode 100644
index dc289fa84ec9..000000000000
--- a/games-strategy/freeorion/files/freeorion-0.5-ccache.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -30,7 +30,6 @@ ENDIF(NOT CMAKE_BUILD_TYPE)
- message(STATUS "Build type CMAKE_BUILD_TYPE set to ${CMAKE_BUILD_TYPE}")
-
- include(UseCompilerCache)
--find_compiler_cache(PROGRAM ccache)
-
- list(APPEND GODOT_CPP_CMAKE_VARS "CMAKE_BUILD_TYPE;CMAKE_CONFIGURATION_TYPES;CMAKE_TOOLCHAIN_FILE;PYTHON_EXECUTABLE")
- get_cmake_property(vars CACHE_VARIABLES)
-@@ -50,7 +49,6 @@ endforeach()
-
- project(FreeOrion)
-
--use_compiler_cache_with_xcode()
-
- include(GNUInstallDirs)
- include(UseCodeCoverage)
diff --git a/games-strategy/freeorion/freeorion-0.5.ebuild b/games-strategy/freeorion/freeorion-0.5.ebuild
deleted file mode 100644
index 7bf2bf981654..000000000000
--- a/games-strategy/freeorion/freeorion-0.5.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit check-reqs cmake multiprocessing python-single-r1 xdg
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/freeorion/freeorion.git"
-else
- SRC_URI="https://github.com/freeorion/freeorion/releases/download/v${PV}/FreeOrion_v${PV}_Source.tar.gz"
- S="${WORKDIR}/src-tarball"
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Free turn-based space empire and galactic conquest game"
-HOMEPAGE="https://www.freeorion.org/"
-
-LICENSE="GPL-2+ CC-BY-SA-3.0 LGPL-2.1+"
-SLOT="0"
-IUSE="+client doc test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-libs/boost:=[${PYTHON_USEDEP},nls,python]')
- sys-libs/zlib:=
- client? (
- media-libs/freetype
- media-libs/glew:=
- media-libs/libglvnd
- media-libs/libogg
- media-libs/libpng:=
- media-libs/libsdl2[opengl,video]
- media-libs/libvorbis
- media-libs/openal
- )"
-RDEPEND="
- ${DEPEND}
- client? (
- media-fonts/dejavu
- media-fonts/roboto
- )"
-BDEPEND="
- ${PYTHON_DEPS}
- doc? (
- app-text/doxygen
- media-gfx/graphviz
- )
- test? (
- $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
- )"
-
-PATCHES=(
- "${FILESDIR}/freeorion-0.5-ccache.patch"
-)
-
-freeorion_check-reqs() {
- # cc1plus processes may suddenly use ~1.5GB all at once early on (2+GB
- # if debug symbols) then far less for the rest, check minimal jobs*1.5
- local CHECKREQS_MEMORY=$(($(makeopts_jobs)*1500))M
- check-reqs_${EBUILD_PHASE_FUNC}
-}
-
-pkg_pretend() {
- freeorion_check-reqs
-}
-
-pkg_setup() {
- freeorion_check-reqs
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
-
- sed -i 's/-O3//' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_CLIENT_GG=$(usex client)
- -DBUILD_CLIENT_GODOT=no # TODO, perhaps with system godot (experimental)
- -DBUILD_TESTING=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile all $(usev doc)
-}
-
-src_test() {
- cmake_src_test -j1 # avoid running 2 conflicting servers
-
- local EPYTEST_DESELECT=(
- # broken with 3.11 but is not known to cause issues, just skip for now
- tests/AI/save_game_codec/test_savegame_manager.py::test_setstate_call
- )
-
- epytest -o cache_dir="${T}"/pytest_cache default/python/tests
-}
-
-src_install() {
- local DOCS=( ChangeLog.md README.md )
- cmake_src_install
-
- use doc && dodoc -r "${BUILD_DIR}"/doc/cpp-apidoc/html
-
- if use client; then
- local font
- for font in roboto/Roboto-{Bold,Regular}.ttf dejavu/DejaVuSans{-Bold,}.ttf; do
- dosym -r /usr/share/{fonts/${font%/*},${PN}/default/data/fonts}/${font##*/}
- done
- rm "${ED}"/usr/share/${PN}/default/data/fonts/LICENSE.{Roboto,DejaVu} || die
- else
- rm -r "${ED}"/usr/share/freeorion/default/data/fonts || die
- fi
-}