summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:48 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:54 +0100
commit1b838ce8f3ee3d7a6370d7eeef1c12b066f059d6 (patch)
treef6e5279163756f43d5ea779abde8d011cadd0548
parentdev-haskell/mmorph: add 1.2.0 (diff)
downloadgentoo-1b838ce8f3ee3d7a6370d7eeef1c12b066f059d6.tar.gz
gentoo-1b838ce8f3ee3d7a6370d7eeef1c12b066f059d6.tar.bz2
gentoo-1b838ce8f3ee3d7a6370d7eeef1c12b066f059d6.zip
dev-haskell/monad-control: add 1.0.3.1
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/monad-control/Manifest1
-rw-r--r--dev-haskell/monad-control/metadata.xml25
-rw-r--r--dev-haskell/monad-control/monad-control-1.0.3.1.ebuild26
3 files changed, 27 insertions, 25 deletions
diff --git a/dev-haskell/monad-control/Manifest b/dev-haskell/monad-control/Manifest
index a0198bdba132..c1bad6539efd 100644
--- a/dev-haskell/monad-control/Manifest
+++ b/dev-haskell/monad-control/Manifest
@@ -1 +1,2 @@
DIST monad-control-1.0.2.3.tar.gz 13864 BLAKE2B c150338e8a585dc045fd23404719fe61a2367f7308e15344f81549fd7f0808ef8fa2238a35b0a7c7984d26885352186bd6bf43359dec68b2df93581b021dd794 SHA512 59837326ec9f25220cb6c7329c91a5806b0ec7412d6af24c0f0d52c4fd93b084e92edd4f5f61a4f9c4248034fa540c23b65d2aacdfca737ece98bb132b8f08d4
+DIST monad-control-1.0.3.1.tar.gz 13985 BLAKE2B b7dbf0b579ca114190cfe6a5400950d20825f7455a4924154e8416dd475eafa81310c397f3283e5d77ac70e158caf46f34fe5214b989ae2bd051de1968cde704 SHA512 b82ac2d3b2ab1892f79bab1341c9ff17ea89b988438cfd40c246f5ffe4560cb2b77e4a1ed1aa9dc2bb64644b9d6da76eda7b40acf8cc34bb03e77b18127e93a1
diff --git a/dev-haskell/monad-control/metadata.xml b/dev-haskell/monad-control/metadata.xml
index 8124363ca0a0..937381521944 100644
--- a/dev-haskell/monad-control/metadata.xml
+++ b/dev-haskell/monad-control/metadata.xml
@@ -5,29 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This package defines the type class @MonadControlIO@, a subset of
- @MonadIO@ into which generic control operations such as @catch@ can
- be lifted from @IO@. Instances are based on monad transformers in
- @MonadTransControl@, which includes all standard monad transformers
- in the @transformers@ library except @ContT@. For convenience, it
- provides a wrapped version of @Control.Exception@ with types
- generalized from @IO@ to all monads in @MonadControlIO@.
-
- Note that this package is a rewrite of Anders Kaseorg's @monad-peel@ library.
- The main difference is that this package provides CPS style
- operators and exploits the @RankNTypes@ language extension to
- simplify most definitions.
-
- The package includes a copy of the @monad-peel@ testsuite written by Anders Kaseorg.
- The tests can be performed by using @cabal test@.
-
- The following @critertion@ based benchmark shows that @monad-control@
- is on average about 2.5 times faster than @monad-peel@:
-
- &lt;https://github.com/basvandijk/bench-monad-peel-control&gt;
- </longdescription>
- <upstream>
- <remote-id type="github">basvandijk/monad-control</remote-id>
- </upstream>
</pkgmetadata>
diff --git a/dev-haskell/monad-control/monad-control-1.0.3.1.ebuild b/dev-haskell/monad-control/monad-control-1.0.3.1.ebuild
new file mode 100644
index 000000000000..096011c07e8b
--- /dev/null
+++ b/dev-haskell/monad-control/monad-control-1.0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Lift control operations, like exception catching, through monad transformers"
+HOMEPAGE="https://github.com/basvandijk/monad-control"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+
+RDEPEND=">=dev-haskell/stm-2.3:=[profile?] <dev-haskell/stm-3:=[profile?]
+ >=dev-haskell/transformers-base-0.4.4:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-0.8:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"