summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-24 12:46:31 +0100
committerSam James <sam@gentoo.org>2022-10-24 12:46:31 +0100
commit1b124e8c6ecdfeb13a717ef0aadc87108b335a8a (patch)
treedb36cd69aa45b66d789aecfbfdb4b9ab7467dbde
parentnet-libs/libtorrent-rasterbar: drop 1.2.17 (diff)
downloadgentoo-1b124e8c6ecdfeb13a717ef0aadc87108b335a8a.tar.gz
gentoo-1b124e8c6ecdfeb13a717ef0aadc87108b335a8a.tar.bz2
gentoo-1b124e8c6ecdfeb13a717ef0aadc87108b335a8a.zip
net-libs/libtorrent-rasterbar: drop 1.2.16
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-libs/libtorrent-rasterbar/Manifest1
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.16.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/net-libs/libtorrent-rasterbar/Manifest b/net-libs/libtorrent-rasterbar/Manifest
index dac213fad2cd..fa7954814192 100644
--- a/net-libs/libtorrent-rasterbar/Manifest
+++ b/net-libs/libtorrent-rasterbar/Manifest
@@ -1,4 +1,3 @@
-DIST libtorrent-rasterbar-1.2.16.tar.gz 4163867 BLAKE2B 2cb4c79d83854bf3e5fc1b2ff9a361539b7690d0df3c2c15f2df1c7b9e782df51fbab57920a3bac56dff872c829a49303d66d33cdc10586ccc01dad3e83b149c SHA512 2bad1bf1604f99b85567056f798bfb78cdd663612291536d1145141e61f843aced416f7608911793c948d77802ef5b3088197b914c100a4278c94033eb304d4b
DIST libtorrent-rasterbar-1.2.18.tar.gz 4178407 BLAKE2B ccf8d891e4c34d101a8d822149d14b46cebf57dd893c00e2481e55c0cb35f6931b02e4b6f8877140316bb3bf1840a54eb04943aa1fd190d29708ae64a5c93604 SHA512 4ac7ad6357a612bdc537d4dbce40935a43c32295773870e490d1acffab9841b2bb3052e476a91f702b7b5eb2ab3e6282792f53593cdcb06ddbd6f1d5a3097ee7
DIST libtorrent-rasterbar-2.0.6.tar.gz 4431174 BLAKE2B 4951a102b68a5a7ba9a98d771ca638e8438b2aeaa95f5d7bf616542c7a02d28e184ee1bf5b7a55cd91a068cd2d4e9756c479e4ddb5eabe89d8aa833d70aa7502 SHA512 4a5d710706040ef6193967dbb13998cb0ddebe7e95c3bf8aec0812876027c68c32b001fd3f07cd4ff1b819660a8d46ae8c7077e72caf92572288a51cdec7daea
DIST libtorrent-rasterbar-2.0.7.tar.gz 4453469 BLAKE2B b04884c55cb96031f6bfcef786ea101d18bb9310ec2e1ed528e27d8f625712855726575beae127f24c007144bb85e1eba293da748ad06794c58ebd9b38ec5aac SHA512 30e558245a261ccf3f23815a037477ae6da1a02da0b7b3aa40383058c5782a341a11ae684f959efc1c9b39e31475ec31451b9ff4b2db3c0bfccc4d42bd6d69c1
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.16.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.16.ebuild
deleted file mode 100644
index 584c481282f5..000000000000
--- a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.2.16.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8,9,10} )
-
-inherit cmake python-single-r1
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="https://libtorrent.org/ https://github.com/arvidn/libtorrent"
-SRC_URI="https://github.com/arvidn/libtorrent/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/10"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+dht debug python ssl test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-libs/boost:=
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost[python,${PYTHON_USEDEP}]
- ')
- )
- ssl? ( dev-libs/openssl:= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="python? (
- $(python_gen_cond_dep '
- dev-python/setuptools[${PYTHON_USEDEP}]
- ')
- )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -Dbuild_examples=OFF
- -Ddht=$(usex dht ON OFF)
- -Dencryption=$(usex ssl ON OFF)
- -Dlogging=$(usex debug ON OFF)
- -Dpython-bindings=$(usex python ON OFF)
- -Dbuild_tests=$(usex test ON OFF)
- )
-
- # We need to drop the . from the Python version to satisfy Boost's
- # FindBoost.cmake module, bug #793038.
- use python && mycmakeargs+=( -Dboost-python-module-name="${EPYTHON/./}" )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # Needs running UPnP server
- -E "test_upnp"
- )
-
- # Checked out Fedora's test workarounds for inspiration
- # https://src.fedoraproject.org/rpms/rb_libtorrent/blob/rawhide/f/rb_libtorrent.spec#_120
- LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" cmake_src_test
-}