summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2021-03-11 07:47:00 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-27 07:49:51 +0200
commit1954021a3763187bfeb6ccc36bec7224eda8706c (patch)
tree060e4137d4c6cc193571506a74bb73d78e7f1e3c
parentsci-libs/hypre: adjust CC check for consistency (diff)
downloadgentoo-1954021a3763187bfeb6ccc36bec7224eda8706c.tar.gz
gentoo-1954021a3763187bfeb6ccc36bec7224eda8706c.tar.bz2
gentoo-1954021a3763187bfeb6ccc36bec7224eda8706c.zip
dev-libs/aws-c-common: Version Bump to 0.5.2
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sven Eden <sven.eden@prydeworx.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-libs/aws-c-common/Manifest1
-rw-r--r--dev-libs/aws-c-common/aws-c-common-0.5.2.ebuild29
-rw-r--r--dev-libs/aws-c-common/files/aws-c-common-0.5.2-remove-Werror-CFLAG.patch11
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/aws-c-common/Manifest b/dev-libs/aws-c-common/Manifest
index a6c552fe9079..9b874b473bc4 100644
--- a/dev-libs/aws-c-common/Manifest
+++ b/dev-libs/aws-c-common/Manifest
@@ -1 +1,2 @@
DIST aws-c-common-0.4.62.tar.gz 411263 BLAKE2B b9eb8eab8fceb949adcb96bc98987c318dcc70dae2cb8ecdcdf36c306be97158a64208c4bcc2452c83f03708cd7fb5401639558bc9bea946234f4b6b4c8eaec1 SHA512 7f31d739a3376404016bd509b40656d7620bddfb77a7f988306f2dcb2b03a03387855d845c2b9f63194d0bf2182a8d96392dba6c2bf847eaeb008115561d73ba
+DIST aws-c-common-0.5.2.tar.gz 422185 BLAKE2B e2058d523f9739b2d28db6ff26e00326977853a1ccc2468c36ba021619b0e9223e8a5584c06a29b511607741d208ac803023c1e6c17df10cd46227274d885978 SHA512 3e3b639f0387ba0e4ea62a35e57b7f0697a5f829bbffe6758d2e43db45543528615298281b045275c582a8cce9f0f6a36a06b231460ce4e2cc42ac01d7a0e952
diff --git a/dev-libs/aws-c-common/aws-c-common-0.5.2.ebuild b/dev-libs/aws-c-common/aws-c-common-0.5.2.ebuild
new file mode 100644
index 000000000000..1427f5278f1e
--- /dev/null
+++ b/dev-libs/aws-c-common/aws-c-common-0.5.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Core c99 package for AWS SDK for C"
+HOMEPAGE="https://github.com/awslabs/aws-c-common"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-remove-Werror-CFLAG.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
diff --git a/dev-libs/aws-c-common/files/aws-c-common-0.5.2-remove-Werror-CFLAG.patch b/dev-libs/aws-c-common/files/aws-c-common-0.5.2-remove-Werror-CFLAG.patch
new file mode 100644
index 000000000000..888205f88d61
--- /dev/null
+++ b/dev-libs/aws-c-common/files/aws-c-common-0.5.2-remove-Werror-CFLAG.patch
@@ -0,0 +1,11 @@
+--- a/cmake/AwsCFlags.cmake 2021-03-11 07:42:36.325962577 +0100
++++ b/cmake/AwsCFlags.cmake 2021-03-11 07:42:46.174962928 +0100
+@@ -53,7 +53,7 @@
+ list(APPEND AWS_C_FLAGS "${_FLAGS}")
+
+ else()
+- list(APPEND AWS_C_FLAGS -Wall -Werror -Wstrict-prototypes -fno-omit-frame-pointer)
++ list(APPEND AWS_C_FLAGS -Wall -Wstrict-prototypes -fno-omit-frame-pointer)
+
+ if(NOT SET_PROPERTIES_NO_WEXTRA)
+ list(APPEND AWS_C_FLAGS -Wextra)