summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-12-13 11:55:32 -0500
committerCraig Andrews <candrews@gentoo.org>2021-12-13 11:55:59 -0500
commit1921a4d19ce225d166fae6c8380ec68a397cdceb (patch)
treedcc37ff6380b74f99e874b6507a6f07758eb85b2
parentdev-java/milton-mail-api: treeclean (diff)
downloadgentoo-1921a4d19ce225d166fae6c8380ec68a397cdceb.tar.gz
gentoo-1921a4d19ce225d166fae6c8380ec68a397cdceb.tar.bz2
gentoo-1921a4d19ce225d166fae6c8380ec68a397cdceb.zip
net-p2p/deluge: 2.0.4 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/deluge/Manifest1
-rw-r--r--net-p2p/deluge/deluge-2.0.4.ebuild142
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild5
3 files changed, 144 insertions, 4 deletions
diff --git a/net-p2p/deluge/Manifest b/net-p2p/deluge/Manifest
index 1328b39e998e..e563b1953867 100644
--- a/net-p2p/deluge/Manifest
+++ b/net-p2p/deluge/Manifest
@@ -1 +1,2 @@
DIST deluge-2.0.3.tar.xz 1777624 BLAKE2B d090e63e7e18c7b420e1c4239c833512a04a72e8b2c494bc8a3a03a3b7a03050eed894de84d7a26a416417b0c874a82809398fcaf57972b1056e2fcceb9d092d SHA512 3abec24495b22ec10649865c7ce7c3271224c7d25c0647b43f3c177b7ccb45d4c5c593f8c89d8bc8eac85ae5dc737f9960827587912dd527bb96100304a7d480
+DIST deluge-2.0.4.tar.xz 1866260 BLAKE2B cce7c9bfb81ec8c8d61072f74ca939fd07093ce553a755970ff010bb0674b82a4072596d008ea9330e4450f7cc9e190f6b61c6e6023565cd0da198fb82bcaae5 SHA512 3dc3602d8b04f3e4fd2797ea72ce1d2043d9e6e256903b6403369fef075de0281e78c049af049fa8e27b249dd0a5e5071472a73e9905781081f148b29d93bf7b
diff --git a/net-p2p/deluge/deluge-2.0.4.ebuild b/net-p2p/deluge/deluge-2.0.4.ebuild
new file mode 100644
index 000000000000..567df54ba964
--- /dev/null
+++ b/net-p2p/deluge/deluge-2.0.4.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+DISTUTILS_SINGLE_IMPL=1
+inherit xdg distutils-r1 systemd
+
+DESCRIPTION="BitTorrent client with a client/server model"
+HOMEPAGE="https://deluge-torrent.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.deluge-torrent.org/${PN}"
+else
+ SRC_URI="http://download.deluge-torrent.org/source/2.0/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="console geoip gtk libnotify sound webinterface"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ libnotify? ( gtk )
+ sound? ( gtk )
+"
+
+DEPEND="
+ <net-libs/libtorrent-rasterbar-2.0.0:=[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/wheel[${PYTHON_USEDEP}]
+ ')
+ dev-util/intltool
+ acct-group/deluge
+ acct-user/deluge"
+RDEPEND="
+ <net-libs/libtorrent-rasterbar-2.0.0:=[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/rencode[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/twisted-17.1.0[crypt,${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
+ geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
+ gtk? (
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+ libnotify? ( x11-libs/libnotify )
+ )
+ dev-python/mako[${PYTHON_USEDEP}]
+ ')"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.3-setup.py.patch"
+ "${FILESDIR}/${PN}-2.0.3-UI-status.patch"
+)
+
+python_prepare_all() {
+ local args=(
+ -e "/Compiling po file/a \\\tuptoDate = False"
+ )
+ sed -i "${args[@]}" -- 'setup.py' || die
+ args=(
+ -e 's|"new_release_check": True|"new_release_check": False|'
+ -e 's|"check_new_releases": True|"check_new_releases": False|'
+ -e 's|"show_new_releases": True|"show_new_releases": False|'
+ )
+ sed -i "${args[@]}" -- 'deluge/core/preferencesmanager.py' || die
+
+ distutils-r1_python_prepare_all
+}
+
+esetup.py() {
+ # bug 531370: deluge has its own plugin system. No need to relocate its egg info files.
+ # Override this call from the distutils-r1 eclass.
+ # This does not respect the distutils-r1 API. DONOT copy this example.
+ set -- "${PYTHON}" setup.py "$@"
+ echo "$@"
+ "$@" || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if ! use console ; then
+ rm -r "${D}/$(python_get_sitedir)/deluge/ui/console/" || die
+ rm "${ED}/usr/bin/deluge-console" || die
+ rm "${ED}/usr/share/man/man1/deluge-console.1" ||die
+ fi
+ if ! use gtk ; then
+ rm -r "${D}/$(python_get_sitedir)/deluge/ui/gtk3/" || die
+ rm -r "${ED}/usr/share/icons/" || die
+ rm "${ED}/usr/bin/deluge-gtk" || die
+ rm "${ED}/usr/share/man/man1/deluge-gtk.1" || die
+ rm "${ED}/usr/share/applications/deluge.desktop" || die
+ fi
+ if use webinterface; then
+ newinitd "${FILESDIR}/deluge-web.init-2" deluge-web
+ newconfd "${FILESDIR}/deluge-web.conf" deluge-web
+ systemd_newunit "${FILESDIR}/deluge-web.service-3" deluge-web.service
+ systemd_install_serviced "${FILESDIR}/deluge-web.service.conf"
+ else
+ rm -r "${D}/$(python_get_sitedir)/deluge/ui/web/" || die
+ rm "${ED}/usr/bin/deluge-web" || die
+ rm "${ED}/usr/share/man/man1/deluge-web.1" || die
+ fi
+ newinitd "${FILESDIR}"/deluged.init-2 deluged
+ newconfd "${FILESDIR}"/deluged.conf-2 deluged
+ systemd_newunit "${FILESDIR}"/deluged.service-2 deluged.service
+ systemd_install_serviced "${FILESDIR}"/deluged.service.conf
+
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog
+ elog "If, after upgrading, deluge doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ elog "To start the daemon either run 'deluged' as user"
+ elog "or modify /etc/conf.d/deluged and run"
+ elog "/etc/init.d/deluged start as root"
+ elog "You can still use deluge the old way"
+ elog
+ elog "Systemd unit files for deluged and deluge-web no longer source"
+ elog "/etc/conf.d/deluge* files. Environment variable customization now"
+ elog "happens in /etc/systemd/system/deluged.service.d/00gentoo.conf"
+ elog "and /etc/systemd/system/deluge-web.service.d/00gentoo.conf"
+ elog
+ elog "For more information look at https://dev.deluge-torrent.org/wiki/Faq"
+ elog
+}
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index e244b9e1a44c..567df54ba964 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
DISTUTILS_SINGLE_IMPL=1
inherit xdg distutils-r1 systemd
@@ -61,9 +61,6 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-2.0.3-setup.py.patch"
"${FILESDIR}/${PN}-2.0.3-UI-status.patch"
- "${FILESDIR}/${PN}-2.0.3-gettext.patch"
- "${FILESDIR}/${P}-fix-pickle.patch"
- "${FILESDIR}/${P}-log.patch"
)
python_prepare_all() {