summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-12-06 19:46:44 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-12-06 19:46:44 +0000
commit18e670769780093252b2cafdf541462ee6e45984 (patch)
treee231649121c45f74f54f864bfc61adc6f5a4da1d
parent2022-12-06 19:31:49 UTC (diff)
parentdev-lang/python: drop leftover debugging append-flags (diff)
downloadgentoo-18e670769780093252b2cafdf541462ee6e45984.tar.gz
gentoo-18e670769780093252b2cafdf541462ee6e45984.tar.bz2
gentoo-18e670769780093252b2cafdf541462ee6e45984.zip
Merge updates from master
-rw-r--r--dev-lang/python/python-3.10.8_p3.ebuild12
-rw-r--r--dev-lang/python/python-3.11.0_p2.ebuild12
-rw-r--r--dev-lang/python/python-3.12.0_alpha2.ebuild12
-rw-r--r--dev-lang/python/python-3.8.15_p3.ebuild12
-rw-r--r--dev-lang/python/python-3.9.15_p3.ebuild12
-rw-r--r--media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch45
-rw-r--r--media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch18
-rw-r--r--net-voip/mumble/files/mumble-1.4-force-alignment.patch28
-rw-r--r--net-voip/mumble/mumble-1.4.287-r1.ebuild (renamed from net-voip/mumble/mumble-1.4.287.ebuild)10
9 files changed, 87 insertions, 74 deletions
diff --git a/dev-lang/python/python-3.10.8_p3.ebuild b/dev-lang/python/python-3.10.8_p3.ebuild
index e7125a5118a9..e491313aed70 100644
--- a/dev-lang/python/python-3.10.8_p3.ebuild
+++ b/dev-lang/python/python-3.10.8_p3.ebuild
@@ -230,6 +230,9 @@ src_configure() {
local -x OPT=
if tc-is-cross-compiler ; then
+ # Hack to workaround get_libdir not being able to handle CBUILD, bug #794181
+ local cbuild_libdir=$(unset PKG_CONFIG_PATH ; $(tc-getBUILD_PKG_CONFIG) --keep-system-libs --libs-only-L libffi)
+
# pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
# propagated to sysconfig for built extensions
local -x CFLAGS_NODIST=${CFLAGS_FOR_BUILD}
@@ -241,6 +244,8 @@ src_configure() {
local myeconfargs_cbuild=(
"${myeconfargs[@]}"
+ --libdir="${cbuild_libdir:2}"
+
# As minimal as possible for the mini CBUILD Python
# we build just for cross.
--without-lto
@@ -253,7 +258,10 @@ src_configure() {
mkdir "${WORKDIR}"/${P}-${CBUILD} || die
pushd "${WORKDIR}"/${P}-${CBUILD} &> /dev/null || die
- ECONF_SOURCE="${S}" econf_build "${myeconfargs_cbuild[@]}"
+ # We disable _ctypes and _crypt for CBUILD because Python's setup.py can't handle locating
+ # libdir correctly for cross.
+ PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _ctypes _crypt" \
+ ECONF_SOURCE="${S}" econf_build "${myeconfargs_cbuild[@]}"
# Avoid as many dependencies as possible for the cross build.
cat >> Makefile <<-EOF || die
@@ -276,7 +284,7 @@ src_configure() {
# not in src_compile, because CHOST configure for Python
# will check the existence of the Python it was pointed to
# immediately.
- emake
+ PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _ctypes _crypt" emake
popd &> /dev/null || die
fi
diff --git a/dev-lang/python/python-3.11.0_p2.ebuild b/dev-lang/python/python-3.11.0_p2.ebuild
index 6888041b8060..4eb6b8b120b6 100644
--- a/dev-lang/python/python-3.11.0_p2.ebuild
+++ b/dev-lang/python/python-3.11.0_p2.ebuild
@@ -219,6 +219,9 @@ src_configure() {
local -x OPT=
if tc-is-cross-compiler ; then
+ # Hack to workaround get_libdir not being able to handle CBUILD, bug #794181
+ local cbuild_libdir=$(unset PKG_CONFIG_PATH ; $(tc-getBUILD_PKG_CONFIG) --keep-system-libs --libs-only-L libffi)
+
# pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
# propagated to sysconfig for built extensions
local -x CFLAGS_NODIST=${CFLAGS_FOR_BUILD}
@@ -230,6 +233,8 @@ src_configure() {
local myeconfargs_cbuild=(
"${myeconfargs[@]}"
+ --libdir="${cbuild_libdir:2}"
+
# As minimal as possible for the mini CBUILD Python
# we build just for cross to satisfy --with-build-python.
--without-lto
@@ -245,7 +250,10 @@ src_configure() {
mkdir "${WORKDIR}"/${P}-${CBUILD} || die
pushd "${WORKDIR}"/${P}-${CBUILD} &> /dev/null || die
- ECONF_SOURCE="${S}" econf_build "${myeconfargs_cbuild[@]}"
+ # We disable _ctypes and _crypt for CBUILD because Python's setup.py can't handle locating
+ # libdir correctly for cross.
+ PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _ctypes _crypt" \
+ ECONF_SOURCE="${S}" econf_build "${myeconfargs_cbuild[@]}"
# Avoid as many dependencies as possible for the cross build.
cat >> Makefile <<-EOF || die
@@ -268,7 +276,7 @@ src_configure() {
# not in src_compile, because CHOST configure for Python
# will check the existence of the --with-build-python value
# immediately.
- emake
+ PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _ctypes _crypt" emake
popd &> /dev/null || die
fi
diff --git a/dev-lang/python/python-3.12.0_alpha2.ebuild b/dev-lang/python/python-3.12.0_alpha2.ebuild
index ec1c57a29503..6a277535661c 100644
--- a/dev-lang/python/python-3.12.0_alpha2.ebuild
+++ b/dev-lang/python/python-3.12.0_alpha2.ebuild
@@ -215,6 +215,9 @@ src_configure() {
local -x OPT=
if tc-is-cross-compiler ; then
+ # Hack to workaround get_libdir not being able to handle CBUILD, bug #794181
+ local cbuild_libdir=$(unset PKG_CONFIG_PATH ; $(tc-getBUILD_PKG_CONFIG) --keep-system-libs --libs-only-L libffi)
+
# pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
# propagated to sysconfig for built extensions
local -x CFLAGS_NODIST=${CFLAGS_FOR_BUILD}
@@ -226,6 +229,8 @@ src_configure() {
local myeconfargs_cbuild=(
"${myeconfargs[@]}"
+ --libdir="${cbuild_libdir:2}"
+
# As minimal as possible for the mini CBUILD Python
# we build just for cross to satisfy --with-build-python.
--without-lto
@@ -241,7 +246,10 @@ src_configure() {
mkdir "${WORKDIR}"/${P}-${CBUILD} || die
pushd "${WORKDIR}"/${P}-${CBUILD} &> /dev/null || die
- ECONF_SOURCE="${S}" econf_build "${myeconfargs_cbuild[@]}"
+ # We disable _ctypes and _crypt for CBUILD because Python's setup.py can't handle locating
+ # libdir correctly for cross.
+ PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _ctypes _crypt" \
+ ECONF_SOURCE="${S}" econf_build "${myeconfargs_cbuild[@]}"
# Avoid as many dependencies as possible for the cross build.
cat >> Makefile <<-EOF || die
@@ -264,7 +272,7 @@ src_configure() {
# not in src_compile, because CHOST configure for Python
# will check the existence of the --with-build-python value
# immediately.
- emake
+ PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _ctypes _crypt" emake
popd &> /dev/null || die
fi
diff --git a/dev-lang/python/python-3.8.15_p3.ebuild b/dev-lang/python/python-3.8.15_p3.ebuild
index 5f5bccbf6686..39a9badeb2d6 100644
--- a/dev-lang/python/python-3.8.15_p3.ebuild
+++ b/dev-lang/python/python-3.8.15_p3.ebuild
@@ -184,6 +184,9 @@ src_configure() {
local -x OPT=
if tc-is-cross-compiler ; then
+ # Hack to workaround get_libdir not being able to handle CBUILD, bug #794181
+ local cbuild_libdir=$(unset PKG_CONFIG_PATH ; $(tc-getBUILD_PKG_CONFIG) --keep-system-libs --libs-only-L libffi)
+
# pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
# propagated to sysconfig for built extensions
local -x CFLAGS_NODIST=${CFLAGS_FOR_BUILD}
@@ -195,6 +198,8 @@ src_configure() {
local myeconfargs_cbuild=(
"${myeconfargs[@]}"
+ --libdir="${cbuild_libdir:2}"
+
# As minimal as possible for the mini CBUILD Python
# we build just for cross.
--without-lto
@@ -207,7 +212,10 @@ src_configure() {
mkdir "${WORKDIR}"/${P}-${CBUILD} || die
pushd "${WORKDIR}"/${P}-${CBUILD} &> /dev/null || die
- ECONF_SOURCE="${S}" econf_build "${myeconfargs_cbuild[@]}"
+ # We disable _ctypes and _crypt for CBUILD because Python's setup.py can't handle locating
+ # libdir correctly for cross.
+ PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _ctypes _crypt" \
+ ECONF_SOURCE="${S}" econf_build "${myeconfargs_cbuild[@]}"
# Avoid as many dependencies as possible for the cross build.
cat >> Makefile <<-EOF || die
@@ -230,7 +238,7 @@ src_configure() {
# not in src_compile, because CHOST configure for Python
# will check the existence of the Python it was pointed to
# immediately.
- emake
+ PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _ctypes _crypt" emake
popd &> /dev/null || die
fi
diff --git a/dev-lang/python/python-3.9.15_p3.ebuild b/dev-lang/python/python-3.9.15_p3.ebuild
index 4ab4f51b7faf..eff2605e1374 100644
--- a/dev-lang/python/python-3.9.15_p3.ebuild
+++ b/dev-lang/python/python-3.9.15_p3.ebuild
@@ -224,6 +224,9 @@ src_configure() {
local -x OPT=
if tc-is-cross-compiler ; then
+ # Hack to workaround get_libdir not being able to handle CBUILD, bug #794181
+ local cbuild_libdir=$(unset PKG_CONFIG_PATH ; $(tc-getBUILD_PKG_CONFIG) --keep-system-libs --libs-only-L libffi)
+
# pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
# propagated to sysconfig for built extensions
local -x CFLAGS_NODIST=${CFLAGS_FOR_BUILD}
@@ -235,6 +238,8 @@ src_configure() {
local myeconfargs_cbuild=(
"${myeconfargs[@]}"
+ --libdir="${cbuild_libdir:2}"
+
# As minimal as possible for the mini CBUILD Python
# we build just for cross.
--without-lto
@@ -247,7 +252,10 @@ src_configure() {
mkdir "${WORKDIR}"/${P}-${CBUILD} || die
pushd "${WORKDIR}"/${P}-${CBUILD} &> /dev/null || die
- ECONF_SOURCE="${S}" econf_build "${myeconfargs_cbuild[@]}"
+ # We disable _ctypes and _crypt for CBUILD because Python's setup.py can't handle locating
+ # libdir correctly for cross.
+ PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _ctypes _crypt" \
+ ECONF_SOURCE="${S}" econf_build "${myeconfargs_cbuild[@]}"
# Avoid as many dependencies as possible for the cross build.
cat >> Makefile <<-EOF || die
@@ -270,7 +278,7 @@ src_configure() {
# not in src_compile, because CHOST configure for Python
# will check the existence of the Python it was pointed to
# immediately.
- emake
+ PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _ctypes _crypt" emake
popd &> /dev/null || die
fi
diff --git a/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch b/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
deleted file mode 100644
index a7e5804319d7..000000000000
--- a/media-gfx/graphite2/files/graphite2-1.3.14-fix-nodefaultlibs.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-https://bugs.gentoo.org/829690
-
-See https://github.com/silnrsi/graphite/pull/44.
-
-Drop -nodefaultlibs:
-- graphite is written in C++ which makes avoiding libstdc++ (or libc++) a dubious
- goal;
-- this ends up breaking e.g. x86/musl because we need to inject -lssp_nonshared,
- but it wouldn't be surprising if it broke other exotic targets too.
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -105,7 +105,7 @@ set_target_properties(graphite2 PROPERTIES PUBLIC_HEADER "${GRAPHITE_HEADERS}"
- if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
- set_target_properties(graphite2 PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wendif-labels -Wshadow -Wctor-dtor-privacy -Wnon-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86|i.86")
- add_definitions(-mfpmath=sse -msse2)
-@@ -135,7 +135,6 @@ endif()
- if (${CMAKE_SYSTEM_NAME} STREQUAL "Darwin")
- set_target_properties(graphite2 PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-unknown-pragmas -Wimplicit-fallthrough -Wendif-labels -Wshadow -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -fno-rtti -fno-exceptions -fvisibility=hidden -fvisibility-inlines-hidden"
-- LINK_FLAGS "-nodefaultlibs"
- LINKER_LANGUAGE C)
- if (${CMAKE_SYSTEM_PROCESSOR} MATCHES "x86|i.86")
- add_definitions(-mfpmath=sse -msse2)
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -47,12 +47,12 @@ else (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
- set_target_properties(graphite2-base PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-class-memaccess -fno-rtti -fno-exceptions"
- COMPILE_DEFINITIONS "GRAPHITE2_NTRACING"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- set_target_properties(graphite2-file PROPERTIES
- COMPILE_FLAGS "-Wall -Wextra -Wno-class-memaccess -fno-rtti -fno-exceptions"
- COMPILE_DEFINITIONS "GRAPHITE2_NTRACING${TELEMETRY}"
-- LINK_FLAGS "-nodefaultlibs ${GRAPHITE_LINK_FLAGS}"
-+ LINK_FLAGS "${GRAPHITE_LINK_FLAGS}"
- LINKER_LANGUAGE C)
- endif()
-
diff --git a/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch b/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
deleted file mode 100644
index b162ca9aa6f9..000000000000
--- a/media-gfx/graphite2/files/graphite2-1.35-fix-gcc-linking.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-https://src.fedoraproject.org/rpms/graphite2/raw/41fb7c104c8f9293254abaa91bbda1daafb458cd/f/graphite-arm-nodefaultlibs.patch
-https://bugs.gentoo.org/829690
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -120,11 +120,7 @@
- if (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
- target_link_libraries(graphite2 kernel32 msvcr90 mingw32 gcc user32)
- else (${CMAKE_CXX_COMPILER} MATCHES ".*mingw.*")
-- if (GRAPHITE2_SANITIZERS)
-- target_link_libraries(graphite2 c gcc_s)
-- else ()
-- target_link_libraries(graphite2 c gcc)
-- endif ()
-+ target_link_libraries(graphite2 c gcc_s)
- endif()
- include(Graphite)
- if (BUILD_SHARED_LIBS)
-
diff --git a/net-voip/mumble/files/mumble-1.4-force-alignment.patch b/net-voip/mumble/files/mumble-1.4-force-alignment.patch
new file mode 100644
index 000000000000..ea0ae4792443
--- /dev/null
+++ b/net-voip/mumble/files/mumble-1.4-force-alignment.patch
@@ -0,0 +1,28 @@
+From 13c051b36b387356815cff5d685bc628b74ba136 Mon Sep 17 00:00:00 2001
+From: Davide Beatrici <git@davidebeatrici.dev>
+Date: Thu, 1 Sep 2022 23:32:57 +0200
+Subject: [PATCH] FIX(positional-audio): Force 8 bytes alignment for
+ CCameraAngles in GTAV plugin
+
+https://en.cppreference.com/w/cpp/language/alignas
+
+This fixes compilation when the implicit alignment is not 8 bytes.
+
+It can be the case with 32 bit targets.
+---
+ plugins/gtav/structs.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plugins/gtav/structs.h b/plugins/gtav/structs.h
+index 2829dc11e1..0e4f76edab 100644
+--- a/plugins/gtav/structs.h
++++ b/plugins/gtav/structs.h
+@@ -118,7 +118,7 @@ struct CCameraManagerAngles {
+ ptr_t cameraAngles; // CCameraAngles *
+ };
+
+-struct CCameraAngles {
++struct alignas(8) CCameraAngles {
+ uint8_t pad1[960];
+ ptr_t playerAngles; // CPlayerAngles *
+ uint8_t pad2[60];
diff --git a/net-voip/mumble/mumble-1.4.287.ebuild b/net-voip/mumble/mumble-1.4.287-r1.ebuild
index 58bb301f3470..9bef3ee35ff6 100644
--- a/net-voip/mumble/mumble-1.4.287.ebuild
+++ b/net-voip/mumble/mumble-1.4.287-r1.ebuild
@@ -21,7 +21,7 @@ else
SRC_URI="https://github.com/mumble-voip/mumble/releases/download/v${MY_PV}/${MY_P}.tar.gz"
S="${WORKDIR}/${P}.src"
fi
- KEYWORDS="amd64 ~arm64 ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
SRC_URI+=" https://dev.gentoo.org/~concord/distfiles/${PN}-1.4-openssl3.patch.xz"
@@ -77,6 +77,7 @@ PATCHES=(
"${WORKDIR}/${PN}-1.4-openssl3.patch"
"${WORKDIR}/${PN}-1.4-crypto-threads.patch"
"${WORKDIR}/${PN}-1.4-odr.patch"
+ "${FILESDIR}/${PN}-1.4-force-alignment.patch"
)
pkg_setup() {
@@ -124,6 +125,13 @@ src_configure() {
cmake_src_configure
}
+src_test() {
+ # https://bugs.gentoo.org/884049
+ # increase timeout for tests
+ local -x QTEST_FUNCTION_TIMEOUT=600000
+ cmake_src_test
+}
+
src_install() {
cmake_src_install