summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-10-21 19:59:32 -0300
committerSam James <sam@gentoo.org>2022-10-24 13:15:00 +0100
commit18368df1fb9423ae402bbdba77d0f059cd1a3dcd (patch)
tree5341f74903acc9787c74ebb453c1b23210effbfa
parentdev-util/ccache: add 4.7.1 (diff)
downloadgentoo-18368df1fb9423ae402bbdba77d0f059cd1a3dcd.tar.gz
gentoo-18368df1fb9423ae402bbdba77d0f059cd1a3dcd.tar.bz2
gentoo-18368df1fb9423ae402bbdba77d0f059cd1a3dcd.zip
media-libs/harfbuzz: bump version to 5.3.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27882 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-5.3.1.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index ec3343ebe8b1..86031818dffe 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -1,3 +1,4 @@
DIST harfbuzz-4.4.1.tar.gz 29231251 BLAKE2B 3947084ea2eedd76d64acfc5286ecd14d772ce0507163bc2c54a86579556a8799959ff4d47ea2919ee8472f8fe50d0266d325e3d0a7024f2ae8dcdf48d14f37e SHA512 bbc415d7b74408b1e8d34bfbc19a3cab002471fdd56d71b469c3129f0eae5532d5c7aaae7bb5cc3942fea6008d2ed9e96a7b20b10f4f5e46db63cecfa5c0248e
DIST harfbuzz-5.1.0.tar.gz 29358116 BLAKE2B 006e66e9c76b505214b948c7c8756af38171b85cc865923e4665a4dd3eb14d89d20456ad4490b11208d57d056b087da78e1742141e41f8a22e644f20d3ea4851 SHA512 bdd7c2ca0b6f2a3a3fffbf0324d3c8bfd64a1753314048f6f67f901d4098e90054eeda9155d134f03c5d3ddefb15e087f872d2d87b2ace07bac6625fb43c7f3e
DIST harfbuzz-5.3.0.tar.xz 17921224 BLAKE2B a220c1d4912487012f30942280651bcb63b5109e49be778a210bf26f4a0bcc7dc5ab7247775286b75cbe5b8fad7c439ae420d2085c6719088f028679242f9269 SHA512 0eae94769ac0157bf1df9b001223b30d40104ac448b1062f34ac793edb27ed1e459ac99954498c4b3cfb65c8cda29f2214a300f11523826b378ab67deec1a5f3
+DIST harfbuzz-5.3.1.tar.xz 17874260 BLAKE2B e4d3926daca4f5c95441a9b99e10acd4b95bf365f56934a2bbb8b35955e8457a90a13b0ad3223d8350012373216083e910f517b34c0dffb09fb218a1f8e9ca48 SHA512 6b0aef2b7445f4a71c324b545414114507d8077dc186366f25140dcd3bedeee67868cfc65c0eef59ed950381a4c101a541900be4995f645377c11754b027b501
diff --git a/media-libs/harfbuzz/harfbuzz-5.3.1.ebuild b/media-libs/harfbuzz/harfbuzz-5.3.1.ebuild
new file mode 100644
index 000000000000..0b9dc09b3923
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-5.3.1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit flag-o-matic meson-multilib python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+
+if [[ ${PV} = 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/harfbuzz/harfbuzz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/harfbuzz/harfbuzz/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="Old-MIT ISC icu"
+# 0.9.18 introduced the harfbuzz-icu split; bug #472416
+# 3.0.0 dropped some unstable APIs; bug #813705
+SLOT="0/4.0.0"
+
+IUSE="+cairo debug doc experimental +glib +graphite icu +introspection test +truetype"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ glib? ( >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-util/glib-utils )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ if ! use debug ; then
+ append-cppflags -DHB_NDEBUG
+ fi
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ # bug #726120
+ sed -i \
+ -e '/tests\/macos\.tests/d' \
+ test/shape/data/in-house/Makefile.sources \
+ || die
+
+ # bug #618772
+ append-cxxflags -std=c++14
+
+ # bug #790359
+ filter-flags -fexceptions -fthreadsafe-statics
+
+ # bug #762415
+ local pyscript
+ for pyscript in $(find -type f -name "*.py") ; do
+ python_fix_shebang -q "${pyscript}"
+ done
+}
+
+multilib_src_configure() {
+ # harfbuzz-gobject only used for introspection, bug #535852
+ local emesonargs=(
+ -Dcoretext="disabled"
+ -Dchafa="disabled"
+
+ $(meson_feature glib)
+ $(meson_feature graphite graphite2)
+ $(meson_feature icu)
+ $(meson_feature introspection gobject)
+ $(meson_feature test tests)
+ $(meson_feature truetype freetype)
+
+ $(meson_native_use_feature cairo)
+ $(meson_native_use_feature doc docs)
+ $(meson_native_use_feature introspection)
+
+ $(meson_use experimental experimental_api)
+ )
+
+ meson_src_configure
+}