summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-01 12:58:22 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-01 13:07:03 +0200
commit1519f9467bd1fb13da9485cc7a737965bb097136 (patch)
tree74021ccca63eaac77b914a14b3f3568e876de414
parentgames-engines/stratagus: Bump to 3.3.1 (diff)
downloadgentoo-1519f9467bd1fb13da9485cc7a737965bb097136.tar.gz
gentoo-1519f9467bd1fb13da9485cc7a737965bb097136.tar.bz2
gentoo-1519f9467bd1fb13da9485cc7a737965bb097136.zip
games-strategy/wargus: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-strategy/wargus/Manifest1
-rw-r--r--games-strategy/wargus/wargus-3.3.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/games-strategy/wargus/Manifest b/games-strategy/wargus/Manifest
index 4ba61d64d047..9a547b9fb426 100644
--- a/games-strategy/wargus/Manifest
+++ b/games-strategy/wargus/Manifest
@@ -5,3 +5,4 @@ DIST wargus-3.1.1.tar.gz 4982124 BLAKE2B 1dd583c46f841c03d0e859e3c79da72da5866c5
DIST wargus-3.1.2.tar.gz 4981468 BLAKE2B 76e925a6cd469a583adffe67f53a407f919b93c6700aeaa182db05b07691d64e6040d6f9f80461b14b81b412882bb58b976253b382d9e4aced7d1429c28832d2 SHA512 6925eab28b63222c4957b40c7b9a57ca231a18a7b36509c90f72d563a43a2ac4bd82bda3ca02e68099045fcddf10dd36c5a93c6f114f7bdcfb67afa7c7471b1e
DIST wargus-3.2.0.tar.gz 5062175 BLAKE2B e742c2dae21aa5a8a05ef8a4cefc7d1245707d401aa9e14dfc633aeac0e4e4e54459c0ce07cbd32aed842c3dcf57ea8df39fcfc34a9316211146a61ce71464dc SHA512 bc85304c0994abf778cf157d1013d9dea18e1d761a3b432018641211824bcdb2e424c938842848d8c7a670d8660289b5860342a99be7af259cf8eaf883af1285
DIST wargus-3.3.0.tar.gz 5094634 BLAKE2B aa0b02d62dc8620ba9517e5c7d1e8193f2c4c0e20b9b96b91cd5aa57fefdfda7354c82d67507aea67704adc7c77d90b858f0f3fb78d2a1bf430b5c4c5251f432 SHA512 3a2bd04aed0ced18a11ab925ca3d4da98f8848b45a0716fe5164ee5e0f9c76a63d7783d9ba94f3de022622e841f0257cb59d507ea772b2cc42419cef01ea8cbc
+DIST wargus-3.3.1.tar.gz 5094251 BLAKE2B b5f3674db93a8973f166e6dd0dcd9adeee330aa3932b97218b10e3540f5bc6123c977f45463d77c1cf6cc8d5dcadf39d799551311e9a891ec91200e668febcd8 SHA512 33a642d87a9a0d407fd8591fbb19d5357b5d7ae2fa3319512776feb0b6dbdc4d403e82de907235a9614302b5b0af466da37af21f7f4093715d39fe7e7da30468
diff --git a/games-strategy/wargus/wargus-3.3.1.ebuild b/games-strategy/wargus/wargus-3.3.1.ebuild
new file mode 100644
index 000000000000..fff6023fa177
--- /dev/null
+++ b/games-strategy/wargus/wargus-3.3.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Warcraft II for the Stratagus game engine"
+HOMEPAGE="
+ https://stratagus.com/
+ https://github.com/Wargus/wargus/
+"
+SRC_URI="
+ https://github.com/Wargus/wargus/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bne"
+
+DEPEND="
+ =games-engines/stratagus-${PV}*[theora]
+ media-libs/libpng:0=
+ sys-libs/zlib:=
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ bne? ( app-arch/stormlib:= )
+ !games-strategy/wargus-data
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+pkg_pretend() {
+ if has_version games-strategy/wargus-data; then
+ ewarn "The system-wide install of game data via games-strategy/wargus-data"
+ ewarn "no longer works. The old data will be uninstalled after merging"
+ ewarn "this version of Wargus. If you would like to preserve it, please"
+ ewarn "abort the process and back /usr/share/stratagus/wargus up."
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DGAMEDIR="${EPREFIX}/usr/bin"
+ -DBINDIR="${EPREFIX}/usr/bin"
+ -DSTRATAGUS="${EPREFIX}/usr/bin/stratagus"
+ -DSHAREDIR="${EPREFIX}/usr/share/stratagus/wargus"
+ -DICONDIR=/usr/share/icons/hicolor/64x64/apps
+ -DWITH_STORMLIB=$(usex bne)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "Wargus requires the data from the original game to run. The game"
+ elog "will ask you for the location of the game data and extract/convert"
+ elog "it automatically on the first run."
+
+ if ! has_version media-video/ffmpeg ||
+ ! has_version media-sound/cdparanoia
+ then
+ elog
+ elog "If you did not convert the game data yet, you may want to install"
+ elog "the following optional dependencies:"
+ elog
+ elog "media-video/ffmpeg -- to convert game videos"
+ elog "media-sound/cdparanoia -- to rip game music from the CD"
+ fi
+
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}