summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-05-26 19:41:50 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-05-26 19:41:50 +0000
commit0a48870c23059d536df80c3266dd45baaa0a2821 (patch)
treecfce3ef0d774770ee0717919bb1134e08a9db883
parent2017-05-26 19:22:15 UTC (diff)
parentnet-misc/rclone: New package (diff)
downloadgentoo-0a48870c23059d536df80c3266dd45baaa0a2821.tar.gz
gentoo-0a48870c23059d536df80c3266dd45baaa0a2821.tar.bz2
gentoo-0a48870c23059d536df80c3266dd45baaa0a2821.zip
Merge updates from master
-rw-r--r--app-office/libreoffice/libreoffice-5.3.3.2.ebuild2
-rw-r--r--app-office/libreoffice/libreoffice-5.3.9999.ebuild2
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild2
-rw-r--r--net-misc/rclone/Manifest1
-rw-r--r--net-misc/rclone/metadata.xml8
-rw-r--r--net-misc/rclone/rclone-1.36.ebuild31
-rw-r--r--net-misc/rclone/rclone-9999.ebuild31
7 files changed, 74 insertions, 3 deletions
diff --git a/app-office/libreoffice/libreoffice-5.3.3.2.ebuild b/app-office/libreoffice/libreoffice-5.3.3.2.ebuild
index 812746ad3bf1..5f6ac8e8e0d8 100644
--- a/app-office/libreoffice/libreoffice-5.3.3.2.ebuild
+++ b/app-office/libreoffice/libreoffice-5.3.3.2.ebuild
@@ -149,7 +149,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
dev-libs/glib:2
gnome-extra/evolution-data-server
)
- firebird? ( >=dev-db/firebird-2.5 )
+ firebird? ( >=dev-db/firebird-3.0.2.32703.0-r1 )
gltf? ( media-libs/libgltf )
gnome? ( gnome-base/dconf )
gstreamer? (
diff --git a/app-office/libreoffice/libreoffice-5.3.9999.ebuild b/app-office/libreoffice/libreoffice-5.3.9999.ebuild
index 812746ad3bf1..5f6ac8e8e0d8 100644
--- a/app-office/libreoffice/libreoffice-5.3.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-5.3.9999.ebuild
@@ -149,7 +149,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
dev-libs/glib:2
gnome-extra/evolution-data-server
)
- firebird? ( >=dev-db/firebird-2.5 )
+ firebird? ( >=dev-db/firebird-3.0.2.32703.0-r1 )
gltf? ( media-libs/libgltf )
gnome? ( gnome-base/dconf )
gstreamer? (
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 9fa466f01185..ccb30f204f76 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -152,7 +152,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
dev-libs/glib:2
gnome-extra/evolution-data-server
)
- firebird? ( >=dev-db/firebird-2.5 )
+ firebird? ( >=dev-db/firebird-3.0.2.32703.0-r1 )
gltf? ( >=media-libs/libgltf-0.1.0 )
gnome? ( gnome-base/dconf )
gstreamer? (
diff --git a/net-misc/rclone/Manifest b/net-misc/rclone/Manifest
new file mode 100644
index 000000000000..71ff95857b67
--- /dev/null
+++ b/net-misc/rclone/Manifest
@@ -0,0 +1 @@
+DIST rclone-1.36.tar.gz 14013564 SHA256 a573b70e3aeb355b943dddd6ae9375386fc21bf12dfba601d8d7280f97c4c884 SHA512 589b5e2370244b5609d1ec8245f9f5f5cf58d6a2d507768db2cfc5a5b882f7d277d797fd0068b904538f3700e1751df03a21697d5295c83a2bf01a78d0ac6b13 WHIRLPOOL aa75c6c32cdcebd79ecf79abd03b4dc0205517808eb232a9655e8ae3da327cd62ad7183f4e0b0f6b7b52649c0c5058fdc2b57bc7b31b7dffb05e8a1508307d5c
diff --git a/net-misc/rclone/metadata.xml b/net-misc/rclone/metadata.xml
new file mode 100644
index 000000000000..76f45cdee0f4
--- /dev/null
+++ b/net-misc/rclone/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>perfinion@gentoo.org</email>
+ <name>Jason Zaman</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/rclone/rclone-1.36.ebuild b/net-misc/rclone/rclone-1.36.ebuild
new file mode 100644
index 000000000000..0c936bdca50e
--- /dev/null
+++ b/net-misc/rclone/rclone-1.36.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build
+EGO_PN="github.com/ncw/${PN}"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman src/${EGO_PN}/${PN}.1
+ dodoc src/${EGO_PN}/README.md
+}
diff --git a/net-misc/rclone/rclone-9999.ebuild b/net-misc/rclone/rclone-9999.ebuild
new file mode 100644
index 000000000000..0c936bdca50e
--- /dev/null
+++ b/net-misc/rclone/rclone-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build
+EGO_PN="github.com/ncw/${PN}"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman src/${EGO_PN}/${PN}.1
+ dodoc src/${EGO_PN}/README.md
+}