summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2023-01-05 18:39:16 +0800
committerSam James <sam@gentoo.org>2023-01-06 02:09:32 +0000
commit039697b8a76d34afd28398e348d4fab0e0bda9ee (patch)
treeffd9594b9a4971aa761f4e01933bd330fc9e8989
parentmedia-libs/libde265: Stabilize 1.0.9 arm, #889880 (diff)
downloadgentoo-039697b8a76d34afd28398e348d4fab0e0bda9ee.tar.gz
gentoo-039697b8a76d34afd28398e348d4fab0e0bda9ee.tar.bz2
gentoo-039697b8a76d34afd28398e348d4fab0e0bda9ee.zip
dev-python/pytables: fix prefix installation
In setup.py default prefix includes "/usr", not "${EPREFIX}/usr". Thus under Gentoo prefix, libraries like hdf5 cannot be found by default. Prefixify this line to fix this. Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28968 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pytables/pytables-3.8.0-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/pytables/pytables-3.8.0-r1.ebuild b/dev-python/pytables/pytables-3.8.0-r1.ebuild
index af123af3a0fa..661e90f4fe6e 100644
--- a/dev-python/pytables/pytables-3.8.0-r1.ebuild
+++ b/dev-python/pytables/pytables-3.8.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
+inherit distutils-r1 prefix
MY_PN=tables
MY_P=${MY_PN}-${PV}
@@ -62,6 +62,7 @@ python_prepare_all() {
rm -r c-blosc/{blosc,internal-complibs} || die
rm tables/libblosc2.so || die
sed -i -e '/blosc2/d' requirements.txt || die
+ hprefixify -w '/prefixes =/' setup.py
distutils-r1_python_prepare_all
}