summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-29 12:09:44 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-29 12:44:43 +0100
commit0073ab110d9bbb84cb0e11e78bdcc87d26911752 (patch)
tree8b625bc8d471d046f02981a542748f1c826149cf
parentdev-python/plotly: add 5.13.0 (diff)
downloadgentoo-0073ab110d9bbb84cb0e11e78bdcc87d26911752.tar.gz
gentoo-0073ab110d9bbb84cb0e11e78bdcc87d26911752.tar.bz2
gentoo-0073ab110d9bbb84cb0e11e78bdcc87d26911752.zip
dev-python/plotly-geo: update EAPI 7 -> 8, pep517, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/plotly-geo/Manifest1
-rw-r--r--dev-python/plotly-geo/plotly-geo-1.0.0-r2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/plotly-geo/Manifest b/dev-python/plotly-geo/Manifest
index 43ba51a2d31f..f0757ea63b2a 100644
--- a/dev-python/plotly-geo/Manifest
+++ b/dev-python/plotly-geo/Manifest
@@ -1 +1,2 @@
DIST plotly-geo-1.0.0.tar.gz 23718591 BLAKE2B f78b36cd7ac6ec10e830f6be5758ed31ad2382882454d96ef652a73a11aa9b3be46ea24fd3f49a6189d9fd9eeaa89ca6777c691be9fc65f4d2a04a4d2bd58823 SHA512 977621c0fc84a6c72b2a91bcba27cc25b277f32cc87a7098675b3d7cb8c468a8291ef66397f3ceb45fbaa3484eba53d7649f809cf9d02af6309562af0b4fdf4a
+DIST plotly.py-5.13.0.gh.tar.gz 30683340 BLAKE2B 0e2c5638c766e5da6e2067d7be270576afed984b45deec0955fa10698d37bd082f3ebc568a8290c17554c672ef9e31cee81b0fae18b9f3249591fe62510ce5fd SHA512 c874b46ac43520519951aad55f93bfcfe03910873fd273f283fe16ae2a4150cfa35104be422c21b65785c77f468f084847278f76bce3d9179cc2a339809c42e3
diff --git a/dev-python/plotly-geo/plotly-geo-1.0.0-r2.ebuild b/dev-python/plotly-geo/plotly-geo-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..c3220f5d9a8f
--- /dev/null
+++ b/dev-python/plotly-geo/plotly-geo-1.0.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+PLOTLY_PV="5.13.0"
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plotly.com/python/"
+SRC_URI="https://github.com/plotly/plotly.py/archive/refs/tags/v${PLOTLY_PV}.tar.gz -> plotly.py-${PLOTLY_PV}.gh.tar.gz"
+S="${WORKDIR}/plotly.py-${PLOTLY_PV}/packages/python/${PN}"
+
+# The warning about tests not being enabled is a false positive.
+# Add distutils_enable_tests and restrict the tests to suppress the warning.
+RESTRICT="test"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/plotly[${PYTHON_USEDEP}]
+"
+
+# There are sphinx docs but we are missing a bunch of dependencies.
+# distutils_enable_sphinx ../../../doc/apidoc
+distutils_enable_tests pytest