aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2017-11-21 17:21:17 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2017-11-21 17:25:44 -0500
commite44fc71e5b02ffc2b8fa438052cff2ba5ab66203 (patch)
treeba405fe66fe2799105947d123eb8fb8e0e47feb2 /virtual
parentInitial Commit (diff)
downloadwine-e44fc71e5b02ffc2b8fa438052cff2ba5ab66203.tar.gz
wine-e44fc71e5b02ffc2b8fa438052cff2ba5ab66203.tar.bz2
wine-e44fc71e5b02ffc2b8fa438052cff2ba5ab66203.zip
Import all from ::gentoo
Diffstat (limited to 'virtual')
-rw-r--r--virtual/wine/metadata.xml16
-rw-r--r--virtual/wine/wine-0-r5.ebuild33
-rw-r--r--virtual/wine/wine-0-r6.ebuild33
3 files changed, 82 insertions, 0 deletions
diff --git a/virtual/wine/metadata.xml b/virtual/wine/metadata.xml
new file mode 100644
index 0000000..de062ba
--- /dev/null
+++ b/virtual/wine/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>wine@gentoo.org</email>
+ <name>Wine</name>
+ </maintainer>
+ <use>
+ <flag name="d3d9">Enable Ixit's Gallium Nine Patchset</flag>
+ <flag name="staging">Enable Wine-Staging's Patchset</flag>
+ </use>
+ <longdescription lang="en">
+ Allows for any variant of Wine, regardless of slotting to fulfill the dependencies
+ traditionally fulfilled by the non-slotted, pre-variant, app-emulation/wine.
+ </longdescription>
+</pkgmetadata>
diff --git a/virtual/wine/wine-0-r5.ebuild b/virtual/wine/wine-0-r5.ebuild
new file mode 100644
index 0000000..ac3dcae
--- /dev/null
+++ b/virtual/wine/wine-0-r5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE="+abi_x86_32 +abi_x86_64 d3d9 staging"
+
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
+
+# Note, the ordering here is intentional, to take advantage of the short-circuit
+# logic of portage, to enforce wine-vanilla as default for new users. The idea
+# behind this is that some USE flags may pull in 3rd-party patchsets, so default
+# of vanilla prevents that.
+RDEPEND="
+ staging? ( || (
+ app-emulation/wine-staging[staging]
+ app-emulation/wine-any[staging]
+ ) )
+ d3d9? ( || (
+ app-emulation/wine-d3d9[d3d9]
+ app-emulation/wine-any[d3d9]
+ ) )
+ || (
+ app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-d3d9[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-any[abi_x86_32=,abi_x86_64=]
+ )
+ !app-emulation/wine:0"
diff --git a/virtual/wine/wine-0-r6.ebuild b/virtual/wine/wine-0-r6.ebuild
new file mode 100644
index 0000000..5371654
--- /dev/null
+++ b/virtual/wine/wine-0-r6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+abi_x86_32 +abi_x86_64 d3d9 staging"
+
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
+
+# Note, the ordering here is intentional, to take advantage of the short-circuit
+# logic of portage, to enforce wine-vanilla as default for new users. The idea
+# behind this is that some USE flags may pull in 3rd-party patchsets, so default
+# of vanilla prevents that.
+RDEPEND="
+ staging? ( || (
+ app-emulation/wine-staging[staging]
+ app-emulation/wine-any[staging]
+ ) )
+ d3d9? ( || (
+ app-emulation/wine-d3d9[d3d9]
+ app-emulation/wine-any[d3d9]
+ ) )
+ || (
+ app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-d3d9[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-any[abi_x86_32=,abi_x86_64=]
+ )
+ !app-emulation/wine:0"