aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoro01eg <o01eg@yandex.ru>2018-01-13 13:06:40 +0300
committero01eg <o01eg@yandex.ru>2018-01-13 13:06:40 +0300
commitf59ac97de1ae2b70d7a04359c4ef184042db94ba (patch)
tree8a6094f70cc355130bc527fec0b3bc9b7c5ab794 /dev-util
parentMerge pull request #316 from stefantalpalaru/repoman (diff)
downloadrust-f59ac97de1ae2b70d7a04359c4ef184042db94ba.tar.gz
rust-f59ac97de1ae2b70d7a04359c4ef184042db94ba.tar.bz2
rust-f59ac97de1ae2b70d7a04359c4ef184042db94ba.zip
Use separate lidir. Use cargo from rust distribution.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cargo/cargo-9999.ebuild51
1 files changed, 6 insertions, 45 deletions
diff --git a/dev-util/cargo/cargo-9999.ebuild b/dev-util/cargo/cargo-9999.ebuild
index 07bfb07..3b284df 100644
--- a/dev-util/cargo/cargo-9999.ebuild
+++ b/dev-util/cargo/cargo-9999.ebuild
@@ -1,56 +1,17 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils bash-completion-r1 git-r3
-
-DESCRIPTION="The Rust's package manager"
+DESCRIPTION="The Rust's package manager (virtual package)"
HOMEPAGE="http://crates.io/"
+SRC_URI=""
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
KEYWORDS=""
-IUSE="libressl"
-
-EGIT_REPO_URI="https://github.com/rust-lang/cargo.git"
-BIN_CARGO_URI="https://static.rust-lang.org/dist/cargo-nightly"
-
-COMMON_DEPEND=">=virtual/rust-999
- sys-libs/zlib
- !libressl? ( dev-libs/openssl:* )
- libressl? ( dev-libs/libressl:0 )
- net-libs/libssh2
- net-libs/http-parser"
-RDEPEND="${COMMON_DEPEND}
- net-misc/curl[ssl]"
-DEPEND="${COMMON_DEPEND}
- dev-util/cmake"
-
-DOCS="LICENSE-APACHE LICENSE-MIT LICENSE-THIRD-PARTY README.md"
-
-pkg_setup() {
- local postfix
- use amd64 && postfix=x86_64-unknown-linux-gnu
- use x86 && postfix=i686-unknown-linux-gnu
-
- # Download nightly cargo to bootstrap from it
-
- wget "${BIN_CARGO_URI}-${postfix}.tar.gz" || die
- unpack "./cargo-nightly-${postfix}.tar.gz"
- mv "./cargo-nightly-${postfix}" "./cargo"
-}
-
-src_compile() {
- "$HOME/cargo/cargo/bin/cargo" build --release || die
-}
+DEPEND=""
+RDEPEND=""
+PDEPEND=">=dev-lang/rust-9999[tools]"
-src_install() {
- default
- dobin target/release/${PN}
- doman src/etc/man/${PN}*.1
- newbashcomp src/etc/cargo.bashcomp.sh cargo
- insinto /usr/share/zsh/site-functions
- doins src/etc/_cargo
-}