aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgentoo90 <gentoo90@gmail.com>2015-05-06 11:49:00 +0300
committergentoo90 <gentoo90@gmail.com>2015-05-06 11:50:39 +0300
commitd4e239a747344ee53d6fb0d40e7d587e384b481f (patch)
treea7e0f35fbebdcdd911a245519d060bfabde4f5d3 /dev-rust
parentMerge pull request #123 from gentoo90/beta4 (diff)
downloadrust-d4e239a747344ee53d6fb0d40e7d587e384b481f.tar.gz
rust-d4e239a747344ee53d6fb0d40e7d587e384b481f.tar.bz2
rust-d4e239a747344ee53d6fb0d40e7d587e384b481f.zip
Fix cargo build when dev-libs/libgit2 is installed (#124)
Diffstat (limited to 'dev-rust')
-rw-r--r--dev-rust/cargo/cargo-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-rust/cargo/cargo-9999.ebuild b/dev-rust/cargo/cargo-9999.ebuild
index 7456c4c..e4361ed 100644
--- a/dev-rust/cargo/cargo-9999.ebuild
+++ b/dev-rust/cargo/cargo-9999.ebuild
@@ -31,6 +31,10 @@ src_configure() {
./configure --prefix="${EPREFIX}"/usr --disable-verify-install || die
}
+src_compile() {
+ emake VERBOSE=1 PKG_CONFIG_PATH="" || die
+}
+
src_install() {
CFG_DISABLE_LDCONFIG="true" emake DESTDIR="${D}" install || die
dobashcomp "${ED}"/usr/etc/bash_completion.d/cargo