aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <w.d.hubbs@gmail.com>2015-02-12 11:45:52 -0600
committerWilliam Hubbs <w.d.hubbs@gmail.com>2015-02-12 11:45:52 -0600
commit692832362fe9853e9e0ccffa9c1225d12dcb8457 (patch)
tree17f74214669a0ca2b5a1ee7ee8262bdd135a7bbd /dev-rust
parentMerge pull request #74 from jauhien/rust-bin (diff)
downloadrust-692832362fe9853e9e0ccffa9c1225d12dcb8457.tar.gz
rust-692832362fe9853e9e0ccffa9c1225d12dcb8457.tar.bz2
rust-692832362fe9853e9e0ccffa9c1225d12dcb8457.zip
dev-rust/cargo: remove extra live ebuild
Move the changes from dev-lang/cargo-9999-r1 to dev-lang/cargo-9999. We do not need the -r1 ebuild in this case.
Diffstat (limited to 'dev-rust')
-rw-r--r--dev-rust/cargo/cargo-9999-r1.ebuild39
-rw-r--r--dev-rust/cargo/cargo-9999.ebuild17
-rw-r--r--dev-rust/cargo/files/cargo-9999-no-ldconfig.patch25
3 files changed, 10 insertions, 71 deletions
diff --git a/dev-rust/cargo/cargo-9999-r1.ebuild b/dev-rust/cargo/cargo-9999-r1.ebuild
deleted file mode 100644
index 10f191c..0000000
--- a/dev-rust/cargo/cargo-9999-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-inherit eutils git-r3
-
-DESCRIPTION="A Rust's package manager"
-HOMEPAGE="http://crates.io/"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS=""
-
-IUSE=""
-
-EGIT_REPO_URI="git://github.com/rust-lang/cargo.git"
-
-RDEPEND=">=virtual/rust-999"
-DEPEND="${DEPEND}
- dev-util/cmake"
-
-src_prepare() {
- use x86 && export BITS=32
- CFG_DISABLE_LDCONFIG="nonempty" ./.travis.install.deps.sh || die
-}
-
-src_configure() {
- ./configure \
- --local-rust-root="${PWD}/rustc" \
- --prefix="${EPREFIX}"/usr \
- --disable-verify-install \
- || die
-}
-
-src_install() {
- CFG_DISABLE_LDCONFIG="true" emake DESTDIR="${D}" install || die
-}
diff --git a/dev-rust/cargo/cargo-9999.ebuild b/dev-rust/cargo/cargo-9999.ebuild
index 9a4ba12..10f191c 100644
--- a/dev-rust/cargo/cargo-9999.ebuild
+++ b/dev-rust/cargo/cargo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -17,20 +17,23 @@ IUSE=""
EGIT_REPO_URI="git://github.com/rust-lang/cargo.git"
-DEPEND=">=virtual/rust-999"
-RDEPEND="${DEPEND}"
+RDEPEND=">=virtual/rust-999"
+DEPEND="${DEPEND}
+ dev-util/cmake"
src_prepare() {
- epatch "${FILESDIR}/${P}-no-ldconfig.patch"
+ use x86 && export BITS=32
+ CFG_DISABLE_LDCONFIG="nonempty" ./.travis.install.deps.sh || die
}
src_configure() {
- "${ECONF_SOURCE:-.}"/configure \
+ ./configure \
+ --local-rust-root="${PWD}/rustc" \
--prefix="${EPREFIX}"/usr \
- --local-rust-root="${EPREFIX}"/usr \
+ --disable-verify-install \
|| die
}
src_install() {
- emake DESTDIR="${D}" install || die
+ CFG_DISABLE_LDCONFIG="true" emake DESTDIR="${D}" install || die
}
diff --git a/dev-rust/cargo/files/cargo-9999-no-ldconfig.patch b/dev-rust/cargo/files/cargo-9999-no-ldconfig.patch
deleted file mode 100644
index 919fa30..0000000
--- a/dev-rust/cargo/files/cargo-9999-no-ldconfig.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Remove ldconfig(1) execution to prevent the installation script from accessing
-outside of a sandbox.
-
-diff --git a/install-template.sh b/install-template.sh
-index 11bf392..bc579f5 100644
---- a/src/rust-installer/install-template.sh
-+++ b/src/rust-installer/install-template.sh
-@@ -697,17 +697,6 @@ done
- # Drop the version number into the manifest dir
- echo "$TEMPLATE_RUST_INSTALLER_VERSION" > "${ABS_LIBDIR}/${TEMPLATE_REL_MANIFEST_DIR}/rust-installer-version"
-
--# Run ldconfig to make dynamic libraries available to the linker
--if [ "$CFG_OSTYPE" = "unknown-linux-gnu" -a ! -n "$CFG_DISABLE_LDCONFIG" ]; then
-- msg "running ldconfig"
-- ldconfig
-- if [ $? -ne 0 ]
-- then
-- warn "failed to run ldconfig."
-- warn "this may happen when not installing as root and may be fine"
-- fi
--fi
--
- # Sanity check: can we run the installed binaries?
- #
- # As with the verification above, make sure the right LD_LIBRARY_PATH-equivalent