aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgentoo90 <gentoo90@gmail.com>2015-04-07 18:59:20 +0300
committergentoo90 <gentoo90@gmail.com>2015-04-07 18:59:20 +0300
commit3975792e1b103071ea2cbcf19a187bf8f6dbb793 (patch)
treef5d231bcfedc7b9fe8e73c985607ac4ff8383fad /dev-rust
parentMerge pull request #96 from geovex/beta (diff)
downloadrust-3975792e1b103071ea2cbcf19a187bf8f6dbb793.tar.gz
rust-3975792e1b103071ea2cbcf19a187bf8f6dbb793.tar.bz2
rust-3975792e1b103071ea2cbcf19a187bf8f6dbb793.zip
dev-rust/cargo: put the bash-completion file to the right place
Diffstat (limited to 'dev-rust')
-rw-r--r--dev-rust/cargo/cargo-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-rust/cargo/cargo-9999.ebuild b/dev-rust/cargo/cargo-9999.ebuild
index 157e09c..3c35f55 100644
--- a/dev-rust/cargo/cargo-9999.ebuild
+++ b/dev-rust/cargo/cargo-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils git-r3
+inherit eutils bash-completion-r1 git-r3
DESCRIPTION="A Rust's package manager"
HOMEPAGE="http://crates.io/"
@@ -36,4 +36,6 @@ src_configure() {
src_install() {
CFG_DISABLE_LDCONFIG="true" emake DESTDIR="${D}" install || die
+ dobashcomp "${ED}"/usr/etc/bash_completion.d/cargo
+ rm -rf "${ED}"/usr/etc
}