aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgentoo90 <gentoo90@gmail.com>2015-04-09 11:15:27 +0300
committergentoo90 <gentoo90@gmail.com>2015-04-09 12:05:26 +0300
commit7703a331f377b46c52c94da935d01e888418665d (patch)
treec25e91f0e619b0e90ba191dbba2ded8ff59d5ca8 /dev-rust/cargo/cargo-9999.ebuild
parentdev-rust/cargo: fix #42 (diff)
downloadrust-7703a331f377b46c52c94da935d01e888418665d.tar.gz
rust-7703a331f377b46c52c94da935d01e888418665d.tar.bz2
rust-7703a331f377b46c52c94da935d01e888418665d.zip
dev-rust/cargo: add dependencies
If this libs are missing from system, cargo will statically link to its own bundled libs. But if they are present, then there is no way to prevent cargo dynamically linking against them.
Diffstat (limited to 'dev-rust/cargo/cargo-9999.ebuild')
-rw-r--r--dev-rust/cargo/cargo-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-rust/cargo/cargo-9999.ebuild b/dev-rust/cargo/cargo-9999.ebuild
index 6d66e85..0dbcf8c 100644
--- a/dev-rust/cargo/cargo-9999.ebuild
+++ b/dev-rust/cargo/cargo-9999.ebuild
@@ -17,7 +17,11 @@ IUSE=""
EGIT_REPO_URI="https://github.com/rust-lang/cargo.git"
-COMMON_DEPEND=">=virtual/rust-999"
+COMMON_DEPEND=">=virtual/rust-999
+ sys-libs/zlib
+ dev-libs/openssl
+ net-libs/libssh2
+ net-libs/http-parser"
RDEPEND="${COMMON_DEPEND}
net-misc/curl[curl_ssl_openssl]"
DEPEND="${COMMON_DEPEND}