aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorO01eg <o01eg@yandex.ru>2015-10-07 23:38:56 +0300
committerO01eg <o01eg@yandex.ru>2015-10-07 23:58:11 +0300
commit80d6d3db4e83347e833251c3e0c9b6cd40550976 (patch)
tree05c811af4def2028d61ea419d55d76d108a96700 /app-vim
parentdev-utils/racer: Remove vim and emacs plugins installation. ToDo: create ebui... (diff)
downloadrust-80d6d3db4e83347e833251c3e0c9b6cd40550976.tar.gz
rust-80d6d3db4e83347e833251c3e0c9b6cd40550976.tar.bz2
rust-80d6d3db4e83347e833251c3e0c9b6cd40550976.zip
app-vim/vim-racer: Add vim plugin for racer.
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vim-racer/metadata.xml12
-rw-r--r--app-vim/vim-racer/vim-racer-9999.ebuild29
2 files changed, 41 insertions, 0 deletions
diff --git a/app-vim/vim-racer/metadata.xml b/app-vim/vim-racer/metadata.xml
new file mode 100644
index 0000000..6776b6e
--- /dev/null
+++ b/app-vim/vim-racer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vim</herd>
+<maintainer>
+ <email>o01eg@yandex.ru</email>
+ <name>O01eg</name>
+ </maintainer>
+<longdescription lang="en">
+ Vim plugin for racer - RUST completion utility.
+</longdescription>
+</pkgmetadata>
diff --git a/app-vim/vim-racer/vim-racer-9999.ebuild b/app-vim/vim-racer/vim-racer-9999.ebuild
new file mode 100644
index 0000000..3d39cc7
--- /dev/null
+++ b/app-vim/vim-racer/vim-racer-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin git-r3
+
+DESCRIPTION="vim plugin: racer support"
+HOMEPAGE="https://github.com/racer-rust/vim-racer"
+LICENSE="MIT"
+KEYWORDS=""
+IUSE=""
+EGIT_REPO_URI="https://github.com/racer-rust/vim-racer"
+RDEPEND="dev-util/racer"
+
+src_prepare() {
+ sed -i 's|\(g:racer_cmd = \).*|\1"/usr/bin/racer"|' plugin/racer.vim
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ elog "For vim you can use 'let \$RUST_SRC_PATH=\"<path-to>/rust/src/\"'"
+ elog "if you don't want to use environment variable"
+ elog "You also can use \"set hidden\" or else your buffer will be"
+ elog "unloaded on every goto-definition"
+}
+