aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOGINO Masanori <masanori.ogino@gmail.com>2014-02-09 09:24:35 +0900
committerOGINO Masanori <masanori.ogino@gmail.com>2014-02-09 09:24:35 +0900
commit065616900e25433f551a082a099e595373f36555 (patch)
tree500b06d46fb878ce80c71ec709c45f15e4ca975b /app-vim
parentMake get-snapshot.py working. (diff)
downloadrust-065616900e25433f551a082a099e595373f36555.tar.gz
rust-065616900e25433f551a082a099e595373f36555.tar.bz2
rust-065616900e25433f551a082a099e595373f36555.zip
Add editor support packages for Rust 0.9.
Signed-off-by: OGINO Masanori <masanori.ogino@gmail.com>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/rust-mode/rust-mode-0.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-vim/rust-mode/rust-mode-0.9.ebuild b/app-vim/rust-mode/rust-mode-0.9.ebuild
new file mode 100644
index 0000000..f549c3a
--- /dev/null
+++ b/app-vim/rust-mode/rust-mode-0.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax highlighting, indentation, quickfix and other useful things for editing Rust code"
+HOMEPAGE="http://www.rust-lang.org/"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+if [[ ${PV} != 9999 ]]; then
+ MY_P="rust-${PV}"
+ SRC_URI="http://static.rust-lang.org/dist/${MY_P}.tar.gz"
+
+ S="${WORKDIR}/${MY_P}/src/etc/vim"
+else
+ EGIT_SOURCEDIR="${S}"
+ S="${S}/src/etc/vim"
+
+ inherit git-2
+
+ EGIT_REPO_URI="git://github.com/mozilla/rust.git"
+fi
+
+src_configure() {
+ echo "just for suppressing econf"
+}