aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorstefson <herrtimson@yahoo.de>2019-07-18 15:40:36 +0200
committerstefson <herrtimson@yahoo.de>2019-07-18 15:40:36 +0200
commit664165e622653c667226ab6c1275a66efd9e44cf (patch)
tree66ae640b6f2ebe922ea1fd94ec8efd1028d414a7
parentdev-rust/cranelift: update some deps (diff)
downloadrust-664165e622653c667226ab6c1275a66efd9e44cf.tar.gz
rust-664165e622653c667226ab6c1275a66efd9e44cf.tar.bz2
rust-664165e622653c667226ab6c1275a66efd9e44cf.zip
dev-rust/cranelift: add tests
-rw-r--r--dev-rust/cranelift-tools/cranelift-tools-0.35.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-rust/cranelift-tools/cranelift-tools-0.35.0.ebuild b/dev-rust/cranelift-tools/cranelift-tools-0.35.0.ebuild
index 1b41c9f..b7353db 100644
--- a/dev-rust/cranelift-tools/cranelift-tools-0.35.0.ebuild
+++ b/dev-rust/cranelift-tools/cranelift-tools-0.35.0.ebuild
@@ -136,7 +136,7 @@ RESTRICT="mirror"
LICENSE="apache-2.0-with-llvm-exception"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="test"
DEPEND=">=virtual/rust-1.35.0"
RDEPEND=""
@@ -153,6 +153,10 @@ src_compile() {
cargo build -j$(makeopts_jobs) --release || die
}
+src_test() {
+ cargo test || die "tests failed"
+}
+
src_install() {
dobin target/release/clif-util
}