aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <w.d.hubbs@gmail.com>2015-02-05 12:32:38 -0600
committerWilliam Hubbs <w.d.hubbs@gmail.com>2015-02-05 13:58:40 -0600
commit4cfb11c3f202588a8e5f7af023b3b0d449ebc66a (patch)
tree7b08b19ee5feec621dbeab2e932f28021783d9b7
parentMerge pull request #67 from williamh/fix-racer (diff)
downloadrust-4cfb11c3f202588a8e5f7af023b3b0d449ebc66a.tar.gz
rust-4cfb11c3f202588a8e5f7af023b3b0d449ebc66a.tar.bz2
rust-4cfb11c3f202588a8e5f7af023b3b0d449ebc66a.zip
Remove some unnecessary live ebuild revisions
The only thing that changed in these was the upstream locations. Also, since these are live ebuilds, we don't really need to do revision bumps.
-rw-r--r--app-emacs/rust-mode/rust-mode-9999-r1.ebuild23
-rw-r--r--app-emacs/rust-mode/rust-mode-9999.ebuild5
-rw-r--r--app-shells/rust-zshcomp/rust-zshcomp-9999-r1.ebuild28
-rw-r--r--app-shells/rust-zshcomp/rust-zshcomp-9999.ebuild13
-rw-r--r--app-vim/rust-mode/rust-mode-9999-r1.ebuild21
-rw-r--r--app-vim/rust-mode/rust-mode-9999.ebuild5
6 files changed, 4 insertions, 91 deletions
diff --git a/app-emacs/rust-mode/rust-mode-9999-r1.ebuild b/app-emacs/rust-mode/rust-mode-9999-r1.ebuild
deleted file mode 100644
index ba78455..0000000
--- a/app-emacs/rust-mode/rust-mode-9999-r1.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-inherit elisp git-r3
-
-DESCRIPTION="A major emacs mode for editing Rust source code"
-HOMEPAGE="http://www.rust-lang.org/"
-EGIT_REPO_URI="https://github.com/rust-lang/rust-mode"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS=""
-
-DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
- !<=dev-lang/rust-0.11.0-r1:0.11
- !<=dev-lang/rust-999:nightly
- !<=dev-lang/rust-9999-r2:git
-"
-
-SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/rust-mode/rust-mode-9999.ebuild b/app-emacs/rust-mode/rust-mode-9999.ebuild
index 5709bc1..68cb959 100644
--- a/app-emacs/rust-mode/rust-mode-9999.ebuild
+++ b/app-emacs/rust-mode/rust-mode-9999.ebuild
@@ -8,11 +8,10 @@ inherit elisp git-r3
DESCRIPTION="A major emacs mode for editing Rust source code"
HOMEPAGE="http://www.rust-lang.org/"
-EGIT_REPO_URI="git://github.com/rust-lang/rust.git"
+EGIT_REPO_URI="https://github.com/rust-lang/rust-mode"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
-KEYWORDS=""
DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
!<=dev-lang/rust-0.11.0-r1:0.11
@@ -20,6 +19,4 @@ DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
!<=dev-lang/rust-9999-r2:git
"
-S="${S}/src/etc/emacs"
-
SITEFILE="50${PN}-gentoo.el"
diff --git a/app-shells/rust-zshcomp/rust-zshcomp-9999-r1.ebuild b/app-shells/rust-zshcomp/rust-zshcomp-9999-r1.ebuild
deleted file mode 100644
index 1c543fc..0000000
--- a/app-shells/rust-zshcomp/rust-zshcomp-9999-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-inherit git-r3
-
-DESCRIPTION="Rust zsh completions"
-HOMEPAGE="http://www.rust-lang.org/"
-EGIT_REPO_URI="https://github.com/rust-lang/zsh-config"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS=""
-
-DEPEND="app-shells/zsh
- !!<=app-admin/eselect-rust-0.1_pre20140820
- !<=dev-lang/rust-0.11.0-r1:0.11
- !<=dev-lang/rust-999:nightly
- !<=dev-lang/rust-9999-r2:git
-"
-RDEPEND="${DEPEND}"
-
-src_install() {
- insinto /usr/share/zsh/site-functions
- doins _rust
-}
diff --git a/app-shells/rust-zshcomp/rust-zshcomp-9999.ebuild b/app-shells/rust-zshcomp/rust-zshcomp-9999.ebuild
index 3b7f0ca..6266ea2 100644
--- a/app-shells/rust-zshcomp/rust-zshcomp-9999.ebuild
+++ b/app-shells/rust-zshcomp/rust-zshcomp-9999.ebuild
@@ -8,11 +8,10 @@ inherit git-r3
DESCRIPTION="Rust zsh completions"
HOMEPAGE="http://www.rust-lang.org/"
-EGIT_REPO_URI="git://github.com/rust-lang/rust.git"
+EGIT_REPO_URI="https://github.com/rust-lang/zsh-config"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
-KEYWORDS=""
DEPEND="app-shells/zsh
!!<=app-admin/eselect-rust-0.1_pre20140820
@@ -22,15 +21,7 @@ DEPEND="app-shells/zsh
"
RDEPEND="${DEPEND}"
-src_configure() {
- :
-}
-
-src_compile() {
- :
-}
-
src_install() {
insinto /usr/share/zsh/site-functions
- doins src/etc/zsh/_rust
+ doins _rust
}
diff --git a/app-vim/rust-mode/rust-mode-9999-r1.ebuild b/app-vim/rust-mode/rust-mode-9999-r1.ebuild
deleted file mode 100644
index 12dc204..0000000
--- a/app-vim/rust-mode/rust-mode-9999-r1.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-
-inherit vim-plugin git-r3
-
-DESCRIPTION="Rust mode for vim"
-HOMEPAGE="http://www.rust-lang.org/"
-EGIT_REPO_URI="https://github.com/rust-lang/rust.vim"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS=""
-
-DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
- !<=dev-lang/rust-0.11.0-r1:0.11
- !<=dev-lang/rust-999:nightly
- !<=dev-lang/rust-9999-r2:git
-"
diff --git a/app-vim/rust-mode/rust-mode-9999.ebuild b/app-vim/rust-mode/rust-mode-9999.ebuild
index 069a772..42fb997 100644
--- a/app-vim/rust-mode/rust-mode-9999.ebuild
+++ b/app-vim/rust-mode/rust-mode-9999.ebuild
@@ -8,16 +8,13 @@ inherit vim-plugin git-r3
DESCRIPTION="Rust mode for vim"
HOMEPAGE="http://www.rust-lang.org/"
-EGIT_REPO_URI="git://github.com/rust-lang/rust.git"
+EGIT_REPO_URI="https://github.com/rust-lang/rust.vim"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
-KEYWORDS=""
DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
!<=dev-lang/rust-0.11.0-r1:0.11
!<=dev-lang/rust-999:nightly
!<=dev-lang/rust-9999-r2:git
"
-
-S="${S}/src/etc/vim"