aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberg <david@ixit.cz>2020-04-12 21:15:09 +0200
committerMikhail Pukhlikov <cynede@gentoo.org>2020-05-25 13:53:39 +0400
commit34cfff090ed5b13c5d8b8ddf0bb9e2e70b258d7d (patch)
tree5285a7c634ec723383c283bedec92e5aa4e9be43
parentvirtual/rust: multilib support (diff)
downloadrust-34cfff090ed5b13c5d8b8ddf0bb9e2e70b258d7d.tar.gz
rust-34cfff090ed5b13c5d8b8ddf0bb9e2e70b258d7d.tar.bz2
rust-34cfff090ed5b13c5d8b8ddf0bb9e2e70b258d7d.zip
dev-lang/rust-bin: keywords mask -999 & -9999 ebuilds
Signed-off-by: David Heidelberg <david@ixit.cz> Closes: https://github.com/gentoo/gentoo-rust/pull/482 Signed-off-by: Mikhail Pukhlikov <cynede@gentoo.org>
-rw-r--r--dev-lang/rust-bin/rust-bin-999.ebuild7
-rw-r--r--dev-lang/rust-bin/rust-bin-9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/dev-lang/rust-bin/rust-bin-999.ebuild b/dev-lang/rust-bin/rust-bin-999.ebuild
index 69c73c4..e1e5699 100644
--- a/dev-lang/rust-bin/rust-bin-999.ebuild
+++ b/dev-lang/rust-bin/rust-bin-999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,12 +17,13 @@ ALL_RUSTLIB_TARGETS=( "${ALL_RUSTLIB_TARGETS[@]/#/rustlib_targets_}" )
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="beta"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS=""
RESTRICT="network-sandbox"
IUSE="clippy cpu_flags_x86_sse2 doc libressl rls rustfmt ${ALL_RUSTLIB_TARGETS[*]}"
-CDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
+CDEPEND="
+ >=app-eselect/eselect-rust-0.3_pre20150425
!dev-lang/rust:0
rustfmt? ( !dev-util/rustfmt )
"
diff --git a/dev-lang/rust-bin/rust-bin-9999.ebuild b/dev-lang/rust-bin/rust-bin-9999.ebuild
index 3eb3dbc..bd0fb59 100644
--- a/dev-lang/rust-bin/rust-bin-9999.ebuild
+++ b/dev-lang/rust-bin/rust-bin-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,12 +22,13 @@ ALL_RUSTLIB_TARGETS=( "${ALL_RUSTLIB_TARGETS[@]/#/rustlib_targets_}" )
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="nightly"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS=""
RESTRICT="network-sandbox"
IUSE="clippy cpu_flags_x86_sse2 doc libressl rls rustfmt ${ALL_RUSTLIB_TARGETS[*]}"
-CDEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
+CDEPEND="
+ >=app-eselect/eselect-rust-0.3_pre20150425
!dev-lang/rust:0
rustfmt? ( !dev-util/rustfmt )
"