summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2023-09-10 09:20:11 +0200
committerFabian Groffen <grobian@gentoo.org>2023-09-10 09:20:11 +0200
commit6fba26061d757780eed5b0a67fa3dbac9b66c21e (patch)
tree7a6cce372d586aa3c483eff142e3d3476068ed4c /sys-devel
parenttoolchain.eclass: fix merge error (diff)
downloadprefix-6fba26061d757780eed5b0a67fa3dbac9b66c21e.tar.gz
prefix-6fba26061d757780eed5b0a67fa3dbac9b66c21e.tar.bz2
prefix-6fba26061d757780eed5b0a67fa3dbac9b66c21e.zip
sys-devel/gcc-12.2.0-r2: fix ld64 version detection
darwin-xtools emits ld64-.* twice, so ensure we only see it once to unbreak the build. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-12.2.0-r2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-12.2.0-r2.ebuild b/sys-devel/gcc/gcc-12.2.0-r2.ebuild
index dc747f7475..d7932fa7ae 100644
--- a/sys-devel/gcc/gcc-12.2.0-r2.ebuild
+++ b/sys-devel/gcc/gcc-12.2.0-r2.ebuild
@@ -86,6 +86,10 @@ src_prepare() {
# situation is tricky and needs careful considerations.
# For now, just disable support for "-stdlib=libc++".
eapply "${FILESDIR}"/gcc-12.2.0-disable-stdlib-option-on-darwin.patch
+
+ # our ld64 is a slight bit different, so tweak expression to not
+ # get confused and break the build
+ sed -i -e 's/grep ld64/grep :ld64/' gcc/configure || die
fi
}