summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-06-21 20:36:37 +0200
committerFabian Groffen <grobian@gentoo.org>2021-06-21 20:36:37 +0200
commit99f0a2cdbd595af380bcbedf82483462ea5ce2e7 (patch)
tree10ebd10e7df15928304dda3451165a08d553c1e0 /dev-libs
parent.github: Add ::gentoo as master for overlay (diff)
downloadprefix-99f0a2cdbd595af380bcbedf82483462ea5ce2e7.tar.gz
prefix-99f0a2cdbd595af380bcbedf82483462ea5ce2e7.tar.bz2
prefix-99f0a2cdbd595af380bcbedf82483462ea5ce2e7.zip
dev-libs/openssl-1.1.1k: minimise diffs with gx86
Package-Manager: Portage-3.0.18-prefix, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/openssl-1.1.1k.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/dev-libs/openssl/openssl-1.1.1k.ebuild b/dev-libs/openssl/openssl-1.1.1k.ebuild
index 49ce2a7da9..ce544b470d 100644
--- a/dev-libs/openssl/openssl-1.1.1k.ebuild
+++ b/dev-libs/openssl/openssl-1.1.1k.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit flag-o-matic toolchain-funcs multilib multilib-minimal
+inherit flag-o-matic toolchain-funcs multilib-minimal
MY_P=${P/_/-}
@@ -283,6 +283,15 @@ multilib_src_install() {
fi
emake DESTDIR="${D}" install
+
+ # This is crappy in that the static archives are still built even
+ # when USE=static-libs. But this is due to a failing in the openssl
+ # build system: the static archives are built as PIC all the time.
+ # Only way around this would be to manually configure+compile openssl
+ # twice; once with shared lib support enabled and once without.
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/lib{crypto,ssl}.a || die
+ fi
}
multilib_src_install_all() {
@@ -292,13 +301,6 @@ multilib_src_install_all() {
dodoc CHANGES* FAQ NEWS README doc/*.txt doc/${PN}-c-indent.el
- # This is crappy in that the static archives are still built even
- # when USE=static-libs. But this is due to a failing in the openssl
- # build system: the static archives are built as PIC all the time.
- # Only way around this would be to manually configure+compile openssl
- # twice; once with shared lib support enabled and once without.
- use static-libs || rm -f "${ED}"/usr/lib*/lib*.a
-
# create the certs directory
keepdir ${SSL_CNF_DIR}/certs