aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2018-06-27 21:13:51 +0200
committerBart Ribbers <bribbers@disroot.org>2018-06-27 21:13:51 +0200
commit746a3cf4a35c0127e01285f412c152c9a24532c1 (patch)
treed221bf0ef3f8cc4feb8bb6d1173f7003518f3333 /net-im
parentUpdate Quaternion to 0.0.9.2 and add some missing mtxclient dependencies (diff)
downloadmatrix-746a3cf4a35c0127e01285f412c152c9a24532c1.tar.gz
matrix-746a3cf4a35c0127e01285f412c152c9a24532c1.tar.bz2
matrix-746a3cf4a35c0127e01285f412c152c9a24532c1.zip
Add new Matrix client: GNOME's Fractal
Diffstat (limited to 'net-im')
-rw-r--r--net-im/fractal/Manifest2
-rw-r--r--net-im/fractal/fractal-3.29.1.ebuild37
-rw-r--r--net-im/fractal/fractal-9999.ebuild40
3 files changed, 79 insertions, 0 deletions
diff --git a/net-im/fractal/Manifest b/net-im/fractal/Manifest
new file mode 100644
index 0000000..c0b15cf
--- /dev/null
+++ b/net-im/fractal/Manifest
@@ -0,0 +1,2 @@
+EBUILD fractal-3.29.1.ebuild 716 BLAKE2B 32f528bb398a51c660eae5242ca39157b2e2f531deebf0707625e9df775a1fc3f0d4d9f6bf27b3c2c73b2add66ad76df52ebc0d98d1a67bb229ec8531c4e8296 SHA512 bda4f3e22871204dd637ca5a0b7a3e1583a734441c3943dab02a6896e1287b1641093e5e2a8b09d731e7c115e0176462821469b63eb97475b77daf00a7d748a1
+EBUILD fractal-9999.ebuild 796 BLAKE2B e8787ccc025a41431f81dccebf7a93926f7752fbed629cf7a7fed16c310a071f1fdde8801c786c90f4553192a30958b280ca82536da82d7f2334f0d474b399d8 SHA512 94a5836b5d1f7af066367347d46c07143fb4afee4caa0127cb84175a8bedca345c94e39fefbdb051141d0885a3011c14a30f4c7a782a6fad005e32b329e82253
diff --git a/net-im/fractal/fractal-3.29.1.ebuild b/net-im/fractal/fractal-3.29.1.ebuild
new file mode 100644
index 0000000..26a1cf2
--- /dev/null
+++ b/net-im/fractal/fractal-3.29.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Matrix group messaging app"
+HOMEPAGE="https://wiki.gnome.org/Apps/Fractal"
+
+inherit git-r3 meson xdg-utils gnome2-utils
+
+EGIT_REPO_URI="https://gitlab.gnome.org/world/fractal.git"
+if [[ ${PV} != "9999" ]]; then
+ EGIT_COMMIT="${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-lang/rust
+ >=app-text/gspell-1.8.1"
+DEPEND="${RDEPEND}
+ dev-util/ninja
+ dev-util/meson
+ dev-util/ninja
+ dev-util/cargo"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
diff --git a/net-im/fractal/fractal-9999.ebuild b/net-im/fractal/fractal-9999.ebuild
new file mode 100644
index 0000000..f6a03d6
--- /dev/null
+++ b/net-im/fractal/fractal-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Matrix group messaging app"
+HOMEPAGE="https://wiki.gnome.org/Apps/Fractal"
+
+inherit git-r3 meson xdg-utils gnome2-utils
+
+EGIT_REPO_URI="https://gitlab.gnome.org/world/fractal.git"
+if [[ ${PV} != "9999" ]]; then
+ EGIT_COMMIT="v${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-lang/rust
+ media-libs/gstreamer
+ media-libs/gst-plugins-base
+ media-libs/gst-plugins-bad
+ >=app-text/gspell-1.8.1"
+DEPEND="${RDEPEND}
+ dev-util/ninja
+ dev-util/meson
+ dev-util/ninja
+ dev-util/cargo"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}