aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMichael Englehorn <michael@englehorn.com>2019-10-19 09:53:15 -0500
committerBart Ribbers <bribbers@disroot.org>2019-10-20 13:11:14 +0200
commit7183d5e7458e51af9384ca940f1bd9adf37e6de1 (patch)
tree0cbbe6ae4da4a21c4c79d102e594f3b709f82934 /net-im
parentdev-libs/mtxclient: drop nlohmann_json patch (diff)
downloadmatrix-7183d5e7458e51af9384ca940f1bd9adf37e6de1.tar.gz
matrix-7183d5e7458e51af9384ca940f1bd9adf37e6de1.tar.bz2
matrix-7183d5e7458e51af9384ca940f1bd9adf37e6de1.zip
net-im/riot-web: fix electron build
`node_modules/.bin/build` became `node_modules/.bin/electron-builder`, the build was failing before this change to the ebuild.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/riot-web/riot-web-1.5.0-r1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/net-im/riot-web/riot-web-1.5.0-r1.ebuild b/net-im/riot-web/riot-web-1.5.0-r1.ebuild
new file mode 100644
index 0000000..19c5abb
--- /dev/null
+++ b/net-im/riot-web/riot-web-1.5.0-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A glossy Matrix collaboration client for the web"
+HOMEPAGE="https://riot.im"
+
+inherit eutils gnome2-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/vector-im/riot-web.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/vector-im/riot-web/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+emoji"
+REQUIRED_USE=""
+
+DEPEND="sys-devel/binutils:*
+ net-libs/nodejs
+ sys-apps/yarn
+ x11-libs/libXScrnSaver
+ net-print/cups
+ dev-libs/nss
+ gnome-base/gconf
+ emoji? ( >=media-fonts/noto-emoji-20180823 )"
+RDEPEND="${DEPEND}"
+
+QA_PREBUILT="
+ opt/Riot/libffmpeg.so
+ opt/Riot/libnode.so
+ opt/Riot/riot-web"
+
+DESTINATION="/" # We build and unpack a Debian installer, which already has everything in the proper directories {usr,opt}, so we just set the destination to "/"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == "9999" ]]; then
+ "${S}"/scripts/fetch-develop.deps.sh
+ fi
+
+ yarn install || die "Yarn module installation failed"
+
+ cp "${S}"/config.sample.json "${S}"/config.json
+}
+
+src_compile() {
+ yarn run build || die "Build failed"
+
+ "${S}"/node_modules/.bin/electron-builder --linux --x64 || die "Bundling failed"
+}
+
+src_install() {
+ ar x "${S}"/electron_app/dist/riot-web*.deb
+ tar xvf data.tar.xz
+
+ mv usr/share/doc/${PN} usr/share/doc/${PF}
+ gunzip usr/share/doc/${PF}/changelog.gz
+ insinto ${DESTINATION}
+ doins -r usr
+ doins -r opt
+ fperms +x /opt/Riot/${PN}
+ dosym ${DESTINATION}/opt/Riot/${PN} ${DESTINATION}/usr/bin/${PN}
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}