aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDeepBlueV7.X <nicolas.werner@gmx.net>2019-05-06 14:13:30 +0000
committerPureTryOut <bribbers@disroot.org>2019-05-06 14:13:30 +0000
commitda1a8b351b91087412dd6843bbc0454a62e3ff2c (patch)
tree23096ee8de3a8cdd98be9c14d0417ec092ac889a /dev-libs
parentnet-im/spectral: add emojis recommended by upstream (diff)
downloadmatrix-da1a8b351b91087412dd6843bbc0454a62e3ff2c.tar.gz
matrix-da1a8b351b91087412dd6843bbc0454a62e3ff2c.tar.bz2
matrix-da1a8b351b91087412dd6843bbc0454a62e3ff2c.zip
net-im/nheko(-reborn): re-add
This adds Nheko back to the repository which was removed because the old maintainer didn't have that much time to maintain it anymore. Since then development resumed in the Nheko-Reborn repository and development is somewhat active. Currently this doesn't build with the upstream nlohmann_json and it has some issues with const variables used in a non-const context, so there are some manual patches needed.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mtxclient/Manifest1
-rw-r--r--dev-libs/mtxclient/files/find_nlohmann_json_meson.patch37
-rw-r--r--dev-libs/mtxclient/metadata.xml16
-rw-r--r--dev-libs/mtxclient/mtxclient-0.2.0.ebuild43
-rw-r--r--dev-libs/mtxclient/mtxclient-9999.ebuild43
-rw-r--r--dev-libs/tweeny/Manifest1
-rw-r--r--dev-libs/tweeny/metadata.xml18
-rw-r--r--dev-libs/tweeny/tweeny-3.ebuild26
8 files changed, 185 insertions, 0 deletions
diff --git a/dev-libs/mtxclient/Manifest b/dev-libs/mtxclient/Manifest
new file mode 100644
index 0000000..f38798c
--- /dev/null
+++ b/dev-libs/mtxclient/Manifest
@@ -0,0 +1 @@
+DIST mtxclient-0.2.0.tar.gz 477869 BLAKE2B 714f826b405b88a9eee795cc58777c3ca2d5e76f8bf1611b7e7508f132a2ab2ab65513b59a9163fb2e2f39f256c8cad9cb26631d5dab5c568baae4b6aa89787d SHA512 ce8b6846c803913dd9c1a9e855099d491cb7ba85bd191eb742b498cba9cc5d09ad8768857f8f1972a5376056ff02b22470e87e3b7e99e31e887e29d43b8d2d37
diff --git a/dev-libs/mtxclient/files/find_nlohmann_json_meson.patch b/dev-libs/mtxclient/files/find_nlohmann_json_meson.patch
new file mode 100644
index 0000000..2cde441
--- /dev/null
+++ b/dev-libs/mtxclient/files/find_nlohmann_json_meson.patch
@@ -0,0 +1,37 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 71058f0..5882591 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -81,12 +81,7 @@ set_package_properties(sodium PROPERTIES
+ TYPE REQUIRED
+ )
+
+-find_package(nlohmann_json 3.2.0)
+-set_package_properties(nlohmann_json PROPERTIES
+- DESCRIPTION "JSON for Modern C++, a C++11 header-only JSON class"
+- URL "https://nlohmann.github.io/json/"
+- TYPE REQUIRED
+-)
++pkg_search_module(JSON REQUIRED nlohmann_json>=3.2.0)
+
+ set(Boost_USE_STATIC_LIBS OFF)
+ set(Boost_USE_STATIC_RUNTIME OFF)
+@@ -157,7 +152,8 @@ target_include_directories(matrix_client
+ PUBLIC
+ ${Boost_INCLUDE_DIRS}
+ ${OPENSSL_INCLUDE_DIR}
+- ${sodium_INCLUDE_DIR})
++ ${sodium_INCLUDE_DIR}
++ ${JSON_INCLUDE_DIRS})
+ target_include_directories(
+ matrix_client
+ PUBLIC
+@@ -171,7 +167,7 @@ target_link_libraries(matrix_client
+ OpenSSL::SSL
+ Olm::Olm
+ ZLIB::ZLIB
+- nlohmann_json::nlohmann_json)
++ ${JSON_LIBRARIES})
+
+ if(NOT MSVC AND NOT APPLE)
+ target_link_libraries(matrix_client PUBLIC Threads::Threads)
diff --git a/dev-libs/mtxclient/metadata.xml b/dev-libs/mtxclient/metadata.xml
new file mode 100644
index 0000000..c7fefe0
--- /dev/null
+++ b/dev-libs/mtxclient/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>nicolas.werner@hotmail.de</email>
+</maintainer>
+<upstream>
+<maintainer status="active">
+<name>Joseph Donofry</name>
+<email>joedonofry@gmail.com</email>
+</maintainer>
+</upstream>
+<longdescription lang="en">
+Client API library for the Matrix protocol, built on top of Boost.Asio.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-libs/mtxclient/mtxclient-0.2.0.ebuild b/dev-libs/mtxclient/mtxclient-0.2.0.ebuild
new file mode 100644
index 0000000..36965f1
--- /dev/null
+++ b/dev-libs/mtxclient/mtxclient-0.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="An implementation of the Double Ratchet cryptographic ratchet in C++"
+HOMEPAGE="https://github.com/Nheko-Reborn/mtxclient"
+
+inherit eutils cmake-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nheko-Reborn/${PN}.git"
+else
+ SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="-test"
+
+PATCHES=(
+ "${FILESDIR}/find_nlohmann_json_meson.patch"
+)
+RDEPEND="
+ dev-libs/libsodium
+ >=dev-libs/boost-1.66.0
+ dev-libs/olm"
+DEPEND="${RDEPEND}
+ dev-libs/spdlog
+ dev-cpp/nlohmann_json
+ >=dev-util/cmake-3.11
+ test? ( dev-cpp/gtest )
+"
+#cmake >= 3.11 needed for boost deps
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_LIB_TESTS="$(usex test)"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/mtxclient/mtxclient-9999.ebuild b/dev-libs/mtxclient/mtxclient-9999.ebuild
new file mode 100644
index 0000000..36965f1
--- /dev/null
+++ b/dev-libs/mtxclient/mtxclient-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="An implementation of the Double Ratchet cryptographic ratchet in C++"
+HOMEPAGE="https://github.com/Nheko-Reborn/mtxclient"
+
+inherit eutils cmake-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Nheko-Reborn/${PN}.git"
+else
+ SRC_URI="https://github.com/Nheko-Reborn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="-test"
+
+PATCHES=(
+ "${FILESDIR}/find_nlohmann_json_meson.patch"
+)
+RDEPEND="
+ dev-libs/libsodium
+ >=dev-libs/boost-1.66.0
+ dev-libs/olm"
+DEPEND="${RDEPEND}
+ dev-libs/spdlog
+ dev-cpp/nlohmann_json
+ >=dev-util/cmake-3.11
+ test? ( dev-cpp/gtest )
+"
+#cmake >= 3.11 needed for boost deps
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_LIB_TESTS="$(usex test)"
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/tweeny/Manifest b/dev-libs/tweeny/Manifest
new file mode 100644
index 0000000..ab2308a
--- /dev/null
+++ b/dev-libs/tweeny/Manifest
@@ -0,0 +1 @@
+DIST tweeny-3.tar.gz 48997 BLAKE2B d9431f3135b763365bb679a964bdc73a0fa16a993a1b784381722d30bd9855f1467761796bad0b7894a4fc5434463e232b4f911707a7252a15a9f208106b697c SHA512 41f2562a0e55b0fd2c219fab384bf46f70432abb47953b5ac768a29b2ea7b790c6aa56fd44c1fef583f6fa2011010d7dd7e637bcd2d8a9be5c9638a7f2ce7436
diff --git a/dev-libs/tweeny/metadata.xml b/dev-libs/tweeny/metadata.xml
new file mode 100644
index 0000000..859ae68
--- /dev/null
+++ b/dev-libs/tweeny/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>nicolas.werner@hotmail.de</email>
+</maintainer>
+<upstream>
+<maintainer status="active">
+<name>Leonardo Guilherme de Freitas</name>
+<email>leonardo.guilherme@gmail.com</email>
+</maintainer>
+</upstream>
+<longdescription lang="en">
+Tweeny is an inbetweening library designed for the creation of complex animations for games and other beautiful interactive software. It leverages features of modern C++ to empower developers with an intuitive API for declaring tweenings of any type of value, as long as they support arithmetic operations.
+
+The goal of Tweeny is to provide means to create fluid interpolations when animating position, scale, rotation, frames or other values of screen objects, by setting their values as the tween starting point and then, after each tween step, plugging back the result.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-libs/tweeny/tweeny-3.ebuild b/dev-libs/tweeny/tweeny-3.ebuild
new file mode 100644
index 0000000..3fd2a37
--- /dev/null
+++ b/dev-libs/tweeny/tweeny-3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A modern C++ tweening library"
+HOMEPAGE="http://mobius3.github.io/tweeny"
+
+inherit eutils cmake-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/mobius3/${PN}.git"
+else
+ SRC_URI="https://github.com/mobius3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"