aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-01-20 07:32:12 -0800
committerorbea <orbea@riseup.net>2024-01-20 07:32:12 -0800
commitde2f7d31913e8bfc5f78d1e28e3ac3d2d3d91fc1 (patch)
tree65e7c2b58fe13879d3a51d825f4c313cca17927e /www-client
parentnet-misc/stunnel: stabilize 5.71-r1 for arm, ppc, ppc64 (diff)
downloadlibressl-de2f7d31913e8bfc5f78d1e28e3ac3d2d3d91fc1.tar.gz
libressl-de2f7d31913e8bfc5f78d1e28e3ac3d2d3d91fc1.tar.bz2
libressl-de2f7d31913e8bfc5f78d1e28e3ac3d2d3d91fc1.zip
www-client/netsurf: add 3.11, drop 3.10-r7
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/netsurf/Manifest2
-rw-r--r--www-client/netsurf/files/netsurf-3.10-gcc10-fno-common.patch23
-rw-r--r--www-client/netsurf/files/netsurf-3.11-libressl-3.5.patch (renamed from www-client/netsurf/files/netsurf-3.10-libressl-3.5.patch)25
-rw-r--r--www-client/netsurf/files/netsurf-3.9-conditionally-include-image-headers.patch35
-rw-r--r--www-client/netsurf/netsurf-3.11.ebuild (renamed from www-client/netsurf/netsurf-3.10-r7.ebuild)18
5 files changed, 12 insertions, 91 deletions
diff --git a/www-client/netsurf/Manifest b/www-client/netsurf/Manifest
index 974348b..13e202c 100644
--- a/www-client/netsurf/Manifest
+++ b/www-client/netsurf/Manifest
@@ -1 +1 @@
-DIST netsurf-3.10-src.tar.gz 4084480 BLAKE2B 267ce1811cbf11d053f721e22b8a6d484e796102a4c9baaa10580d92cc1eecfe3f126fb97456262675c962ec88a5235e48dc85f2a5168631f6c9dd5b5082b43b SHA512 1b1153916438e08146271dc04200aefbdba3b2c4ca9432a43abfc3811b5418df7ed21bbd91767f12d04331a236227379d2c412fcf13f25349685a549723bf13d
+DIST netsurf-3.11-src.tar.gz 4311767 BLAKE2B aa361b44ddb90fe513e0c34ae7d5f320037c439abb2455f50c224db118cf51da8bbeeac1276f0afdb5763287a6ffaba9d8fad460718ab0659871c1fda143513a SHA512 852ed7afe891828e7e594f1906ed5a7af9c62511b61dbe37ff1ca0700e3b08151db952ad47a18f9c8cfd3f6d78fd93485aa8e39de08eca904f5dbfa747af90c3
diff --git a/www-client/netsurf/files/netsurf-3.10-gcc10-fno-common.patch b/www-client/netsurf/files/netsurf-3.10-gcc10-fno-common.patch
deleted file mode 100644
index 677004c..0000000
--- a/www-client/netsurf/files/netsurf-3.10-gcc10-fno-common.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Backport of upstream fix: https://git.netsurf-browser.org/netsurf.git/commit/?id=434f6c3fe7d1d2c6a3e6ae6338608a4a4421ab1b
-
-https://bugs.netsurf-browser.org/mantis/view.php?id=2778
-https://bugs.gentoo.org/835379
---- a/frontends/framebuffer/convert_font.c
-+++ b/frontends/framebuffer/convert_font.c
-@@ -290,14 +290,14 @@ bool generate_font_header(const char *path, struct font_data *data)
-
-
- for (s = 0; s < 4; s++) {
-- fprintf(fp, "const uint8_t *%s_section_table;\n",
-+ fprintf(fp, "extern const uint8_t *%s_section_table;\n",
- var_lables[s]);
-- fprintf(fp, "const uint16_t *%s_sections;\n",
-+ fprintf(fp, "extern const uint16_t *%s_sections;\n",
- var_lables[s]);
-
- }
-
-- fprintf(fp, "const uint8_t *font_glyph_data;\n");
-+ fprintf(fp, "extern const uint8_t *font_glyph_data;\n");
-
- fprintf(fp, "\n\n");
diff --git a/www-client/netsurf/files/netsurf-3.10-libressl-3.5.patch b/www-client/netsurf/files/netsurf-3.11-libressl-3.5.patch
index d9add88..5efb701 100644
--- a/www-client/netsurf/files/netsurf-3.10-libressl-3.5.patch
+++ b/www-client/netsurf/files/netsurf-3.11-libressl-3.5.patch
@@ -2,10 +2,9 @@ X509_get_signature_nid(), ASN1_STRING_get0_data(), RSA_bits() and DH_bits()
have been available since LibreSSL 2.7.
DSA_bits(), RSA_get0_n(), RSA_get0_e() will be available in LibreSSL 3.5.
-Index: content/fetchers/about.c
---- a/content/fetchers/about.c
-+++ b/content/fetchers/about.c
-@@ -538,7 +538,8 @@ static nserror free_ns_cert_info(struct ns_cert_info *
+--- a/content/fetchers/about/certificate.c
++++ b/content/fetchers/about/certificate.c
+@@ -137,7 +137,8 @@ static nserror free_ns_cert_info(struct ns_cert_info *cinfo)
/* OpenSSL 1.0.x, 1.0.2, 1.1.0 and 1.1.1 API all changed
* LibreSSL declares its OpenSSL version as 2.1 but only supports 1.0.x API
*/
@@ -13,25 +12,11 @@ Index: content/fetchers/about.c
+#if (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x3050000fL) || \
+ (OPENSSL_VERSION_NUMBER < 0x1010000fL)
/* 1.0.x */
-
+
#if (defined(LIBRESSL_VERSION_NUMBER) || (OPENSSL_VERSION_NUMBER < 0x1000200fL))
-@@ -609,7 +610,7 @@ static const BIGNUM *ns_RSA_get0_e(const RSA *r)
- #define ns_DH_bits DH_bits
-
- #else
--/* 1.1.1 and later */
-+/* 1.1.1 and later, LibreSSL 3.5.0 and later */
- #define ns_X509_get_signature_nid X509_get_signature_nid
- #define ns_ASN1_STRING_get0_data ASN1_STRING_get0_data
- #define ns_RSA_get0_n RSA_get0_n
-
-X509_up_ref has been available since LibreSSL 2.5.
-X509_free has always been available.
-
-Index: content/fetchers/curl.c
--- a/content/fetchers/curl.c
+++ b/content/fetchers/curl.c
-@@ -92,7 +92,7 @@
+@@ -98,7 +98,7 @@
/* OpenSSL 1.0.x to 1.1.0 certificate reference counting changed
* LibreSSL declares its OpenSSL version as 2.1 but only supports the old way
*/
diff --git a/www-client/netsurf/files/netsurf-3.9-conditionally-include-image-headers.patch b/www-client/netsurf/files/netsurf-3.9-conditionally-include-image-headers.patch
deleted file mode 100644
index 603c209..0000000
--- a/www-client/netsurf/files/netsurf-3.9-conditionally-include-image-headers.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -rup a/content/handlers/image/image.c b/content/handlers/image/image.c
---- a/content/handlers/image/image.c 2019-07-17 10:28:13.000000000 +0000
-+++ b/content/handlers/image/image.c 2019-09-27 15:09:03.860000000 +0000
-@@ -27,15 +27,31 @@
- #include "netsurf/content.h"
- #include "desktop/gui_internal.h"
-
-+#ifdef WITH_BMP
- #include "image/bmp.h"
-+#endif
-+#ifdef WITH_GIF
- #include "image/gif.h"
-+#endif
- #include "image/ico.h"
-+#ifdef WITH_JPEG
- #include "image/jpeg.h"
-+#endif
-+#ifdef WITH_NSSPRITE
- #include "image/nssprite.h"
-+#endif
-+#ifdef WITH_PNG
- #include "image/png.h"
-+#endif
-+#ifdef WITH_RSVG
- #include "image/rsvg.h"
-+#endif
-+#ifdef WITH_NS_SVG
- #include "image/svg.h"
-+#endif
-+#ifdef WITH_WEBP
- #include "image/webp.h"
-+#endif
- #include "image/image.h"
-
- /**
diff --git a/www-client/netsurf/netsurf-3.10-r7.ebuild b/www-client/netsurf/netsurf-3.11.ebuild
index dd8707c..585c83d 100644
--- a/www-client/netsurf/netsurf-3.10-r7.ebuild
+++ b/www-client/netsurf/netsurf-3.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ inherit desktop netsurf toolchain-funcs
DESCRIPTION="A free, open source web browser"
HOMEPAGE="https://www.netsurf-browser.org/"
-SRC_URI="http://download.netsurf-browser.org/netsurf/releases/source/${P}-src.tar.gz"
+SRC_URI="https://download.netsurf-browser.org/netsurf/releases/source/${P}-src.tar.gz"
LICENSE="GPL-2 MIT"
SLOT="0"
@@ -25,7 +25,7 @@ RDEPEND="
dev-libs/libxml2:2
net-misc/curl
net-libs/libdom
- net-libs/libhubbub
+ >=net-libs/libhubbub-0.3.8
bmp? ( media-libs/libnsbmp )
fbcon? (
dev-libs/libnsfb
@@ -34,7 +34,7 @@ RDEPEND="
media-libs/freetype
)
)
- gif? ( media-libs/libnsgif )
+ gif? ( >=media-libs/libnsgif-1.0.0 )
gtk? (
dev-libs/glib:2
x11-libs/gtk+:3
@@ -56,17 +56,14 @@ DEPEND="${RDEPEND}"
BDEPEND="
dev-libs/check
dev-perl/HTML-Parser
- dev-util/netsurf-buildsystem
+ dev-build/netsurf-buildsystem
virtual/pkgconfig
- javascript? ( app-editors/vim-core )
"
PATCHES=(
- "${FILESDIR}/${PN}-3.9-conditionally-include-image-headers.patch"
"${FILESDIR}/${PN}-3.10-julia-libutf8proc-header-location.patch"
"${FILESDIR}/${PN}-3.10-disable-failing-tests.patch"
- "${FILESDIR}/${PN}-3.10-gcc10-fno-common.patch"
- "${FILESDIR}/${PN}-3.10-libressl-3.5.patch"
+ "${FILESDIR}/${PN}-3.11-libressl-3.5.patch"
)
DOCS=(
@@ -123,9 +120,6 @@ src_test() {
}
src_install() {
- sed -e '1iexit;' \
- -i "${WORKDIR}"/*/utils/git-testament.pl || die
-
if use fbcon ; then
# See earlier comments about rsvg.h.
_emake NETSURF_USE_RSVG=NO TARGET=framebuffer DESTDIR="${D}" install