aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-12-11 12:52:34 -0800
committerAric Belsito <lluixhi@gmail.com>2016-12-11 12:52:34 -0800
commit0ec51b02d88c3eea587b48fd1eef3a33e25c6da2 (patch)
treebcc1ff66bce0dd625bcb696287f524bd98e83883 /www-client
parentMerge pull request #178 from zetok/tlsdate (diff)
downloadlibressl-0ec51b02d88c3eea587b48fd1eef3a33e25c6da2.tar.gz
libressl-0ec51b02d88c3eea587b48fd1eef3a33e25c6da2.tar.bz2
libressl-0ec51b02d88c3eea587b48fd1eef3a33e25c6da2.zip
www-client/lynx: Add 2.8.9_pre11
Adds an ifdef to support new versions of OpenSSL, and in so doing breaks LibreSSL support
Diffstat (limited to 'www-client')
-rw-r--r--www-client/lynx/Manifest1
-rw-r--r--www-client/lynx/files/lynx-2.8.6-mint.patch32
-rw-r--r--www-client/lynx/files/lynx-2.8.8_p1-parallel.patch57
-rw-r--r--www-client/lynx/files/lynx-2.8.9-libressl.patch12
-rw-r--r--www-client/lynx/lynx-2.8.9_pre11.ebuild101
-rw-r--r--www-client/lynx/metadata.xml12
6 files changed, 215 insertions, 0 deletions
diff --git a/www-client/lynx/Manifest b/www-client/lynx/Manifest
new file mode 100644
index 0000000..37fe0ce
--- /dev/null
+++ b/www-client/lynx/Manifest
@@ -0,0 +1 @@
+DIST lynx2.8.9dev.11.tar.bz2 2665470 SHA256 2a1092f2cde76f109e4f1df1760c1d2a8792ba7018ab7ff3cc2b01d14e0c15b3 SHA512 702be6cb4f97bae4765d3de3d6ef1cd09e2ef27b570dfbea4f26a411f5bba2ab6d16aee5dbec0ebe63533de17664684ff42fb857b2d17d416774777b38083f50 WHIRLPOOL 476d9ef89f5ce5b8a91cffdd19f86111e8c35fb589da1a08b967f69674426ef52eaa58c402707d9ff6822954a5a45fd708640eaa3e51293bbc0d0a09f1051851
diff --git a/www-client/lynx/files/lynx-2.8.6-mint.patch b/www-client/lynx/files/lynx-2.8.6-mint.patch
new file mode 100644
index 0000000..3c79877
--- /dev/null
+++ b/www-client/lynx/files/lynx-2.8.6-mint.patch
@@ -0,0 +1,32 @@
+--- lynx2-8-6/src/UCdomap.h.old 2009-03-18 08:16:12.000000000 +0000
++++ lynx2-8-6/src/UCdomap.h 2009-03-18 08:15:12.000000000 +0000
+@@ -172,6 +172,18 @@
+ 0, 128,UCT_ENC_UTF8,-4)
+ #endif
+
++#ifndef NO_CHARSET_windows_1250
++#define NO_CHARSET_windows_1250 !ALL_CHARSETS
++#endif
++
++#if NO_CHARSET_windows_1250
++#define UC_CHARSET_SETUP_windows_1250 /* nothing */
++#else
++/* Is this right ??? */
++#define UC_CHARSET_SETUP_x_transparent UC_Charset_NoUctb_Setup("windows-1250","windows-1250",\
++ 0, 128,UCT_ENC_8BIT,0)
++#endif
++
+ #ifdef __cplusplus
+ }
+ #endif
+--- lynx2-8-6/WWW/Library/Implementation/www_tcp.h.old 2009-03-18 06:45:10.000000000 +0000
++++ lynx2-8-6/WWW/Library/Implementation/www_tcp.h 2009-03-18 06:45:22.000000000 +0000
+@@ -94,7 +94,7 @@
+ # endif
+ #endif /* HAVE_DIRENT_H */
+
+-#if !(defined(DOSPATH) || defined(__EMX__) || defined(__CYGWIN__))
++#if !(defined(DOSPATH) || defined(__EMX__) || defined(__CYGWIN__) || defined(__MINT__))
+ #define STRUCT_DIRENT__D_INO 1
+ #endif
+
diff --git a/www-client/lynx/files/lynx-2.8.8_p1-parallel.patch b/www-client/lynx/files/lynx-2.8.8_p1-parallel.patch
new file mode 100644
index 0000000..a674520
--- /dev/null
+++ b/www-client/lynx/files/lynx-2.8.8_p1-parallel.patch
@@ -0,0 +1,57 @@
+--- lynx2-8-8/makefile.in
++++ lynx2-8-8/makefile.in
+@@ -215,10 +215,10 @@
+
+ all lynx$x: cfg_defs.h LYHelp.h
+ @MSG_DIR_MAKE@ $(SHELL) $(scripts_dir)/fixtext.sh $(srcdir)/LYMessages_en.h >LYMessages.c
+-@MSG_DIR_MAKE@ cd $(PO_DIR) && $(MAKE_RECUR)
+- cd $(WWW_DIR) && $(MAKE_RECUR) $(WWW_CFLAGS)
+- cd $(CHR_DIR) && $(MAKE_RECUR) all $(CHR_CFLAGS)
+- cd $(SRC_DIR) && $(MAKE_RECUR) all $(SRC_CFLAGS)
++@MSG_DIR_MAKE@ $(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)" -C $(PO_DIR)
++ $(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)" -C $(WWW_DIR) $(WWW_CFLAGS)
++ $(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)" -C $(CHR_DIR) all $(CHR_CFLAGS)
++ $(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)" -C $(SRC_DIR) all $(SRC_CFLAGS)
+
+ lint:
+ cd $(WWW_DIR) && $(MAKE_RECUR) LINT="$(LINT)" $(WWW_CFLAGS) $@
+@@ -258,8 +258,8 @@
+ rm -f core *.core
+
+ depend: cfg_defs.h LYHelp.h
+- cd $(WWW_DIR) && $(MAKE_RECUR) $@
+- cd $(SRC_DIR) && $(MAKE_RECUR) $@
++ $(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)" -C $(WWW_DIR) $@
++ $(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)" -C $(SRC_DIR) $@
+
+ distclean: clean
+ -rm -f WWW/Library/*/*~
+@@ -337,7 +337,7 @@
+ @echo Full installation complete.
+
+ install-bin: $(BINDIR) lynx$x
+-@MSG_DIR_MAKE@ cd $(PO_DIR) && $(MAKE_RECUR) install
++@MSG_DIR_MAKE@ $(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)" -C $(PO_DIR)
+ @ECHO_CC@$(SHELL) -c \
+ 'if test -f $(BINDIR)/$(binary_PROG) ; then \
+ mv -f $(BINDIR)/$(binary_PROG) $(BINDIR)/lynx.old; fi'
+--- lynx2-8-8/src/makefile.in
++++ lynx2-8-8/src/makefile.in
+@@ -118,7 +118,7 @@
+ @echo "Compiling Lynx sources"
+
+ do_chartrans_stuff:
+- -cd chrtrans && $(MAKE_RECUR) \
++ -$(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)" -C chrtrans \
+ SITE_DEFS="$(SITE_DEFS)" \
+ BUILD_CFLAGS="$(BUILD_CFLAGS)" \
+ BUILD_CPPFLAGS="$(BUILD_CPPFLAGS)" \
+@@ -209,7 +209,7 @@
+ $(CHRTR)viscii_uni.h
+
+ $(TABLES):
+- -cd chrtrans && $(MAKE_RECUR) tables
++ -$(MAKE) @cf_cv_makeflags@ DESTDIR="$(DESTDIR)" CC="$(CC)" -C chrtrans tables
+
+ UCdomap$o : UCdomap.c \
+ chrtrans/UCkd.h \
diff --git a/www-client/lynx/files/lynx-2.8.9-libressl.patch b/www-client/lynx/files/lynx-2.8.9-libressl.patch
new file mode 100644
index 0000000..f5becb2
--- /dev/null
+++ b/www-client/lynx/files/lynx-2.8.9-libressl.patch
@@ -0,0 +1,12 @@
+diff -Naur lynx2.8.9dev.11.orig/WWW/Library/Implementation/HTTP.c lynx2.8.9dev.11/WWW/Library/Implementation/HTTP.c
+--- lynx2.8.9dev.11.orig/WWW/Library/Implementation/HTTP.c 2016-12-11 12:48:58.951251787 -0800
++++ lynx2.8.9dev.11/WWW/Library/Implementation/HTTP.c 2016-12-11 12:49:46.633762684 -0800
+@@ -926,7 +926,7 @@
+ #elif SSLEAY_VERSION_NUMBER >= 0x0900
+ #ifndef USE_NSS_COMPAT_INCL
+ if (!try_tls) {
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000L
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ SSL_set_min_proto_version(handle, TLS1_1_VERSION);
+ #else
+ SSL_set_options(handle, SSL_OP_NO_TLSv1);
diff --git a/www-client/lynx/lynx-2.8.9_pre11.ebuild b/www-client/lynx/lynx-2.8.9_pre11.ebuild
new file mode 100644
index 0000000..0c3f492
--- /dev/null
+++ b/www-client/lynx/lynx-2.8.9_pre11.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# VERSIONING SCHEME TRANSLATION
+# Upstream : Gentoo
+# rel. : _p
+# pre. : _rc
+# dev. : _pre
+
+case ${PV} in
+ *_pre*) MY_P="${PN}${PV/_pre/dev.}" ;;
+ *_rc*) MY_P="${PN}${PV/_rc/pre.}" ;;
+ *_p*|*) MY_P="${PN}${PV/_p/rel.}" ;;
+esac
+
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.isc.org/"
+SRC_URI="http://invisible-mirror.net/archives/lynx/tarballs/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 cjk gnutls idn ipv6 nls ssl unicode libressl"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ ssl? (
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ gnutls? (
+ dev-libs/libgcrypt:0=
+ >=net-libs/gnutls-2.6.4:=
+ )
+ )
+ bzip2? ( app-arch/bzip2 )
+ idn? ( net-dns/libidn )
+"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.8.6-mint.patch
+ "${FILESDIR}"/${PN}-2.8.8_p1-parallel.patch
+ "${FILESDIR}"/${PN}-2.8.9-libressl.patch
+)
+
+pkg_setup() {
+ ! use ssl && elog "SSL support disabled; you will not be able to access secure websites."
+}
+
+src_configure() {
+ local myconf=(
+ --enable-nested-tables
+ --enable-cgi-links
+ --enable-persistent-cookies
+ --enable-prettysrc
+ --enable-nsl-fork
+ --enable-file-upload
+ --enable-read-eta
+ --enable-color-style
+ --enable-scrollbar
+ --enable-included-msgs
+ --enable-externs
+ --with-zlib
+ $(use_enable nls)
+ $(use_enable idn idna)
+ $(use_enable ipv6)
+ $(use_enable cjk)
+ $(use_enable unicode japanese-utf8)
+ $(use_with bzip2 bzlib)
+ $(usex ssl "--with-$(usex gnutls gnutls ssl)=${EPREFIX}/usr" "")
+ --with-screen=$(usex unicode "ncursesw" "ncurses")
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ sed -i "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
+ "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
+ if use unicode ; then
+ sed -i '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
+ "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
+ fi
+
+ dodoc CHANGES COPYHEADER PROBLEMS README
+ dodoc -r docs lynx_help
+}
diff --git a/www-client/lynx/metadata.xml b/www-client/lynx/metadata.xml
new file mode 100644
index 0000000..f4f92f0
--- /dev/null
+++ b/www-client/lynx/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <use>
+ <flag name="ssl">Enable HTTPS support.</flag>
+ <flag name="gnutls">Use gnutls library for HTTPS support (openssl is the default library for HTTPS support).</flag>
+ </use>
+</pkgmetadata>