aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormaurerpe <junk4me46806@yahoo.com>2016-02-21 21:06:26 -0500
committermaurerpe <junk4me46806@yahoo.com>2016-02-21 21:06:26 -0500
commitdc6ca071b858fc2c68f1b8b6218e3bebc5bf6201 (patch)
tree6e56c15b0e0dcc27738bdc87cf6dc03276637ee8 /net-wireless
parentMerge branch 'master' of https://github.com/gentoo/libressl (diff)
downloadlibressl-dc6ca071b858fc2c68f1b8b6218e3bebc5bf6201.tar.gz
libressl-dc6ca071b858fc2c68f1b8b6218e3bebc5bf6201.tar.bz2
libressl-dc6ca071b858fc2c68f1b8b6218e3bebc5bf6201.zip
Remove unneeded ebuilds
apt-crypt/qca-ossl is no longer in portage and net-wireless/wpa_suplicant is already fixed in portage, so neither is needed in this overlay.
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/wpa_supplicant/Manifest1
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_cli.sh47
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant-2.5-do-not-call-dbus-functions-with-NULL-path.patch12
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant-2.5-libressl.patch48
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant-conf.d6
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant-init.d70
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant.conf7
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant.service11
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant_at.service11
-rw-r--r--net-wireless/wpa_supplicant/metadata.xml28
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-2.5-r1.ebuild400
11 files changed, 0 insertions, 641 deletions
diff --git a/net-wireless/wpa_supplicant/Manifest b/net-wireless/wpa_supplicant/Manifest
deleted file mode 100644
index 192819a..0000000
--- a/net-wireless/wpa_supplicant/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST wpa_supplicant-2.5.tar.gz 2607336 SHA256 cce55bae483b364eae55c35ba567c279be442ed8bab5b80a3c7fb0d057b9b316 SHA512 e3ca36ed10b4dae8f663e98ad230c8c059c952316c21a6b0638ecb1b40a5ef1b9083138ab45207cb764a17e870b4bd0625dd6efdb65856cb4dca13ccc0559e81 WHIRLPOOL 7f35ba06fc4022fe21f05a54a5b108bf2111dcb22e795e1566a514400db8348e79cc80b605dab5b586ab8f3966833ade7153e63c118794a0f06c4afd7a37781d
diff --git a/net-wireless/wpa_supplicant/files/wpa_cli.sh b/net-wireless/wpa_supplicant/files/wpa_cli.sh
deleted file mode 100644
index f363ba9..0000000
--- a/net-wireless/wpa_supplicant/files/wpa_cli.sh
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/bin/sh
-# Copyright 1999-2011 Gentoo Foundation
-# Written by Roy Marples <uberlord@gentoo.org>
-# Distributed under the terms of the GNU General Public License v2
-# Alternatively, this file may be distributed under the terms of the BSD License
-# $Id$
-
-if [ -z "$1" -o -z "$2" ]; then
- logger -t wpa_cli "Insufficient parameters"
- exit 1
-fi
-
-INTERFACE="$1"
-ACTION="$2"
-
-# Note, the below action must NOT mark the interface down via ifconfig, ip or
-# similar. Addresses can be removed, changed and daemons can be stopped, but
-# the interface must remain up for wpa_supplicant to work.
-
-if [ -f /etc/gentoo-release ]; then
- EXEC="/etc/init.d/net.${INTERFACE} --quiet"
-else
- logger -t wpa_cli "I don't know what to do with this distro!"
- exit 1
-fi
-
-case ${ACTION} in
- CONNECTED)
- EXEC="${EXEC} start"
- ;;
- DISCONNECTED)
- # Deactivated, since stopping /etc/init.d/net.wlanX
- # stops the network completly.
- EXEC="false ${EXEC} stop"
- ;;
- *)
- logger -t wpa_cli "Unknown action ${ACTION}"
- exit 1
- ;;
-esac
-
-# ${EXEC} can use ${IN_BACKGROUND} so that it knows that the user isn't
-# stopping the interface and a background process - like wpa_cli - is.
-export IN_BACKGROUND=true
-
-logger -t wpa_cli "interface ${INTERFACE} ${ACTION}"
-${EXEC} || logger -t wpa_cli "executing '${EXEC}' failed"
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-2.5-do-not-call-dbus-functions-with-NULL-path.patch b/net-wireless/wpa_supplicant/files/wpa_supplicant-2.5-do-not-call-dbus-functions-with-NULL-path.patch
deleted file mode 100644
index deb6996..0000000
--- a/net-wireless/wpa_supplicant/files/wpa_supplicant-2.5-do-not-call-dbus-functions-with-NULL-path.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur wpa_supplicant/dbus/dbus_new_helpers.c wpa_supplicant-fixed/dbus/dbus_new_helpers.c
---- wpa_supplicant/dbus/dbus_new_helpers.c 2015-09-27 15:02:05.000000000 -0400
-+++ wpa_supplicant-fixed/dbus/dbus_new_helpers.c 2015-10-05 18:38:58.489713168 -0400
-@@ -847,7 +847,7 @@
- const struct wpa_dbus_property_desc *dsc;
- int i = 0;
-
-- if (iface == NULL)
-+ if (iface == NULL || path == NULL)
- return;
-
- dbus_connection_get_object_path_data(iface->con, path,
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-2.5-libressl.patch b/net-wireless/wpa_supplicant/files/wpa_supplicant-2.5-libressl.patch
deleted file mode 100644
index 5efee0e..0000000
--- a/net-wireless/wpa_supplicant/files/wpa_supplicant-2.5-libressl.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -Naurw wpa_supplicant-2.5.orig/src/crypto/tls_openssl.c wpa_supplicant-2.5/src/crypto/tls_openssl.c
---- wpa_supplicant-2.5.orig/src/crypto/tls_openssl.c 2015-09-27 12:02:05.000000000 -0700
-+++ wpa_supplicant-2.5/src/crypto/tls_openssl.c 2015-10-06 10:28:45.296546845 -0700
-@@ -2229,7 +2229,7 @@
- }
-
- if (certs) {
--#if OPENSSL_VERSION_NUMBER >= 0x10002000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10002000L && !defined(LIBRESSL_VERSION_NUMBER)
- SSL_clear_chain_certs(ssl);
- while ((cert = sk_X509_pop(certs)) != NULL) {
- X509_NAME_oneline(X509_get_subject_name(cert), buf,
-@@ -2247,7 +2247,7 @@
- /* Try to continue anyway */
- }
- sk_X509_free(certs);
--#ifndef OPENSSL_IS_BORINGSSL
-+#if !defined(OPENSSL_IS_BORINGSSL) && !defined(LIBRESSL_VERSION_NUMBER)
- res = SSL_build_cert_chain(ssl,
- SSL_BUILD_CHAIN_FLAG_CHECK |
- SSL_BUILD_CHAIN_FLAG_IGNORE_ERROR);
-@@ -2812,7 +2812,7 @@
- if (conn == NULL || keys == NULL)
- return -1;
- ssl = conn->ssl;
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- if (ssl == NULL || ssl->s3 == NULL || ssl->session == NULL)
- return -1;
-
-@@ -2841,7 +2841,7 @@
- #ifndef CONFIG_FIPS
- static int openssl_get_keyblock_size(SSL *ssl)
- {
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- const EVP_CIPHER *c;
- const EVP_MD *h;
- int md_size;
-@@ -2911,7 +2911,7 @@
- "mode");
- return -1;
- #else /* CONFIG_FIPS */
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- SSL *ssl;
- u8 *rnd;
- int ret = -1;
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-conf.d b/net-wireless/wpa_supplicant/files/wpa_supplicant-conf.d
deleted file mode 100644
index 104b9dc..0000000
--- a/net-wireless/wpa_supplicant/files/wpa_supplicant-conf.d
+++ /dev/null
@@ -1,6 +0,0 @@
-# conf.d file for wpa_supplicant
-#
-# Please check man 8 wpa_supplicant for more information about the options
-# wpa_supplicant accepts.
-#
-wpa_supplicant_args=""
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-init.d b/net-wireless/wpa_supplicant/files/wpa_supplicant-init.d
deleted file mode 100644
index 8429a37..0000000
--- a/net-wireless/wpa_supplicant/files/wpa_supplicant-init.d
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/sbin/runscript
-# Copyright (c) 2009 Roy Marples <roy@marples.name>
-# All rights reserved. Released under the 2-clause BSD license.
-
-command=/usr/sbin/wpa_supplicant
-: ${wpa_supplicant_conf:=/etc/wpa_supplicant/wpa_supplicant.conf}
-wpa_supplicant_if=${wpa_supplicant_if:+-i}$wpa_supplicant_if
-command_args="$wpa_supplicant_args -B -c$wpa_supplicant_conf $wpa_supplicant_if"
-name="WPA Supplicant Daemon"
-
-depend()
-{
- need localmount
- use logger
- after bootmisc modules
- before dns dhcpcd net
- keyword -shutdown
-}
-
-find_wireless()
-{
- local iface=
-
- case "$RC_UNAME" in
- Linux)
- for iface in /sys/class/net/*; do
- if [ -e "$iface"/wireless -o \
- -e "$iface"/phy80211 ]
- then
- echo "${iface##*/}"
- return 0
- fi
- done
- ;;
- *)
- for iface in /dev/net/* $(ifconfig -l 2>/dev/null); do
- if ifconfig "${iface##*/}" 2>/dev/null | \
- grep -q "[ ]*ssid "
- then
- echo "${iface##*/}"
- return 0
- fi
- done
- ;;
- esac
-
- return 1
-}
-
-append_wireless()
-{
- local iface= i=
-
- iface=$(find_wireless)
- if [ -n "$iface" ]; then
- for i in $iface; do
- command_args="$command_args -i$i"
- done
- else
- eerror "Could not find a wireless interface"
- fi
-}
-
-start_pre()
-{
- case " $command_args" in
- *" -i"*) ;;
- *) append_wireless;;
- esac
-}
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant.conf b/net-wireless/wpa_supplicant/files/wpa_supplicant.conf
deleted file mode 100644
index c3a29e5..0000000
--- a/net-wireless/wpa_supplicant/files/wpa_supplicant.conf
+++ /dev/null
@@ -1,7 +0,0 @@
-# This is a network block that connects to any unsecured access point.
-# We give it a low priority so any defined blocks are preferred.
-network={
- key_mgmt=NONE
- priority=-9999999
-}
-
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant.service b/net-wireless/wpa_supplicant/files/wpa_supplicant.service
deleted file mode 100644
index e1e75b1..0000000
--- a/net-wireless/wpa_supplicant/files/wpa_supplicant.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=WPA supplicant
-
-[Service]
-Type=dbus
-BusName=fi.epitest.hostap.WPASupplicant
-ExecStart=/usr/sbin/wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -u
-
-[Install]
-WantedBy=multi-user.target
-Alias=dbus-fi.epitest.hostap.WPASupplicant.service
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant_at.service b/net-wireless/wpa_supplicant/files/wpa_supplicant_at.service
deleted file mode 100644
index af0cebf..0000000
--- a/net-wireless/wpa_supplicant/files/wpa_supplicant_at.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=WPA supplicant daemon (interface-specific version)
-
-# NetworkManager users will probably want the dbus version instead.
-
-[Service]
-Type=simple
-ExecStart=/usr/sbin/wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i%I
-
-[Install]
-Alias=multi-user.target.wants/wpa_supplicant@wlan0.service
diff --git a/net-wireless/wpa_supplicant/metadata.xml b/net-wireless/wpa_supplicant/metadata.xml
deleted file mode 100644
index 27c3b64..0000000
--- a/net-wireless/wpa_supplicant/metadata.xml
+++ /dev/null
@@ -1,28 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer>
- <email>gurligebis@gentoo.org</email>
- <name>Bjarke Istrup Pedersen</name>
- </maintainer>
- <maintainer>
- <email>zerochaos@gentoo.org</email>
- <name>Rick Farina</name>
- </maintainer>
- <use>
- <flag name='ap'>Add support for access point mode</flag>
- <flag name='eap-sim'>Add support for EAP-SIM authentication algorithm</flag>
- <flag name='fasteap'>Add support for FAST-EAP authentication algorithm</flag>
- <flag name='hs2-0'>Add support for 802.11u and Passpoint for HotSpot 2.0</flag>
- <flag name='p2p'>Add support for Wi-Fi Direct mode</flag>
- <flag name='ps3'>Add support for ps3 hypervisor driven gelic wifi</flag>
- <flag name='tdls'>Add support for Tunneled Direct Link Setup (802.11z)</flag>
- <flag name='uncommon-eap-types'>Add support for Wi-Fi Protected Setup</flag>
- <flag name='wps'>Add support for Wi-Fi Protected Setup</flag>
- <flag name='wimax'>Add support for Wimax EAP-PEER authentication algorithm</flag>
- <flag name='smartcard'>Add support for smartcards</flag>
- </use>
- <upstream>
- <remote-id type="cpe">cpe:/a:wpa_supplicant:wpa_supplicant</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-2.5-r1.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-2.5-r1.ebuild
deleted file mode 100644
index b20082f..0000000
--- a/net-wireless/wpa_supplicant/wpa_supplicant-2.5-r1.ebuild
+++ /dev/null
@@ -1,400 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils toolchain-funcs qt4-r2 qmake-utils systemd multilib
-
-DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
-HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
-SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
-LICENSE="|| ( GPL-2 BSD )"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="ap dbus gnutls eap-sim fasteap +hs2-0 libressl p2p ps3 qt4 qt5 readline selinux smartcard ssl tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
-REQUIRED_USE="fasteap? ( !gnutls !ssl ) smartcard? ( ssl ) ?? ( qt4 qt5 )"
-
-CDEPEND="dbus? ( sys-apps/dbus )
- kernel_linux? (
- eap-sim? ( sys-apps/pcsc-lite )
- dev-libs/libnl:3
- net-wireless/crda
- )
- !kernel_linux? ( net-libs/libpcap )
- qt4? (
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtsvg:4
- )
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtsvg:5
- )
- readline? (
- sys-libs/ncurses:0=
- sys-libs/readline:0
- )
- ssl? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )
- !ssl? (
- gnutls? (
- net-libs/gnutls
- dev-libs/libgcrypt:*
- )
- !gnutls? ( dev-libs/libtommath )
- )
-"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
-"
-RDEPEND="${CDEPEND}
- selinux? ( sec-policy/selinux-networkmanager )
-"
-
-S="${WORKDIR}/${P}/${PN}"
-
-Kconfig_style_config() {
- #param 1 is CONFIG_* item
- #param 2 is what to set it = to, defaulting in y
- CONFIG_PARAM="${CONFIG_HEADER:-CONFIG_}$1"
- setting="${2:-y}"
-
- if [ ! $setting = n ]; then
- #first remove any leading "# " if $2 is not n
- sed -i "/^# *$CONFIG_PARAM=/s/^# *//" .config || echo "Kconfig_style_config error uncommenting $CONFIG_PARAM"
- #set item = $setting (defaulting to y)
- sed -i "/^$CONFIG_PARAM/s/=.*/=$setting/" .config || echo "Kconfig_style_config error setting $CONFIG_PARAM=$setting"
- else
- #ensure item commented out
- sed -i "/^$CONFIG_PARAM/s/$CONFIG_PARAM/# $CONFIG_PARAM/" .config || echo "Kconfig_style_config error commenting $CONFIG_PARAM"
- fi
-}
-
-pkg_setup() {
- if use gnutls && use ssl ; then
- elog "You have both 'gnutls' and 'ssl' USE flags enabled: defaulting to USE=\"ssl\""
- fi
-}
-
-src_prepare() {
- pushd "${WORKDIR}/${P}" >/dev/null || die
- # Fix for LibreSSL
- epatch "${FILESDIR}/wpa_supplicant-2.5-libressl.patch"
- popd > /dev/null || die
-
- # net/bpf.h needed for net-libs/libpcap on Gentoo/FreeBSD
- sed -i \
- -e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \
- ../src/l2_packet/l2_packet_freebsd.c || die
-
- # People seem to take the example configuration file too literally (bug #102361)
- sed -i \
- -e "s:^\(opensc_engine_path\):#\1:" \
- -e "s:^\(pkcs11_engine_path\):#\1:" \
- -e "s:^\(pkcs11_module_path\):#\1:" \
- wpa_supplicant.conf || die
-
- # Change configuration to match Gentoo locations (bug #143750)
- sed -i \
- -e "s:/usr/lib/opensc:/usr/$(get_libdir):" \
- -e "s:/usr/lib/pkcs11:/usr/$(get_libdir):" \
- wpa_supplicant.conf || die
-
- #if use dbus; then
- # epatch "${FILESDIR}/${P}-dbus-path-fix.patch"
- #fi
-
- # systemd entries to D-Bus service files (bug #372877)
- echo 'SystemdService=wpa_supplicant.service' \
- | tee -a dbus/*.service >/dev/null || die
-
- cd "${WORKDIR}/${P}"
-
- if use wimax; then
- # generate-libeap-peer.patch comes before
- # fix-undefined-reference-to-random_get_bytes.patch
- epatch "${FILESDIR}/${P}-generate-libeap-peer.patch"
-
- # multilib-strict fix (bug #373685)
- sed -e "s/\/usr\/lib/\/usr\/$(get_libdir)/" -i src/eap_peer/Makefile
- fi
-
- # bug (320097)
- epatch "${FILESDIR}/${P}-do-not-call-dbus-functions-with-NULL-path.patch"
-
- # TODO - NEED TESTING TO SEE IF STILL NEEDED, NOT COMPATIBLE WITH 1.0 OUT OF THE BOX,
- # SO WOULD BE NICE TO JUST DROP IT, IF IT IS NOT NEEDED.
- # bug (374089)
- #epatch "${FILESDIR}/${P}-dbus-WPAIE-fix.patch"
-}
-
-src_configure() {
- # Toolchain setup
- tc-export CC
-
- cp defconfig .config
-
- # Basic setup
- Kconfig_style_config CTRL_IFACE
- Kconfig_style_config BACKEND file
- Kconfig_style_config IBSS_RSN
- Kconfig_style_config IEEE80211W
- Kconfig_style_config IEEE80211R
-
- # Basic authentication methods
- # NOTE: we don't set GPSK or SAKE as they conflict
- # with the below options
- Kconfig_style_config EAP_GTC
- Kconfig_style_config EAP_MD5
- Kconfig_style_config EAP_OTP
- Kconfig_style_config EAP_PAX
- Kconfig_style_config EAP_PSK
- Kconfig_style_config EAP_TLV
- Kconfig_style_config EAP_EXE
- Kconfig_style_config IEEE8021X_EAPOL
- Kconfig_style_config PKCS12
- Kconfig_style_config PEERKEY
- Kconfig_style_config EAP_LEAP
- Kconfig_style_config EAP_MSCHAPV2
- Kconfig_style_config EAP_PEAP
- Kconfig_style_config EAP_TLS
- Kconfig_style_config EAP_TTLS
-
- # Enabling background scanning.
- Kconfig_style_config BGSCAN_SIMPLE
- Kconfig_style_config BGSCAN_LEARN
-
- # Enabling mesh networks.
- Kconfig_style_config MESH
-
- if use dbus ; then
- Kconfig_style_config CTRL_IFACE_DBUS
- Kconfig_style_config CTRL_IFACE_DBUS_NEW
- Kconfig_style_config CTRL_IFACE_DBUS_INTRO
- fi
-
- # Enable support for writing debug info to a log file and syslog.
- Kconfig_style_config DEBUG_FILE
- Kconfig_style_config DEBUG_SYSLOG
-
- if use hs2-0 ; then
- Kconfig_style_config INTERWORKING
- Kconfig_style_config HS20
- fi
-
- if use uncommon-eap-types; then
- Kconfig_style_config EAP_GPSK
- Kconfig_style_config EAP_SAKE
- Kconfig_style_config EAP_GPSK_SHA256
- Kconfig_style_config EAP_IKEV2
- Kconfig_style_config EAP_EKE
- fi
-
- if use eap-sim ; then
- # Smart card authentication
- Kconfig_style_config EAP_SIM
- Kconfig_style_config EAP_AKA
- Kconfig_style_config EAP_AKA_PRIME
- Kconfig_style_config PCSC
- fi
-
- if use fasteap ; then
- Kconfig_style_config EAP_FAST
- fi
-
- if use readline ; then
- # readline/history support for wpa_cli
- Kconfig_style_config READLINE
- else
- #internal line edit mode for wpa_cli
- Kconfig_style_config WPA_CLI_EDIT
- fi
-
- # SSL authentication methods
- if use ssl ; then
- Kconfig_style_config TLS openssl
- elif use gnutls ; then
- Kconfig_style_config TLS gnutls
- Kconfig_style_config GNUTLS_EXTRA
- else
- Kconfig_style_config TLS internal
- fi
-
- if use smartcard ; then
- Kconfig_style_config SMARTCARD
- fi
-
- if use tdls ; then
- Kconfig_style_config TDLS
- fi
-
- if use kernel_linux ; then
- # Linux specific drivers
- Kconfig_style_config DRIVER_ATMEL
- Kconfig_style_config DRIVER_HOSTAP
- Kconfig_style_config DRIVER_IPW
- Kconfig_style_config DRIVER_NL80211
- Kconfig_style_config DRIVER_RALINK
- Kconfig_style_config DRIVER_WEXT
- Kconfig_style_config DRIVER_WIRED
-
- if use ps3 ; then
- Kconfig_style_config DRIVER_PS3
- fi
-
- elif use kernel_FreeBSD ; then
- # FreeBSD specific driver
- Kconfig_style_config DRIVER_BSD
- fi
-
- # Wi-Fi Protected Setup (WPS)
- if use wps ; then
- Kconfig_style_config WPS
- Kconfig_style_config WPS2
- # USB Flash Drive
- Kconfig_style_config WPS_UFD
- # External Registrar
- Kconfig_style_config WPS_ER
- # Universal Plug'n'Play
- Kconfig_style_config WPS_UPNP
- # Near Field Communication
- Kconfig_style_config WPS_NFC
- fi
-
- # Wi-Fi Direct (WiDi)
- if use p2p ; then
- Kconfig_style_config P2P
- Kconfig_style_config WIFI_DISPLAY
- fi
-
- # Access Point Mode
- if use ap ; then
- Kconfig_style_config AP
- fi
-
- # Enable mitigation against certain attacks against TKIP
- Kconfig_style_config DELAYED_MIC_ERROR_REPORT
-
- # If we are using libnl 2.0 and above, enable support for it
- # Bug 382159
- # Removed for now, since the 3.2 version is broken, and we don't
- # support it.
- if has_version ">=dev-libs/libnl-3.2"; then
- Kconfig_style_config LIBNL32
- fi
-
- if use qt4 ; then
- pushd "${S}"/wpa_gui-qt4 > /dev/null
- eqmake4 wpa_gui.pro
- popd > /dev/null
- fi
- if use qt5 ; then
- pushd "${S}"/wpa_gui-qt4 > /dev/null
- eqmake5 wpa_gui.pro
- popd > /dev/null
- fi
-}
-
-src_compile() {
- einfo "Building wpa_supplicant"
- emake V=1 BINDIR=/usr/sbin
-
- if use wimax; then
- emake -C ../src/eap_peer clean
- emake -C ../src/eap_peer
- fi
-
- if use qt4 || use qt5; then
- pushd "${S}"/wpa_gui-qt4 > /dev/null
- einfo "Building wpa_gui"
- emake
- popd > /dev/null
- fi
-}
-
-src_install() {
- dosbin wpa_supplicant
- dobin wpa_cli wpa_passphrase
-
- # baselayout-1 compat
- if has_version "<sys-apps/baselayout-2.0.0"; then
- dodir /sbin
- dosym /usr/sbin/wpa_supplicant /sbin/wpa_supplicant
- dodir /bin
- dosym /usr/bin/wpa_cli /bin/wpa_cli
- fi
-
- if has_version ">=sys-apps/openrc-0.5.0"; then
- newinitd "${FILESDIR}/${PN}-init.d" wpa_supplicant
- newconfd "${FILESDIR}/${PN}-conf.d" wpa_supplicant
- fi
-
- exeinto /etc/wpa_supplicant/
- newexe "${FILESDIR}/wpa_cli.sh" wpa_cli.sh
-
- dodoc ChangeLog {eap_testing,todo}.txt README{,-WPS} \
- wpa_supplicant.conf
-
- newdoc .config build-config
-
- doman doc/docbook/*.{5,8}
-
- if use qt4 || use qt5 ; then
- into /usr
- dobin wpa_gui-qt4/wpa_gui
- doicon wpa_gui-qt4/icons/wpa_gui.svg
- make_desktop_entry wpa_gui "WPA Supplicant Administration GUI" "wpa_gui" "Qt;Network;"
- fi
-
- use wimax && emake DESTDIR="${D}" -C ../src/eap_peer install
-
- if use dbus ; then
- pushd "${S}"/dbus > /dev/null
- insinto /etc/dbus-1/system.d
- newins dbus-wpa_supplicant.conf wpa_supplicant.conf
- insinto /usr/share/dbus-1/system-services
- doins fi.epitest.hostap.WPASupplicant.service fi.w1.wpa_supplicant1.service
- popd > /dev/null
-
- # This unit relies on dbus support, bug 538600.
- systemd_dounit systemd/wpa_supplicant.service
- fi
-
- systemd_dounit "systemd/wpa_supplicant@.service"
- systemd_dounit "systemd/wpa_supplicant-nl80211@.service"
- systemd_dounit "systemd/wpa_supplicant-wired@.service"
-}
-
-pkg_postinst() {
- elog "If this is a clean installation of wpa_supplicant, you"
- elog "have to create a configuration file named"
- elog "/etc/wpa_supplicant/wpa_supplicant.conf"
- elog
- elog "An example configuration file is available for reference in"
- elog "/usr/share/doc/${PF}/"
-
- if [[ -e ${ROOT}etc/wpa_supplicant.conf ]] ; then
- echo
- ewarn "WARNING: your old configuration file ${ROOT}etc/wpa_supplicant.conf"
- ewarn "needs to be moved to ${ROOT}etc/wpa_supplicant/wpa_supplicant.conf"
- fi
-
- # Mea culpa, feel free to remove that after some time --mgorny.
- local fn
- for fn in wpa_supplicant{,@wlan0}.service; do
- if [[ -e "${ROOT}"/etc/systemd/system/network.target.wants/${fn} ]]
- then
- ebegin "Moving ${fn} to multi-user.target"
- mv "${ROOT}"/etc/systemd/system/network.target.wants/${fn} \
- "${ROOT}"/etc/systemd/system/multi-user.target.wants/
- eend ${?} \
- "Please try to re-enable ${fn}"
- fi
- done
-}