aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-07-05 21:11:55 -0700
committerQuentin Retornaz <gentoo@retornaz.com>2022-07-11 00:49:23 +0200
commitde95d5bb2d85d57be5c31fad028d148f5321d542 (patch)
treefeb080e53f834754ee23dc627345aa595d42fdfd /net-libs
parentnet-libs/pjproject: Add 2.10-r2 (diff)
downloadlibressl-de95d5bb2d85d57be5c31fad028d148f5321d542.tar.gz
libressl-de95d5bb2d85d57be5c31fad028d148f5321d542.tar.bz2
libressl-de95d5bb2d85d57be5c31fad028d148f5321d542.zip
net-libs/pjproject: Remove old version
Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/libressl/pull/437 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/pjproject/Manifest1
-rw-r--r--net-libs/pjproject/files/pjproject-2.7.2-libressl.patch98
-rw-r--r--net-libs/pjproject/files/pjproject-2.7.2-ssl-flipflop.patch103
-rw-r--r--net-libs/pjproject/pjproject-2.7.2-r2.ebuild114
4 files changed, 0 insertions, 316 deletions
diff --git a/net-libs/pjproject/Manifest b/net-libs/pjproject/Manifest
index 6adb41c..048f8a5 100644
--- a/net-libs/pjproject/Manifest
+++ b/net-libs/pjproject/Manifest
@@ -1,2 +1 @@
DIST pjproject-2.10.tar.gz 8768705 BLAKE2B 42d70867e2e0474313426f1e188586d203d6165c28a133a62dedacd2deb2899215212824d9402a48fcc66bb08a17b796d3625e1d51a8aedc9aa4b3a3bf1cb8fa SHA512 a67f083df175b536b4e6a7b7fe39e07d3ee805d6917ec64a50694542a7455c33a100889191044ab3fa679b6656774a6be045621aa53510b5f04cdde9ddd59893
-DIST pjproject-2.7.2.tar.bz2 4994233 BLAKE2B 44ecaf0997d5dd9b18e0b811cead7c9104e63894fa06fb1d64e79b60fa4210968fd90ef47e5f5be3629675363c8756ce3bc1834caa9700654ab4c53efe676ee7 SHA512 3d355ffcbbeed62cfc711e574a987dc06043ccf4f2625820adffa89167022b8306fcee3fada71d3d45e7b902fc9c65ac8221de101cbafed25362a3921f702afd
diff --git a/net-libs/pjproject/files/pjproject-2.7.2-libressl.patch b/net-libs/pjproject/files/pjproject-2.7.2-libressl.patch
deleted file mode 100644
index 07efa9c..0000000
--- a/net-libs/pjproject/files/pjproject-2.7.2-libressl.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-Index: /third_party/srtp/crypto/hash/hmac_ossl.c
-===================================================================
---- /third_party/srtp/crypto/hash/hmac_ossl.c (revision 5725)
-+++ /third_party/srtp/crypto/hash/hmac_ossl.c (revision 5726)
-@@ -52,6 +52,8 @@
- #include <openssl/evp.h>
- #include <openssl/hmac.h>
-+#include <openssl/opensslv.h>
-
- #define SHA1_DIGEST_SIZE 20
-+#define USING_LIBRESSL (defined(LIBRESSL_VERSION_NUMBER))
-
- /* the debug module for authentiation */
-@@ -77,5 +79,5 @@
- /* OpenSSL 1.1.0 made HMAC_CTX an opaque structure, which must be allocated
- using HMAC_CTX_new. But this function doesn't exist in OpenSSL 1.0.x. */
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if USING_LIBRESSL || OPENSSL_VERSION_NUMBER < 0x10100000L
- {
- /* allocate memory for auth and HMAC_CTX structures */
-@@ -122,5 +124,5 @@
- hmac_ctx = (HMAC_CTX*)a->state;
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if USING_LIBRESSL || OPENSSL_VERSION_NUMBER < 0x10100000L
- HMAC_CTX_cleanup(hmac_ctx);
-
-Index: /pjlib/src/pj/ssl_sock_ossl.c
-===================================================================
---- /pjlib/src/pj/ssl_sock_ossl.c (revision 5725)
-+++ /pjlib/src/pj/ssl_sock_ossl.c (revision 5726)
-@@ -56,6 +56,10 @@
- #include <openssl/rand.h>
- #include <openssl/opensslconf.h>
--
--#if !defined(OPENSSL_NO_EC) && OPENSSL_VERSION_NUMBER >= 0x1000200fL
-+#include <openssl/opensslv.h>
-+
-+#define USING_LIBRESSL (defined(LIBRESSL_VERSION_NUMBER))
-+
-+#if !USING_LIBRESSL && !defined(OPENSSL_NO_EC) \
-+ && OPENSSL_VERSION_NUMBER >= 0x1000200fL
-
- # include <openssl/obj_mac.h>
-@@ -115,5 +119,5 @@
-
-
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if !USING_LIBRESSL && OPENSSL_VERSION_NUMBER >= 0x10100000L
- # define OPENSSL_NO_SSL2 /* seems to be removed in 1.1.0 */
- # define M_ASN1_STRING_data(x) ASN1_STRING_get0_data(x)
-@@ -539,5 +543,5 @@
-
- /* Init OpenSSL lib */
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if USING_LIBRESSL || OPENSSL_VERSION_NUMBER < 0x10100000L
- SSL_library_init();
- SSL_load_error_strings();
-@@ -560,5 +564,7 @@
- const char *cname;
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if (USING_LIBRESSL && LIBRESSL_VERSION_NUMBER < 0x2020100fL)\
-+ || OPENSSL_VERSION_NUMBER < 0x10100000L
-+
- meth = (SSL_METHOD*)SSLv23_server_method();
- if (!meth)
-@@ -603,5 +609,6 @@
- SSL_set_session(ssl, SSL_SESSION_new());
-
--#if !defined(OPENSSL_NO_EC) && OPENSSL_VERSION_NUMBER >= 0x1000200fL
-+#if !USING_LIBRESSL && !defined(OPENSSL_NO_EC) \
-+ && OPENSSL_VERSION_NUMBER >= 0x1000200fL
- openssl_curves_num = SSL_get_shared_curve(ssl,-1);
- if (openssl_curves_num > PJ_ARRAY_SIZE(openssl_curves))
-@@ -795,5 +802,6 @@
-
- /* Determine SSL method to use */
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if (USING_LIBRESSL && LIBRESSL_VERSION_NUMBER < 0x2020100fL)\
-+ || OPENSSL_VERSION_NUMBER < 0x10100000L
- switch (ssock->param.proto) {
- case PJ_SSL_SOCK_PROTO_TLS1:
-@@ -1232,5 +1240,6 @@
- static pj_status_t set_curves_list(pj_ssl_sock_t *ssock)
- {
--#if !defined(OPENSSL_NO_EC) && OPENSSL_VERSION_NUMBER >= 0x1000200fL
-+#if !USING_LIBRESSL && !defined(OPENSSL_NO_EC) \
-+ && OPENSSL_VERSION_NUMBER >= 0x1000200fL
- int ret;
- int curves[PJ_SSL_SOCK_MAX_CURVES];
-@@ -1263,5 +1272,5 @@
- static pj_status_t set_sigalgs(pj_ssl_sock_t *ssock)
- {
--#if OPENSSL_VERSION_NUMBER >= 0x1000200fL
-+#if !USING_LIBRESSL && OPENSSL_VERSION_NUMBER >= 0x1000200fL
- int ret;
-
diff --git a/net-libs/pjproject/files/pjproject-2.7.2-ssl-flipflop.patch b/net-libs/pjproject/files/pjproject-2.7.2-ssl-flipflop.patch
deleted file mode 100644
index c984bc6..0000000
--- a/net-libs/pjproject/files/pjproject-2.7.2-ssl-flipflop.patch
+++ /dev/null
@@ -1,103 +0,0 @@
---- pjproject-2.7.1.ORIG/aconfigure.ac 2018-02-06 11:34:20.973411193 +0000
-+++ pjproject-2.7.1/aconfigure.ac 2018-02-06 13:33:31.525015674 +0000
-@@ -1551,57 +1551,56 @@
- enable_ssl=no
- fi
-
--dnl # Include SSL support
-+dnl # Correct --enable vs --disable SSL flipflop logic
- AC_SUBST(ac_no_ssl)
- AC_SUBST(ac_ssl_has_aes_gcm,0)
- AC_ARG_ENABLE(ssl,
- AS_HELP_STRING([--disable-ssl],
- [Exclude SSL support the build (default: autodetect)])
-- ,
-- [
-- if test "$enable_ssl" = "no"; then
-- [ac_no_ssl=1]
-- AC_MSG_RESULT([Checking if SSL support is disabled... yes])
-- fi
-- ],
-- [
-- AC_MSG_RESULT([checking for OpenSSL installations..])
-- if test "x$with_ssl" != "xno" -a "x$with_ssl" != "x"; then
-- CFLAGS="$CFLAGS -I$with_ssl/include"
-- LDFLAGS="$LDFLAGS -L$with_ssl/lib"
-- AC_MSG_RESULT([Using SSL prefix... $with_ssl])
-- fi
-- AC_SUBST(openssl_h_present)
-- AC_SUBST(libssl_present)
-- AC_SUBST(libcrypto_present)
-- AC_CHECK_HEADER(openssl/ssl.h,[openssl_h_present=1])
-- AC_CHECK_LIB(crypto,ERR_load_BIO_strings,[libcrypto_present=1 && LIBS="-lcrypto $LIBS"])
-- AC_CHECK_LIB(ssl,SSL_CTX_new,[libssl_present=1 && LIBS="-lssl $LIBS"])
-- if test "x$openssl_h_present" = "x1" -a "x$libssl_present" = "x1" -a "x$libcrypto_present" = "x1"; then
-- AC_MSG_RESULT([OpenSSL library found, SSL support enabled])
--
-- # Check if SRTP should be compiled with OpenSSL
-- # support, to enable cryptos such as AES GCM.
--
-- # EVP_CIPHER_CTX is now opaque in OpenSSL 1.1.0, libsrtp 1.5.4 uses it as a transparent type.
-- # Update 2.7: our bundled libsrtp has been upgraded to 2.1.0,
-- # so we can omit EVP_CIPHER_CTX definition check now.
-- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <openssl/evp.h>]],
-- [EVP_CIPHER_CTX *ctx;EVP_aes_128_gcm();])],
-- [AC_CHECK_LIB(crypto,EVP_aes_128_gcm,[ac_ssl_has_aes_gcm=1])])
-- if test "x$ac_ssl_has_aes_gcm" = "x1"; then
-- AC_MSG_RESULT([OpenSSL has AES GCM support, SRTP will use OpenSSL])
-- else
-- AC_MSG_RESULT([OpenSSL AES GCM support not found, SRTP will only support AES CM cryptos])
-- fi
--
-- # PJSIP_HAS_TLS_TRANSPORT setting follows PJ_HAS_SSL_SOCK
-- #AC_DEFINE(PJSIP_HAS_TLS_TRANSPORT, 1)
-- AC_DEFINE(PJ_HAS_SSL_SOCK, 1)
-+)
-+
-+dnl # OpenSSL detection
-+AC_MSG_CHECKING([OpenSSL installations])
-+if test "x$enable_ssl" = "xno"; then
-+ ac_no_ssl=1
-+ AC_MSG_RESULT([explicitly disabled])
-+else
-+ if test "x$with_ssl" != "xno" -a "x$with_ssl" != "x"; then
-+ CFLAGS="$CFLAGS -I$with_ssl/include"
-+ LDFLAGS="$LDFLAGS -L$with_ssl/lib"
-+ AC_MSG_RESULT([Using SSL prefix... $with_ssl])
-+ fi
-+ AC_SUBST(openssl_h_present)
-+ AC_SUBST(libssl_present)
-+ AC_SUBST(libcrypto_present)
-+ AC_CHECK_HEADER(openssl/ssl.h,[openssl_h_present=1])
-+ AC_CHECK_LIB(crypto,ERR_load_BIO_strings,[libcrypto_present=1 && LIBS="-lcrypto $LIBS"])
-+ AC_CHECK_LIB(ssl,SSL_CTX_new,[libssl_present=1 && LIBS="-lssl $LIBS"])
-+ if test "x$openssl_h_present" = "x1" -a "x$libssl_present" = "x1" -a "x$libcrypto_present" = "x1"; then
-+ AC_MSG_RESULT([OpenSSL library found, SSL support enabled])
-+
-+ # Check if SRTP should be compiled with OpenSSL
-+ # support, to enable cryptos such as AES GCM.
-+
-+ # EVP_CIPHER_CTX is now opaque in OpenSSL 1.1.0, libsrtp 1.5.4 uses it as a transparent type.
-+ # Update 2.7: our bundled libsrtp has been upgraded to 2.1.0,
-+ # so we can omit EVP_CIPHER_CTX definition check now.
-+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <openssl/evp.h>]],
-+ [EVP_CIPHER_CTX *ctx;EVP_aes_128_gcm();])],
-+ [AC_CHECK_LIB(crypto,EVP_aes_128_gcm,[ac_ssl_has_aes_gcm=1])])
-+ if test "x$ac_ssl_has_aes_gcm" = "x1"; then
-+ AC_MSG_RESULT([OpenSSL has AES GCM support, SRTP will use OpenSSL])
- else
-- AC_MSG_RESULT([** OpenSSL libraries not found, disabling SSL support **])
-+ AC_MSG_RESULT([OpenSSL AES GCM support not found, SRTP will only support AES CM cryptos])
- fi
-- ])
-+
-+ # PJSIP_HAS_TLS_TRANSPORT setting follows PJ_HAS_SSL_SOCK
-+ #AC_DEFINE(PJSIP_HAS_TLS_TRANSPORT, 1)
-+ AC_DEFINE(PJ_HAS_SSL_SOCK, 1)
-+ else
-+ AC_MSG_RESULT([** OpenSSL libraries not found, disabling SSL support **])
-+ fi
-+fi
-
- dnl # Obsolete option --with-opencore-amrnb
- AC_ARG_WITH(opencore-amrnb,
diff --git a/net-libs/pjproject/pjproject-2.7.2-r2.ebuild b/net-libs/pjproject/pjproject-2.7.2-r2.ebuild
deleted file mode 100644
index e7a5866..0000000
--- a/net-libs/pjproject/pjproject-2.7.2-r2.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic
-
-DESCRIPTION="Open source SIP, Media, and NAT Traversal Library"
-HOMEPAGE="https://www.pjsip.org/"
-SRC_URI="https://www.pjsip.org/release/${PV}/${P}.tar.bz2"
-KEYWORDS="amd64 ~ppc x86"
-
-LICENSE="GPL-2"
-SLOT="0"
-CODEC_FLAGS="g711 g722 g7221 gsm ilbc speex l16"
-VIDEO_FLAGS="sdl ffmpeg v4l2 openh264 libyuv"
-SOUND_FLAGS="alsa oss portaudio"
-IUSE="amr debug doc epoll examples ipv6 opus resample silk ssl static-libs webrtc ${CODEC_FLAGS} ${VIDEO_FLAGS} ${SOUND_FLAGS}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-ssl-flipflop.patch
- "${FILESDIR}"/${P}-libressl.patch
-)
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- oss? ( media-libs/portaudio[oss] )
- portaudio? ( media-libs/portaudio )
-
- amr? ( media-libs/opencore-amr )
- gsm? ( media-sound/gsm )
- ilbc? ( media-libs/libilbc )
- opus? ( media-libs/opus )
- speex? ( media-libs/speexdsp )
-
- ffmpeg? ( media-video/ffmpeg:= )
- sdl? ( media-libs/libsdl )
- openh264? ( media-libs/openh264 )
- resample? ( media-libs/libsamplerate )
-
- ssl? ( dev-libs/openssl:0= )
-
- net-libs/libsrtp:0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- !!media-plugins/mediastreamer-bcg729"
-
-REQUIRED_USE="?? ( ${SOUND_FLAGS} )"
-
-src_prepare() {
- default
- rm configure || die "Unable to remove unwanted wrapper"
- mv aconfigure.ac configure.ac || die "Unable to rename configure script source"
- eautoreconf
-}
-
-src_configure() {
- local myconf=()
- local videnable="--disable-video"
- local t
-
- use ipv6 && append-cflags -DPJ_HAS_IPV6=1
- use debug || append-cflags -DNDEBUG=1
-
- for t in ${CODEC_FLAGS}; do
- myconf+=( $(use_enable ${t} ${t}-codec) )
- done
-
- for t in ${VIDEO_FLAGS}; do
- myconf+=( $(use_enable ${t}) )
- use "${t}" && videnable="--enable-video"
- done
-
- econf \
- --enable-shared \
- --with-external-srtp \
- ${videnable} \
- $(use_enable epoll) \
- $(use_with gsm external-gsm) \
- $(use_with speex external-speex) \
- $(use_enable speex speex-aec) \
- $(use_enable resample) \
- $(use_enable resample libsamplerate) \
- $(use_enable resample resample-dll) \
- $(use_enable alsa sound) \
- $(use_enable oss) \
- $(use_with portaudio external-pa) \
- $(use_enable portaudio ext-sound) \
- $(use_enable amr opencore-amr) \
- $(use_enable silk) \
- $(use_enable opus) \
- $(use_enable ssl) \
- $(use_enable webrtc libwebrtc) \
- "${myconf[@]}"
-}
-
-src_compile() {
- emake dep
- emake
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- if use doc; then
- dodoc README.txt README-RTEMS
- fi
-
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r pjsip-apps/src/samples
- fi
-
- use static-libs || rm "${D}/usr/$(get_libdir)/*.a"
-}