aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaki Xi <space_raccoon@riseup.net>2023-01-15 22:03:43 +0100
committerQuentin Retornaz <gentoo@retornaz.com>2023-01-17 01:50:17 +0100
commita619157cb2b0c7df1c8e38812b619b0b12baaf3e (patch)
treef427626b701c606d3ddb60a0b9209e00a97aaa98 /dev-python
parentdev-python/m2crypto version update (diff)
downloadlibressl-a619157cb2b0c7df1c8e38812b619b0b12baaf3e.tar.gz
libressl-a619157cb2b0c7df1c8e38812b619b0b12baaf3e.tar.bz2
libressl-a619157cb2b0c7df1c8e38812b619b0b12baaf3e.zip
dev-python/m2crypto drop old-version
Signed-off-by: Saki Xi <space_raccoon@riseup.net> Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/m2crypto/m2crypto-0.37.1.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/m2crypto/m2crypto-0.37.1.ebuild b/dev-python/m2crypto/m2crypto-0.37.1.ebuild
deleted file mode 100644
index 3e44a80..0000000
--- a/dev-python/m2crypto/m2crypto-0.37.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2018-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 toolchain-funcs
-
-MY_PN="M2Crypto"
-DESCRIPTION="A Python crypto and SSL toolkit"
-HOMEPAGE="https://gitlab.com/m2crypto/m2crypto https://pypi.org/project/M2Crypto/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- >=dev-lang/swig-2.0.9
- test? ( dev-python/parameterized[${PYTHON_USEDEP}] )
-"
-RDEPEND="dev-libs/openssl:0="
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-libressl-0.31.0.patch"
-)
-
-swig_define() {
- local x
- for x; do
- if tc-cpp-is-true "defined(${x})"; then
- SWIG_FEATURES+=" -D${x}"
- fi
- done
-}
-
-src_prepare() {
- # TODO
- sed -e 's:test_server_simple_timeouts:_&:' \
- -i tests/test_ssl.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- # setup.py looks at platform.machine() to determine swig options.
- # For exotic ABIs, we need to give swig a hint.
- local -x SWIG_FEATURES=
-
- # https://bugs.gentoo.org/617946
- swig_define __ILP32__
-
- # https://bugs.gentoo.org/674112
- swig_define __ARM_PCS_VFP
-
- distutils-r1_python_compile --openssl="${ESYSROOT}"/usr
-}
-
-python_test() {
- esetup.py test
-}