aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-02-05 23:31:14 -0800
committerAric Belsito <lluixhi@gmail.com>2017-02-05 23:31:14 -0800
commit0570fc8078d95b62f23a73c2b29940595e2c086d (patch)
treebf53092544b7efed13503d8ab6d47e2480a13117 /dev-python
parentdev-qt/qtnetwork: Fix build with OpenSSL (diff)
downloadlibressl-0570fc8078d95b62f23a73c2b29940595e2c086d.tar.gz
libressl-0570fc8078d95b62f23a73c2b29940595e2c086d.tar.bz2
libressl-0570fc8078d95b62f23a73c2b29940595e2c086d.zip
dev-python/cryptography: version bump to 1.7.2
Remove 1.3 which is no longer in the tree.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cryptography/Manifest2
-rw-r--r--dev-python/cryptography/cryptography-1.7.2.ebuild (renamed from dev-python/cryptography/cryptography-1.3.1.ebuild)17
-rw-r--r--dev-python/cryptography/files/cryptography-1.3-libressl.patch30
3 files changed, 11 insertions, 38 deletions
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index 0f5af40..9b74575 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -1,2 +1,2 @@
-DIST cryptography-1.3.1.tar.gz 383852 SHA256 b4b36175e0f95ddc88435c26dbe3397edce48e2ff5fe41d504cdb3beddcd53e2 SHA512 8b833619d0aec5e6630c8e069e886f6b708b0b3a4f4ca4e37797a24c69be4cacf162f20c068deaecc3222ee0323583582d384e49fa3dbaeaeefc0d7d8c92918a WHIRLPOOL f9e7c75e910699afdf4adc4fb7257135b97c357c967bbca95f332e1f2ed262716ebba6a648427f86a524e75f6ac46aea7f891fe42100c9d7cf8ffcc317fb7905
DIST cryptography-1.7.1.tar.gz 420673 SHA256 953fef7d40a49a795f4d955c5ce4338abcec5dea822ed0414ed30348303fdb4c SHA512 fb88b0ee9e314526fcdbb6d35da409b7335c7408a69d2350c58379471d2b9d76021010955629cf776d26312f22d4f8aa3f135955a19dfbff9d602176c9bbfd40 WHIRLPOOL 24b705889b95b568000600662ec82e3f5571582525db3571f3285b99f985b0a21eefd14dccc577700bc082891f7d3c563ac78a8bfd8d810da3ff38914ae5a86d
+DIST cryptography-1.7.2.tar.gz 420867 SHA256 878cb68b3da3d493ffd68f36db11c29deee623671d3287c3f8d685117ffda9a9 SHA512 8ddd119385064e1f8288ff318ec16f500b5c125a3811ccb306aeb2664fac495fcdd3cb5a7cbacd10156505c9526b9cdbd66860b35bbcd2f9a6bb285dd6cba8c5 WHIRLPOOL 531265115a6573c54e2cf85a03f1ed0ebe033fd7818168a3bcda938458f9a32464d7de0c226f46a300635ee52e4995285889bb693bc56f77f816bc81d52bfc61
diff --git a/dev-python/cryptography/cryptography-1.3.1.ebuild b/dev-python/cryptography/cryptography-1.7.2.ebuild
index 15c6f5c..969afbe 100644
--- a/dev-python/cryptography/cryptography-1.3.1.ebuild
+++ b/dev-python/cryptography/cryptography-1.7.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -15,14 +15,14 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="|| ( Apache-2.0 BSD )"
SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="libressl test"
RDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl )
$(python_gen_cond_dep '>=dev-python/cffi-1.4.1:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy{,3})
>=dev-python/idna-2.0[${PYTHON_USEDEP}]
>=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
@@ -38,13 +38,16 @@ DEPEND="${RDEPEND}
dev-python/iso8601[${PYTHON_USEDEP}]
dev-python/pretend[${PYTHON_USEDEP}]
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
)"
DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
-PATCHES=( "${FILESDIR}/${PN}-1.3-libressl.patch" )
+PATCHES=( "${FILESDIR}"/${PN}-1.7.1-libressl251.patch )
python_test() {
+ distutils_install_for_testing
+
py.test -v -v -x || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/cryptography/files/cryptography-1.3-libressl.patch b/dev-python/cryptography/files/cryptography-1.3-libressl.patch
deleted file mode 100644
index e2a6e8b..0000000
--- a/dev-python/cryptography/files/cryptography-1.3-libressl.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 1e88d741f6e15d9170466a08dfe85f28b12c7623 Mon Sep 17 00:00:00 2001
-From: Paul Kehrer <paul.l.kehrer@gmail.com>
-Date: Mon, 28 Mar 2016 22:00:00 -0400
-Subject: [PATCH] fix libressl breakage reported in #2858
-
----
- src/_cffi_src/build_openssl.py | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/src/_cffi_src/build_openssl.py b/src/_cffi_src/build_openssl.py
-index 2ff28d7..3f92529 100644
---- a/src/_cffi_src/build_openssl.py
-+++ b/src/_cffi_src/build_openssl.py
-@@ -38,8 +38,15 @@ def _osx_libraries(build_static):
-
-
- _PRE_INCLUDE = """
-+#include <openssl/opensslv.h>
-+/*
-+ LibreSSL removed e_os2.h from the public headers so we'll only include it
-+ if we're using vanilla OpenSSL.
-+*/
-+#if !defined(LIBRESSL_VERSION_NUMBER)
- #include <openssl/e_os2.h>
--#if defined(OPENSSL_SYS_WINDOWS)
-+#endif
-+#if defined(OPENSSL_SYS_WINDOWS) || defined(_WIN32)
- #include <windows.h>
- #endif
- """