aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-04-22 16:38:24 -0700
committerorbea <orbea@riseup.net>2024-04-22 16:38:24 -0700
commit4d0b6beb75df99ea239c35ff83454f4b7f9bdf32 (patch)
tree4f6f7843690d33149ca32e512fabd3a7133990fb
parentdev-python/m2crypto: stabilize 0.41.0 (diff)
downloadlibressl-4d0b6beb75df99ea239c35ff83454f4b7f9bdf32.tar.gz
libressl-4d0b6beb75df99ea239c35ff83454f4b7f9bdf32.tar.bz2
libressl-4d0b6beb75df99ea239c35ff83454f4b7f9bdf32.zip
dev-python/m2crypto: drop 0.40.1
Signed-off-by: orbea <orbea@riseup.net>
-rw-r--r--dev-python/m2crypto/Manifest1
-rw-r--r--dev-python/m2crypto/m2crypto-0.40.1.ebuild79
2 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index 1624fd7..3574714 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,2 +1 @@
-DIST M2Crypto-0.40.1.tar.gz 1266138 BLAKE2B a44de6b66695e0fbbba671682a7773ddbbd15225d27329d357e0005e395a70c6b006401ec30fb6938c9c4683377519844ea646df7c176181977139f6381c6907 SHA512 ca914de14621af4aa9b7f11664702557e596438cc76869478a2a75eb37ca14243e7064db7e32985834260ffa9136836884e60916d542a685ac3f1481b9320b69
DIST M2Crypto-0.41.0.tar.gz 1151680 BLAKE2B 6c5294294fd62ca69eec8222324ce8a1012c999aab241eba2e5b0085c0d7b598fd62f26e106bea95bfad3199abb2db9876547f521b34f45930b00540a6ecc24a SHA512 50ca5e32ae999b9ecdc7f3bbd35221b4a7523ef29e54eb4bc266457723117718955f99b9e7ac42a4cb982f0e22a94e5c852d6886d7dfb157d040ad86c17660fb
diff --git a/dev-python/m2crypto/m2crypto-0.40.1.ebuild b/dev-python/m2crypto/m2crypto-0.40.1.ebuild
deleted file mode 100644
index 725038f..0000000
--- a/dev-python/m2crypto/m2crypto-0.40.1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 2018-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-PYTHON_COMPAT=( python3_{10..12} )
-PYPI_NO_NORMALIZE=1
-PYPI_PN="M2Crypto"
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 toolchain-funcs pypi
-
-DESCRIPTION="A Python crypto and SSL toolkit"
-HOMEPAGE="
- https://gitlab.com/m2crypto/m2crypto/
- https://pypi.org/project/M2Crypto/
-"
-
-# openssl via src/SWIG/_lib11_compat.i
-LICENSE="MIT openssl"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test abi_mips_n32 abi_mips_n64 abi_mips_o32"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- >=dev-lang/swig-2.0.9
-"
-RDEPEND="
- dev-libs/openssl:=
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-libressl-0.38.0.patch
-)
-
-distutils_enable_tests setup.py
-
-swig_define() {
- local x
- for x; do
- if tc-cpp-is-true "defined(${x})"; then
- SWIG_FEATURES+=" -D${x}"
- fi
- done
-}
-
-src_prepare() {
- # relies on very exact clock behavior which apparently fails
- # with inconvenient CONFIG_HZ*
- sed -e 's:test_server_simple_timeouts:_&:' \
- -i tests/test_ssl.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- # setup.py looks at platform.machine() to determine swig options.
- # For exotic ABIs, we need to give swig a hint.
- local -x SWIG_FEATURES=
-
- # https://bugs.gentoo.org/617946
- swig_define __ILP32__
-
- # https://bugs.gentoo.org/674112
- swig_define __ARM_PCS_VFP
-
- # Avoid similar errors to bug #688668 for MIPS
- if use abi_mips_n32; then
- swig_define _MIPS_SIM = _ABIN32
- elif use abi_mips_n64; then
- swig_define _MIPS_SIM = _ABI64
- elif use abi_mips_o32; then
- swig_define _MIPS_SIM = _ABIO32
- fi
-
- distutils-r1_python_compile --openssl="${ESYSROOT}"/usr
-}