aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/maestral/maestral-1.7.0_rc1.ebuild')
-rw-r--r--net-misc/maestral/maestral-1.7.0_rc1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/net-misc/maestral/maestral-1.7.0_rc1.ebuild b/net-misc/maestral/maestral-1.7.0_rc1.ebuild
deleted file mode 100644
index ef1159aae..000000000
--- a/net-misc/maestral/maestral-1.7.0_rc1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 xdg
-
-MY_PV=${PV/_rc/.dev}
-DESCRIPTION="Maestral is an open-source Dropbox client written in Python"
-HOMEPAGE="https://maestral.app"
-SRC_URI="https://github.com/samschott/maestral/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-LICENSE="MIT"
-SLOT="0"
-if [[ ${PV} != *_rc* ]]; then
- KEYWORDS="~amd64"
-fi
-
-RDEPEND="
- >=dev-python/click-8.0.2[${PYTHON_USEDEP}]
- >=dev-python/desktop-notifier-3.3.0[${PYTHON_USEDEP}]
- =dev-python/dropbox-11*[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.15[${PYTHON_USEDEP}]
- >=dev-python/keyring-22.0.0[${PYTHON_USEDEP}]
- >=dev-python/keyrings-alt-3.1.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/pathspec-0.5.8[${PYTHON_USEDEP}]
- >=dev-python/Pyro5-5.10[${PYTHON_USEDEP}]
- >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- >=dev-python/survey-3.4.3[${PYTHON_USEDEP}]
- <dev-python/survey-4.0.0[${PYTHON_USEDEP}]
- >=dev-python/watchdog-2.0.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/build[${PYTHON_USEDEP}]
-"
-
-EPYTEST_DESELECT=(
- # requires dev-python/pytest-benchmark not available for py3.11
- tests/offline/test_clean_local_events.py::test_performance
-
- # requires systemd
- tests/offline/test_cli.py::test_autostart
-
- # requires network
- tests/offline/test_main.py::test_check_for_updates
-)
-
-distutils_enable_tests pytest