aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/qview/qview-6.1.ebuild')
-rw-r--r--media-gfx/qview/qview-6.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-gfx/qview/qview-6.1.ebuild b/media-gfx/qview/qview-6.1.ebuild
new file mode 100644
index 000000000..64445115d
--- /dev/null
+++ b/media-gfx/qview/qview-6.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Practical and minimal image viewer"
+HOMEPAGE="https://github.com/jurplel/qView https://interversehq.com/qview/"
+SRC_URI="https://github.com/jurplel/qView/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/qView-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-qt/qtbase[concurrent,gui,network,widgets]
+"
+
+DEPEND="${RDEPEND}
+"
+
+BDEPEND="
+ dev-qt/qttools[linguist]
+"
+
+src_configure() {
+ eqmake6 PREFIX=/usr qView.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}