aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/glicko2/glicko2-2.0.0-r1.ebuild19
-rw-r--r--dev-python/glicko2/glicko2-2.0.0.ebuild24
2 files changed, 19 insertions, 24 deletions
diff --git a/dev-python/glicko2/glicko2-2.0.0-r1.ebuild b/dev-python/glicko2/glicko2-2.0.0-r1.ebuild
new file mode 100644
index 000000000..c6a18e6cb
--- /dev/null
+++ b/dev-python/glicko2/glicko2-2.0.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="glicko2 implementation in python"
+HOMEPAGE="https://github.com/deepy/glicko2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
diff --git a/dev-python/glicko2/glicko2-2.0.0.ebuild b/dev-python/glicko2/glicko2-2.0.0.ebuild
deleted file mode 100644
index 8e58ac871..000000000
--- a/dev-python/glicko2/glicko2-2.0.0.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( python3_{8,9} pypy3)
-
-inherit distutils-r1
-
-DESCRIPTION="glicko2 implementation in python"
-HOMEPAGE="https://github.com/deepy/glicko2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-distutils_enable_tests setup.py
-
-src_prepare() {
- sed -i -e "s/distribute/setuptools/g" \
- -e 's/setuptools.find_packages()/setuptools.find_packages(exclude=["*test*"])/g' \
- setup.py
- default
-}