aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/komikku/komikku-1.51.1.ebuild')
-rw-r--r--app-text/komikku/komikku-1.51.1.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/app-text/komikku/komikku-1.51.1.ebuild b/app-text/komikku/komikku-1.51.1.ebuild
deleted file mode 100644
index 7af66f6f1..000000000
--- a/app-text/komikku/komikku-1.51.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="sqlite(+),ssl(+)"
-DISTUTILS_USE_PEP517=no
-DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 meson gnome2-utils xdg
-
-DESCRIPTION="Manga reader for GNOME"
-HOMEPAGE="https://apps.gnome.org/Komikku/"
-SRC_URI="https://codeberg.org/valos/Komikku/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RESTRICT="test"
-# Depend on a random server that may or may not be accessible.
-#PROPERTIES="test_network"
-
-DEPEND="
- dev-libs/glib:2
- dev-libs/gobject-introspection
- >=gui-libs/gtk-4.12:4
- >=gui-libs/libadwaita-1.5:1[introspection]
- net-libs/webkit-gtk:6[introspection]
-"
-RDEPEND="
- ${DEPEND}
- x11-libs/libnotify[introspection]
- $(python_gen_cond_dep '
- app-arch/brotli[python,${PYTHON_USEDEP}]
- dev-python/beautifulsoup4[${PYTHON_USEDEP}]
- dev-python/colorthief[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/dateparser[${PYTHON_USEDEP}]
- dev-python/emoji[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/natsort[${PYTHON_USEDEP}]
- dev-python/piexif[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pillow-heif[${PYTHON_USEDEP}]
- dev-python/pygobject[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/rarfile[compressed,${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/unidecode[${PYTHON_USEDEP}]
- ')
-"
-BDEPEND="
- dev-util/blueprint-compiler
- sys-devel/gettext
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest-steps[${PYTHON_USEDEP}]
- ')
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # fix broken shebang
- sed "s|py_installation.full_path()|'${PYTHON}'|" -i bin/meson.build || die
-}
-
-src_test() {
- emake setup
- emake develop
- emake test
-}
-
-src_install() {
- meson_src_install
- python_optimize
-}
-
-pkg_postinst() {
- gnome2_schemas_update
- xdg_pkg_postinst
-}
-
-pkg_postrm() {
- gnome2_schemas_update
- xdg_pkg_postrm
-}