aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorLuciano Degni (Pungolo) <degni.public@gmail.com>2022-10-24 15:20:22 +0200
committerLuciano Degni (Pungolo) <degni.public@gmail.com>2022-10-24 15:20:56 +0200
commit2c6c193dbe767eb3d62305ecc46647e7ae86e266 (patch)
tree61b603e275e348dc9c3ad9922e8f9397aee250ca /x11-wm
parentgames-util/roll: enable tests (diff)
downloadguru-2c6c193dbe767eb3d62305ecc46647e7ae86e266.tar.gz
guru-2c6c193dbe767eb3d62305ecc46647e7ae86e266.tar.bz2
guru-2c6c193dbe767eb3d62305ecc46647e7ae86e266.zip
x11-wm/dk: add 1.7
Signed-off-by: Luciano Degni (Pungolo) <degni.public@gmail.com>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dk/Manifest1
-rw-r--r--x11-wm/dk/dk-1.7.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/x11-wm/dk/Manifest b/x11-wm/dk/Manifest
new file mode 100644
index 000000000..de452118e
--- /dev/null
+++ b/x11-wm/dk/Manifest
@@ -0,0 +1 @@
+DIST dk-1.7.tar.gz 61896 BLAKE2B 06a914b377591d3ebe0a92de430bf5a540252ded4fb6ea731fa6fd7459268eab82547c36071385b44f293434a8028a888e60071ae185915852e2dc98acb2daea SHA512 17a36938d22caf436414bb7c29b4370f768c3155c7835b455ae63c374e45fad1218e4332e2b2d4e8f7933259b4c8d7ad19b86fbede063b670c755668ce77796e
diff --git a/x11-wm/dk/dk-1.7.ebuild b/x11-wm/dk/dk-1.7.ebuild
new file mode 100644
index 000000000..9ec1de9dc
--- /dev/null
+++ b/x11-wm/dk/dk-1.7.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A list based tiling window manager in the vein of dwm, bspwm, and xmonad."
+HOMEPAGE="https://bitbucket.org/natemaia/dk/src/master/"
+#EGIT_REPO_URI="https://bitbucket.org/natemaia/dk.git"
+SRC_URI="https://bitbucket.org/natemaia/dk/get/bc9bd6349321c27ddb2dd7a9cb7630e2f1794c85.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
+
+inherit toolchain-funcs xdg-utils desktop
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples man"
+RESTRICT=strip
+DEPEND="
+ x11-base/xcb-proto
+ x11-libs/libxcb
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+"
+
+RDEPEND="
+ ${DEPEND}
+ x11-misc/sxhkd
+"
+KEYWORDS="amd64 ~riscv x86"
+#src_prepare() {
+# default
+
+# -e "s/ -Os / /" \
+
+# sed -i \
+# -e "/^\(LDFLAGS\|CFLAGS\|CPPFLAGS\)/{s| = | += |g;s|-s ||g}" \
+# Makefile || die
+#}
+
+src_compile() {
+ # -Os not happy
+ #replace-flags -Os -O2
+ cd natemaia-dk-bc9bd6349321 || die
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ cd natemaia-dk-bc9bd6349321 || die
+ if use man; then
+ sed "s/VERSION/${VERSION}/g" man/dk.1 || die
+ doman man/*.*
+ fi
+
+ dobin dk dkcmd
+ make_desktop_entry dk.desktop /usr/share/xsessions/
+ #emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ #DOC="/usr/share/doc/${PF}" MAN="/usr/share/man/man1/" install
+ #dobin ${D}/dk
+
+# insinto /etc/xdg/sxhkd
+# doins examples/sxhkdrc
+
+# if use doc ; then
+# insinto /etc/xdg/sxhkd
+# doins doc/sxhkdrc doc/dkrc
+# insinto /etc/xdg/dk
+# doins doc/scripts
+# fi
+}
+
+#src_test() {
+# emake test
+#}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}