aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2023-12-10 13:32:30 +0100
committerJonas Frei <freijon@pm.me>2023-12-10 13:32:50 +0100
commitd99b89d0032d562003d7f734a243cc64459ddc81 (patch)
tree1bb4ba9b8a290ad518271a7f11cca9ff46e14c37 /x11-terms
parentx11-terms/rio: add 0.0.30 (diff)
downloadguru-d99b89d0032d562003d7f734a243cc64459ddc81.tar.gz
guru-d99b89d0032d562003d7f734a243cc64459ddc81.tar.bz2
guru-d99b89d0032d562003d7f734a243cc64459ddc81.zip
x11-terms/rio-terminfo: add 0.0.30
Signed-off-by: Jonas Frei <freijon@pm.me>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rio-terminfo/Manifest1
-rw-r--r--x11-terms/rio-terminfo/rio-terminfo-0.0.30.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/x11-terms/rio-terminfo/Manifest b/x11-terms/rio-terminfo/Manifest
index 1005ddb4e..1b68daa65 100644
--- a/x11-terms/rio-terminfo/Manifest
+++ b/x11-terms/rio-terminfo/Manifest
@@ -1 +1,2 @@
DIST rio-0.0.28.tar.gz 34177343 BLAKE2B 38a2077a85d3008a361a91d76581128e73bc6a49b7a656d64f44c13512772deec6d0190880f323e41e12c6f6552549675a3f06ae7b20285f0a3bdb0bb5c01292 SHA512 6dd1992ab761d6c5b7ad78c483fe0096a4d1c93b241480c14cf10799cc831029023989f676be835d744f7a170733f3503f37f90ed92e3790dfb8fa334c07e68b
+DIST rio-0.0.30.tar.gz 34176115 BLAKE2B b81e024d9c0d8eae066ee7978d6c3766680d66101fc1670ad7cf993118887e92d4a39f7643bb21898e7cf28f91a9eab5815579953b05e000ef1d70dbb5fd391a SHA512 21372fc52c5a47a36aabcf8f3bb5d81e2832d5526a3915ba23166aaaaacdaa4bdce8d3e338827a4734505625afa1db7f54471c50c56da21bed4bf4c53d6dd89b
diff --git a/x11-terms/rio-terminfo/rio-terminfo-0.0.30.ebuild b/x11-terms/rio-terminfo/rio-terminfo-0.0.30.ebuild
new file mode 100644
index 000000000..ad2dacb02
--- /dev/null
+++ b/x11-terms/rio-terminfo/rio-terminfo-0.0.30.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="rio"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Terminfo for Rio, a hardware-accelerated GPU terminal emulator powered by WebGPU"
+HOMEPAGE="https://raphamorim.io/rio/"
+SRC_URI="
+ https://github.com/raphamorim/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.tar.gz
+"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # intended to be ran on the full rio package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir "/usr/share/terminfo"
+ tic -xo "${ED}/usr/share/terminfo" "misc/rio.terminfo" || die
+}