aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortiotags <tiotags1@gmail.com>2021-04-26 12:39:03 +0300
committertiotags <tiotags1@gmail.com>2021-04-26 12:39:03 +0300
commitae65a194038ff27752b13602466ffef599002c09 (patch)
treeca3d23b85fc805a69380023be9dc06bac99122e4 /www-servers
parentsys-cluster/clusteringsuite: delete patch (diff)
downloadguru-ae65a194038ff27752b13602466ffef599002c09.tar.gz
guru-ae65a194038ff27752b13602466ffef599002c09.tar.bz2
guru-ae65a194038ff27752b13602466ffef599002c09.zip
www-servers/hinsightd: switched to cmake
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alexandru Campeanu <tiotags1@gmail.com>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/hinsightd/files/init.d.sh2
-rw-r--r--www-servers/hinsightd/hinsightd-9999.ebuild30
-rw-r--r--www-servers/hinsightd/metadata.xml2
3 files changed, 21 insertions, 13 deletions
diff --git a/www-servers/hinsightd/files/init.d.sh b/www-servers/hinsightd/files/init.d.sh
index 9146de844e..bc05ab5c93 100644
--- a/www-servers/hinsightd/files/init.d.sh
+++ b/www-servers/hinsightd/files/init.d.sh
@@ -14,7 +14,7 @@ RUN_USER="hinsightd"
extra_commands="checkconfig reload"
command=$RUN_FILE
-command_args="--config $CFG_FILE --logdir $LOG_DIR --cwd $CWD_DIR --pidfile $PID_FILE --tmpdir $TMP_DIR"
+command_args="--config $CFG_FILE --logdir $LOG_DIR/ --cwd $CWD_DIR/ --pidfile $PID_FILE --tmpdir $TMP_DIR"
pidfile="$PID_FILE"
command_args_background="--daemonize"
command_user="$RUN_USER:$RUN_USER"
diff --git a/www-servers/hinsightd/hinsightd-9999.ebuild b/www-servers/hinsightd/hinsightd-9999.ebuild
index 8ae886a394..9107371b81 100644
--- a/www-servers/hinsightd/hinsightd-9999.ebuild
+++ b/www-servers/hinsightd/hinsightd-9999.ebuild
@@ -5,21 +5,30 @@ EAPI=7
LUA_COMPAT=( lua5-{1..4} )
-inherit git-r3 fcaps lua-single systemd
+inherit fcaps lua-single systemd cmake
DESCRIPTION="hinsightd a http/1.1 webserver with (hopefully) minimal goals"
HOMEPAGE="https://gitlab.com/tiotags/hin9"
-EGIT_REPO_URI="https://gitlab.com/tiotags/hin9.git"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.com/tiotags/hin9.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://gitlab.com/tiotags/hin9/-/archive/v${PV}/hin9-v${PV}.tar.gz"
+ S="${WORKDIR}/hin9-v${PV}"
+fi
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE="" #+openssl
+IUSE="+openssl"
REQUIRED_USE="${LUA_REQUIRED_USE}"
BDEPEND="
dev-util/ninja
+ dev-util/cmake
virtual/pkgconfig
"
@@ -29,7 +38,7 @@ RDEPEND="
acct-group/hinsightd
sys-libs/liburing
sys-libs/zlib
- dev-libs/openssl
+ openssl? ( dev-libs/openssl )
"
DEPEND="${RDEPEND}"
@@ -38,16 +47,15 @@ PATCHES=(
"${FILESDIR}/hinsightd-redefine-directories.patch"
)
-#src_configure() {
-#}
-
-src_compile() {
- cd build
- ninja || die
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_OPENSSL=$(usex openssl)
+ )
+ cmake_src_configure
}
src_install() {
- newbin "${S}/build/hin9" hinsightd
+ newbin "${BUILD_DIR}/hin9" hinsightd
newinitd "${FILESDIR}/init.d.sh" hinsightd
systemd_dounit "${FILESDIR}/hinsightd.service" # not tested
diff --git a/www-servers/hinsightd/metadata.xml b/www-servers/hinsightd/metadata.xml
index f494a4303b..f06968fc08 100644
--- a/www-servers/hinsightd/metadata.xml
+++ b/www-servers/hinsightd/metadata.xml
@@ -17,6 +17,6 @@
Full debug information can be toggled per request and outputted to console or a log file.
</longdescription>
<use>
- <!--<flag name="openssl">Enable tls encryption with openssl</flag>-->
+ <flag name="openssl">Enable tls encryption with openssl</flag>
</use>
</pkgmetadata>