aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-07-19 10:46:16 +0200
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-07-19 10:47:31 +0200
commit532ea04b5379c6fc305e7d4dd054616c4727945c (patch)
tree5cd702e30eeb41c955709e7a6b4f5223151dfc27 /www-client
parentnet-p2p/dogecoin-qt: implemented optional 'dogecoind' and 'utils' USE flags. (diff)
downloadguru-532ea04b5379c6fc305e7d4dd054616c4727945c.tar.gz
guru-532ea04b5379c6fc305e7d4dd054616c4727945c.tar.bz2
guru-532ea04b5379c6fc305e7d4dd054616c4727945c.zip
www-client/badwolf-9999: Switched to ninja as buildsystem
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/badwolf/badwolf-9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/www-client/badwolf/badwolf-9999.ebuild b/www-client/badwolf/badwolf-9999.ebuild
index dbb42ae89..5c0d7dbc5 100644
--- a/www-client/badwolf/badwolf-9999.ebuild
+++ b/www-client/badwolf/badwolf-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit xdg
+inherit xdg ninja-utils
if [[ "${PV}" == "9999" ]]
then
@@ -46,8 +46,16 @@ src_configure() {
./configure
}
+src_compile() {
+ eninja
+}
+
+src_test() {
+ eninja test
+}
+
src_install() {
- default
+ DESTDIR="${ED}" eninja install
[[ "${PV}" == "9999" ]] || save_config config.h
}